Import www/nsm update

This commit is contained in:
nikita 2020-07-12 01:26:46 +02:00
parent 16c6717f34
commit 0a87351512
5 changed files with 89 additions and 0 deletions

13
nsm/DESCR Normal file
View File

@ -0,0 +1,13 @@
Nifty Site Manager ("nsm") is a cross-platform framework for managing
and generating websites. Some of its features are:
- it can manage and generate static and dynamic websites.
- it has support for pre/post build/serve scripts to integrate with
cURL, databases, SASS, Grunt, GraphQL, Python Web Server, Live
Server/Reload, and more.
- there is multithreading support
- it is language agnostic, you can use any language you want
(markdown, LATEX, html, xml, css, javascript, php, MySQL, etc)
- it integrates flawlessly with various Javascript and PHP frameworks
- it integrates with Git to clone from and push to various platforms
including AWS, BitBucket, GitHub, GitLab, Netlify, surge.sh, ZEIT Now, etc
- it has a templating system

42
nsm/Makefile Normal file
View File

@ -0,0 +1,42 @@
# $NetBSD: Makefile,v 1.7 2020/01/09 11:28:37 ng0 Exp $
DISTNAME= nsm-2.3.10
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GITHUB:=nifty-site-manager/}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= nikita@NetBSD.org
HOMEPAGE= https://nift.dev/
COMMENT= Cross-platform git- and LaTeX-like command-line website manager
LICENSE= mit
USE_LANGUAGES= c c++
USE_TOOLS+= gmake
INSTALLATION_DIRS= bin
# Avoid building 2 binaries with the exact same content
# where we can symlink instead. This safes 50 percent
# of the binary size and some double computation.
# closed upstream ticket:
# https://github.com/nifty-site-manager/nsm/issues/2
SUBST_CLASSES+= nift
SUBST_STAGE.nift= pre-configure
SUBST_FILES.nift= Makefile
SUBST_SED.nift= -e '/nift/ s,^,\#,g'
SUBST_SED.nift+= -e 's,/usr/local/lib,${PREFIX}/lib,g'
SUBST_SED.nift+= -e 's,CXXFLAGS=-std=c++11,CXXFLAGS+=-std=c++11,g'
SUBST_SED.nift+= -e 's,LINK=,LDFLAGS+=,g'
SUBST_SED.nift+= -e 's,LINK+=,LDFLAGS+=,g'
MAKE_ENV+= BUNDLED=0
MAKE_ENV+= LUA_VERSION=5.3
DL_AUTO_VARS= yes
post-install:
cd ${DESTDIR}${PREFIX}/bin && ${LN} -s nsm nift
.include "../../mk/dlopen.buildlink3.mk"
.include "../../lang/lua53/buildlink3.mk"
.include "../../lang/LuaJIT2/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
nsm/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2019/10/22 10:34:34 ng0 Exp $
bin/nift
bin/nsm

7
nsm/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.7 2020/01/09 11:28:37 ng0 Exp $
SHA1 (nsm-2.3.10.tar.gz) = cc9a04d17a0dc3969241b2ac4758664b335da7d8
RMD160 (nsm-2.3.10.tar.gz) = 627cbbba3e4bd1e5cfe92768ec2beef8e260ff74
SHA512 (nsm-2.3.10.tar.gz) = b329b71b4af87820d75ca82c6bb429c82088f2cae24acdfbbb7cf6ededfd54a91ad96ac605b57d359770faa3f9956745d822d08ed1c83a7678f4a2781e904492
Size (nsm-2.3.10.tar.gz) = 1607394 bytes
SHA1 (patch-Lua.h) = 8fef0e004e82728257acba9a420039e57f89a161

24
nsm/patches/patch-Lua.h Normal file
View File

@ -0,0 +1,24 @@
$NetBSD$
--- Lua.h.orig 2020-07-12 00:15:55.891842413 +0200
+++ Lua.h 2020-07-12 00:17:09.794282009 +0200
@@ -6,6 +6,11 @@
#include "StrFns.h"
+// Lua in pkgsrc can deal with this
+#include <lua.hpp>
+#include <lualib.h>
+#include <lauxlib.h>
+/*
#if defined __BUNDLED__
#if defined __LUA_VERSION_5_3__
#include "Lua-5.3/src/lua.hpp"
@@ -41,6 +44,7 @@
#include "/usr/local/include/luajit-2.1/lua.hpp"
#endif
#endif
+*/
void process_lua_error(std::string& errStr, int& errLineNo);