sfml+: update to sfml+-2.5.1

Changelog:

== SFML 2.5.1

Also available on the website: https://www.sfml-dev.org/changelog.php#sfml-2.5.1

=== General

  * Various CMake fixes (#1414, #1416, #1436, #1439, #1467, #1470)
  * Fixed the installation of pkg-config files (#1466)
  * Fixed two conversion warnings (#1454)
  * [Android] Fixes all symbols in sfml-main are hidden (#1457, #1460)
  * [Android] Fixed some `#define` flag problem (#1458)
  * [Android] Fix deadlock in main cleanup (#1265)
  * [iOS] Modernized toolchain file (#1411)
  * [iOS] Check that `<SFML/Main.hpp>` is used (#1412)
  * [macOS] Add `-ObjC` flag to fix static linking on macOS (#1485)

=== Window

**Bugfixes**

  * [iOS] Use default supported rotations when none are specified (#1417)
  * [iOS] Fixed autocomplete window overlaps keyboard (#1473, #1482)
  * [Linux] Fixed dual monitor issue (#1226, #1238)
  * [Linux] Fixed issue where fullscreen window didn't go over task bars on top and left on in Ubuntu (#1224)
  * [Linux] Fixed the Unix clipboard implementation causing an abort due to internal data races in Xlib (#1437)
  * [macOS] Added additional system cursors (#1401, #1413, #1425)
  * [Windows] Fixed swapped colors for custom cursors (#1464, #1465, #1491)

=== Graphics

**Bugfixes**

  * Fixed a bug in which a `sf::RenderTexture` would not be re-activated after being re-created (#1438)
  * Fixed `sf::RenderTextureImplFBO`'s destructor incorrectly triggering deletion of other `sf::RenderTextureImplFBO`'s active FBOs (#1440)
  * Fix `sf::RenderWindow::setActive` incorrectly trying to unbind an FBO during deactivation (#1442)
  * Fixed `sf::RenderTexture::display()` dereferencing a NULL pointer when being called before `sf::RenderTexture::create()` (#1446)
  * Fixed bug in `sf::Text` when applying an outline color/thickness (#1176)
  * Squash duplicated `sf::Font` glyphs to single chars (#1461)
  * Fixed two issues with glyph sub-pixel positioning (#1452)
  * Reduced context locking & unlocking while creating textures (#1459)
  * Fixed the error message when the wrong bitmap font size is selected (#1456, #1474, #1492)

=== Audio

**Bugfixes**

  * Fixed performance issue with reading WAV files (#1450)

== SFML 2.5.0

Also available on the website: https://www.sfml-dev.org/changelog.php#sfml-2.5.0

=== General

  * Replaced FindSFML.cmake with SFMLConfig.cmake (#1335)
  * Markdown'd and updated readme, changelog, contributing and license files (#1196, #1368, #1317)
  * Improve packaging support (#1173)
  * Added Tagfile generation and search (#1327)
  * Added CMake variables to select the modules to be built (#798, #800)
  * Do not install extlibs if `SFML_USE_SYSTEM_DEPS` is true (#1236, #1237)
  * Fixed various type conversion/comparison warnings (#1325)
  * [Android] Increased minimum API version to 14 (#1362)
  * [Android] Removed custom toolchain and added support for the newest NDK version and Gradle (#1350, #1393)
  * [iOS] Updated the binary libs from exlibs/libs-ios (#1207, #1209)
  * [iOS] Use a CMake toolchain file for iOS build (#1268, #1269)
  * [iOS] Install extlibs if needed (#1348)
  * [iOS] Drop 32 bit support (#1374)
  * [iOS] Force correct iOS architecture for cmake (#1373, #1377)
  * [iOS] Added iOS example (#1378)
  * [macOS] Fixed launch of cocoa examples (#1334)
  * [macOS] Improved application signing process (#1020, #1036, #1194)
  * [macOS] Improved CMake script (#1215, #1371)
  * [macOS] Use `-stdlib=libc++` (#1361)
  * [OpenBSD] Added support for OpenBSD (#1330)

=== System

**Bugfixes**

  * Added protected destructor to `sf::NonCopyable` to prevent possible resource leaks (#1125, #1161)
  * Fixed crash when `sf::Clock` is constructed in a global scope (#1258)

=== Window

**Features**

  * Implemented Cursor API (#269, #784, #827)
  * Implemented Clipboard API (#715, #1204, #1221)
  * Renamed a few key codes (#1395)
  * Added joystick example (#1363)
  * [Windows] Added support for interfacing with joysticks via DirectInput when it is available (#1251, #1326)
  * [Windows] Fix discrete GPU preference symbols being exported from the wrong place (#1192, #1406)

**Bugfixes**

  * [Android] Return correct key code for delete/backspace (#1309, #1362)
  * [iOS] Don't need to find vorbisfile or vorbisenc (#1347)
  * [Linux] Fixed `sf::Window::getPosition()` returning incorrect position because of differences in window managers (#1228, #1266)
  * [Linux] Fix X11 key repeat handling not filtering out events from other windows (#1223, #1230, #1291)
  * [Linux] Restore fullscreen of a non-visible window (#1339)
  * [macOS] Fixed window menu not working (#1091, #1180, #1193)
  * [macOS] Fixed crash with application messing hardware detection e.g. TeamViewer (#1323)
  * [macOS] Added support for (some) Hat/POV axis (#1248)
  * [Windows] Prevent uninitialized read by zeroing memory (#1264)
  * [Windows] Fixed modifier keys handling (#1357)

=== Graphics

**Features**

  * Implemented additional line spacing and letter spacing in `sf::Text` (#928, #1366)
  * Added `sf::VertexBuffer` class (#1308)
  * Added GPU local texture copying support, allowing performance optimizations and texture swapping (#1119, #1319, #1320)
  * Optimize performance by skipping `glTexCoordPointer()` call if not needed (#1015)
  * Generate shape outline vertices only if necessary (#925, #1356)
  * Removed dependency to libjpeg, stb_image_write now supports writing JPEG files (#1278, #1279)
  * Enable comparing `sf::Transform` and optimize resetting OpenGL back to the identity matrix (#1298)
  * Added missing `setActive()` virtual method to `sf::RenderTarget` (#1157)
  * Updated stb_image to v2.16 and stb_image_write to v1.07 (#1270)
  * Added `sf::RenderTexture` stencil and multisampling support (#1274, #1285)
  * Added example demonstrating `sf::VertexBuffer`, `sf::Shader` and `sf::Thread` usage (#1352)
  * Optimized `sf::RenderTexture` performance (#1379)

**Bugfixes**

  * Properly free memory in `sf::Font::cleanup()` (#1119)
  * Fixed memory leak in `sf::Font` (#1216)
  * Fix OpenGL texture coordinate pointer not being updated correctly under certain conditions (#1297)
  * Fix for broken text when the font is reloaded (#1345)
  * Fix memory leak in `sf::Text` (#1233, #1360)
  * Fixed strict aliasing punning warning when generating the key of a glyph in Font.cpp (#1187, #1396)
  * Fixed OpenGL version string being parsed incorrectly on some platforms (#1249, #1390)
  * [macOS] Worked around render target bug (#1132, #1342)
  * [Windows] Replaced time-based joystick poll with a hardware event handler (#1179, #1195, #1198, #1199, #1421)

=== Audio

**Features**

  * Added loop point support to `sf::Music` (#177, #629)
  * Added support for the extensible PCM wave file format (#1296)
  * [iOS] Enable audio module (#1338)

**Bugfixes**

  * Fixed inconsistent seek behavior in `sf::SoundStream` (#1118)
  * Fixed stack overflow in `sf::SoundStream::fillAndPushBuffer()` (#1154)
  * Fixed seeking quirks in the FLAC reader (#966, #1162)
  * Allow polymorphism with `sf::SoundSource` (#1185)
  * Fixed WAV file writer writing wrong header values (#1280, #1281)
  * Small bugfix to argument of `alcCaptureOpenDevice()` (#1304, #1305)
  * [iOS] Find OpenAL correctly (#1263, #1376)
  * [Windows] Updated OpenAL Soft to 1.18.1 fixing crashes (#1247, #1260)

=== Network

**Features**

  * Add append/overwrite parameter to Ftp::upload (#1072, #1399)

**Bugfixes**

  * Fixed wrong condition for building network support (#1253)
  * Changed TCP listen backlog from 0 to SOMAXCONN (#1369, #1407)
  * Fixed socket reuse not conforming to documentation (#1346, #1408)
This commit is contained in:
Yorick Hardy 2019-11-02 22:03:32 +02:00
parent 70438fec68
commit 0af231e4d4
16 changed files with 153 additions and 107 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.6 2015/02/24 17:25:10 blef Exp $
DISTNAME= SFML-2.4.2-sources
PKGNAME= sfml+-2.4.2
DISTNAME= SFML-2.5.1-sources
PKGNAME= sfml+-2.5.1
CATEGORIES= multimedia
MASTER_SITES= http://www.sfml-dev.org/files/
EXTRACT_SUFX= .zip
@ -11,7 +11,7 @@ HOMEPAGE= http://www.sfml-dev.org/
COMMENT= Free multimedia C++ API
LICENSE= zlib
WRKSRC= ${WRKDIR}/SFML-2.4.2
WRKSRC= ${WRKDIR}/SFML-2.5.1
USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_TOOLS+= rm

View File

@ -17,6 +17,7 @@ include/SFML/Audio/SoundRecorder.hpp
include/SFML/Audio/SoundSource.hpp
include/SFML/Audio/SoundStream.hpp
include/SFML/Config.hpp
include/SFML/GpuPreference.hpp
include/SFML/Graphics.hpp
include/SFML/Graphics/BlendMode.hpp
include/SFML/Graphics/CircleShape.hpp
@ -46,6 +47,7 @@ include/SFML/Graphics/Transform.hpp
include/SFML/Graphics/Transformable.hpp
include/SFML/Graphics/Vertex.hpp
include/SFML/Graphics/VertexArray.hpp
include/SFML/Graphics/VertexBuffer.hpp
include/SFML/Graphics/View.hpp
include/SFML/Main.hpp
include/SFML/Network.hpp
@ -88,8 +90,10 @@ include/SFML/System/Vector2.inl
include/SFML/System/Vector3.hpp
include/SFML/System/Vector3.inl
include/SFML/Window.hpp
include/SFML/Window/Clipboard.hpp
include/SFML/Window/Context.hpp
include/SFML/Window/ContextSettings.hpp
include/SFML/Window/Cursor.hpp
include/SFML/Window/Event.hpp
include/SFML/Window/Export.hpp
include/SFML/Window/GlResource.hpp
@ -102,21 +106,31 @@ include/SFML/Window/VideoMode.hpp
include/SFML/Window/Window.hpp
include/SFML/Window/WindowHandle.hpp
include/SFML/Window/WindowStyle.hpp
lib/cmake/SFML/SFMLConfig.cmake
lib/cmake/SFML/SFMLConfigDependencies.cmake
lib/cmake/SFML/SFMLConfigVersion.cmake
lib/cmake/SFML/SFMLSharedTargets-release.cmake
lib/cmake/SFML/SFMLSharedTargets.cmake
lib/libsfml-audio.so
lib/libsfml-audio.so.2.4
lib/libsfml-audio.so.2.4.2
lib/libsfml-audio.so.2.5
lib/libsfml-audio.so.2.5.1
lib/libsfml-graphics.so
lib/libsfml-graphics.so.2.4
lib/libsfml-graphics.so.2.4.2
lib/libsfml-graphics.so.2.5
lib/libsfml-graphics.so.2.5.1
lib/libsfml-network.so
lib/libsfml-network.so.2.4
lib/libsfml-network.so.2.4.2
lib/libsfml-network.so.2.5
lib/libsfml-network.so.2.5.1
lib/libsfml-system.so
lib/libsfml-system.so.2.4
lib/libsfml-system.so.2.4.2
lib/libsfml-system.so.2.5
lib/libsfml-system.so.2.5.1
lib/libsfml-window.so
lib/libsfml-window.so.2.4
lib/libsfml-window.so.2.4.2
share/SFML/cmake/Modules/FindSFML.cmake
share/SFML/license.txt
share/SFML/readme.txt
lib/libsfml-window.so.2.5
lib/libsfml-window.so.2.5.1
lib/pkgconfig/sfml-all.pc
lib/pkgconfig/sfml-audio.pc
lib/pkgconfig/sfml-graphics.pc
lib/pkgconfig/sfml-network.pc
lib/pkgconfig/sfml-system.pc
lib/pkgconfig/sfml-window.pc
share/SFML/license.md
share/SFML/readme.md

View File

@ -1,20 +1,22 @@
$NetBSD: distinfo,v 1.1 2012/10/03 15:05:59 othyro Exp $
SHA1 (SFML-2.4.2-sources.zip) = 9cb3cdf2f679a4979f71d36041c950a82a31178a
RMD160 (SFML-2.4.2-sources.zip) = 02c872a6937e59a710d3b1be97d7d2731b53f143
SHA512 (SFML-2.4.2-sources.zip) = 14f2b9f244bbff681d1992581f20012f3073456e4baed0fb2bf2cf82538e9c5ddd8ce01b0cfb3874af47091ec19654aa23c426df04fe1ffcfa209623dc362f85
Size (SFML-2.4.2-sources.zip) = 24961872 bytes
SHA1 (patch-CMakeLists.txt) = 562f20c12b99c394f8cb0f28d04fdf1f5d129c91
SHA1 (patch-cmake_Config.cmake) = 81e539daa3b13c2e93c31eec8de1f6177a2d6d43
SHA1 (patch-include_SFML_Config.hpp) = 2ef6d01309fa039804dbaa73258e6eee4cf6a5f7
SHA1 (patch-include_SFML_OpenGL.hpp) = 1320361b147b0baf5e882772ea5bcb7643680285
SHA1 (patch-include_SFML_Window_WindowHandle.hpp) = feb03e491f89c2b48e32956821d005f3b32d1cda
SHA1 (patch-src_SFML_System_CMakeLists.txt) = 2cfc1f05b414105549769c7658699972c9e88f86
SHA1 (patch-src_SFML_Window_CMakeLists.txt) = ebc3841486a587b006e03e2edc7c2a5a26cc3499
SHA1 (SFML-2.5.1-sources.zip) = a2d9d8ceed52bcff27d11f21e814b51ba19cd116
RMD160 (SFML-2.5.1-sources.zip) = 3b137887696a223f0c3576b16bae9f0e3535f16f
SHA512 (SFML-2.5.1-sources.zip) = 75b4f3076d817388b78aa060fba6a4c67b2cde3393ec6d9dc66052d9770636572e9bfcd6b63fcb5dc7888e00cda2161cd84b55e07d463159da52ac1142d8d1af
Size (SFML-2.5.1-sources.zip) = 23283095 bytes
SHA1 (patch-CMakeLists.txt) = 445189ad0ee05c3da0883877b86c1789c5571d2a
SHA1 (patch-cmake_Config.cmake) = 295f6112d21c3843d97ef6f603535259b26aae34
SHA1 (patch-include_SFML_Config.hpp) = c795545ce767f3641902368fb5e94715fd75f1a6
SHA1 (patch-include_SFML_OpenGL.hpp) = 520341b68b61a1afcc5cb8ad9023947a3da883c3
SHA1 (patch-include_SFML_Window_WindowHandle.hpp) = 3bb97d698b47d7df4c7333334c9708dcbb0697cb
SHA1 (patch-src_SFML_System_CMakeLists.txt) = 50a7a109d755b074508ae9628b0c971ceb384b20
SHA1 (patch-src_SFML_Window_CMakeLists.txt) = 4c468d54415df4d6925d98d6349d2da862aab29a
SHA1 (patch-src_SFML_Window_ClipboardImpl.hpp) = b7265c1f49a810b04635520d8e70bd58e4aecbe9
SHA1 (patch-src_SFML_Window_CursorImpl.hpp) = 0d5e55a80e1d01a6ec19b6a22d23f7e1a2d8deab
SHA1 (patch-src_SFML_Window_FreeBSD_JoystickImpl.cpp) = 46e882a29624d86043ab15c239e20e70a97c116b
SHA1 (patch-src_SFML_Window_FreeBSD_JoystickImpl.hpp) = a4eb1a07b937d0ad7677cff53b946a8d5a6546ab
SHA1 (patch-src_SFML_Window_GlContext.cpp) = 1419707c8b71e1bfdfd29f049b6aac418713ccd6
SHA1 (patch-src_SFML_Window_InputImpl.hpp) = 3cee9ad1eb3efe282f1044dfd1815a1a17323a1d
SHA1 (patch-src_SFML_Window_GlContext.cpp) = fe812c8e1c1757f4e9e266548921ae2979046a63
SHA1 (patch-src_SFML_Window_InputImpl.hpp) = 98e0f1b3712ba27d754bf32663718a6da71afbd6
SHA1 (patch-src_SFML_Window_JoystickImpl.hpp) = 1940c192f030f08c99d7982933f0d44cd5e4cc49
SHA1 (patch-src_SFML_Window_SensorImpl.hpp) = 0a8f349d1b57ff2fd980ee04ac66341c63eddf41
SHA1 (patch-src_SFML_Window_WindowImpl.cpp) = c60bb2ca5b6444977be41ae04416442f4fdf7f46
SHA1 (patch-src_SFML_Window_SensorImpl.hpp) = 4ed600254af277c7c45bb1b0ed39c0012b5e3d76
SHA1 (patch-src_SFML_Window_WindowImpl.cpp) = fa6966a56a21db3c17f4ea0cc2471d1da4878d1c

View File

@ -1,20 +1,22 @@
$NetBSD$
--- CMakeLists.txt.orig 2017-02-08 11:29:16.000000000 +0000
--- CMakeLists.txt.orig 2018-10-15 19:41:39.000000000 +0000
+++ CMakeLists.txt
@@ -202,11 +202,14 @@ if(SFML_OS_MACOSX)
set(XCODE_TEMPLATES_ARCH "\$(NATIVE_ARCH_ACTUAL)")
@@ -140,7 +140,7 @@ endif()
# For miscellaneous files
if(SFML_OS_WINDOWS OR SFML_OS_IOS)
set(DEFAULT_INSTALL_MISC_DIR .)
-elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
+elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OS_OPENBSD)
set(DEFAULT_INSTALL_MISC_DIR share/SFML)
elseif(SFML_OS_MACOSX)
set(DEFAULT_INSTALL_MISC_DIR /usr/local/share/SFML)
@@ -277,7 +277,7 @@ endif()
# on Linux and BSD-like OS, install pkg-config files by default
set(SFML_INSTALL_PKGCONFIG_DEFAULT FALSE)
-if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
+if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OS_OPENBSD)
set(SFML_INSTALL_PKGCONFIG_DEFAULT TRUE)
endif()
-if(SFML_OS_LINUX OR SFML_OS_FREEBSD)
+if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD)
set(PKGCONFIG_DIR lib${LIB_SUFFIX}/pkgconfig)
if(SFML_OS_FREEBSD)
set(PKGCONFIG_DIR libdata/pkgconfig)
endif()
+ if(SFML_OS_NETSD)
+ set(PKGCONFIG_DIR lib/pkgconfig)
+ endif()
if(BUILD_SHARED_LIBS)
sfml_set_option(SFML_INSTALL_PKGCONFIG_FILES FALSE BOOL "TRUE to automatically install pkg-config files so other projects can find SFML")
if(SFML_INSTALL_PKGCONFIG_FILES)

View File

@ -1,6 +1,6 @@
$NetBSD$
--- cmake/Config.cmake.orig 2017-02-08 11:29:16.000000000 +0000
--- cmake/Config.cmake.orig 2018-10-15 19:41:39.000000000 +0000
+++ cmake/Config.cmake
@@ -31,6 +31,10 @@ elseif(CMAKE_SYSTEM_NAME MATCHES "^k?Fre
set(SFML_OS_FREEBSD 1)
@ -10,15 +10,17 @@ $NetBSD$
+ set(SFML_OS_NETBSD 1)
+ # XXX we want to use OPENGL_ES for some NetBSD, but which?
+ set(OPENGL_ES 0)
elseif(${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
if(IOS)
set(SFML_OS_IOS 1)
@@ -116,7 +120,7 @@ endif()
# define the install directory for miscellaneous files
if(SFML_OS_WINDOWS OR SFML_OS_IOS)
set(INSTALL_MISC_DIR .)
-elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_MACOSX)
+elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OS_MACOSX)
set(INSTALL_MISC_DIR share/SFML)
elseif(SFML_OS_ANDROID)
set(INSTALL_MISC_DIR ${ANDROID_NDK}/sources/sfml)
elseif(CMAKE_SYSTEM_NAME MATCHES "^OpenBSD$")
set(SFML_OS_OPENBSD 1)
# don't use the OpenGL ES implementation on OpenBSD
@@ -77,6 +81,10 @@ if(SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
set(SFML_PKGCONFIG_DIR "/libdata/pkgconfig")
endif()
+if(SFML_OS_NETBSD)
+ set(SFML_PKGCONFIG_DIR "/lib/pkgconfig")
+endif()
+
# detect the compiler and its version
# Note: on some platforms (OS X), CMAKE_COMPILER_IS_GNUCXX is true
# even when CLANG is used, therefore the Clang test is done first

View File

@ -1,6 +1,6 @@
$NetBSD$
--- include/SFML/Config.hpp.orig 2015-08-24 16:01:06.000000000 +0000
--- include/SFML/Config.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ include/SFML/Config.hpp
@@ -86,6 +86,11 @@
// FreeBSD
@ -11,6 +11,6 @@ $NetBSD$
+ // NetBSD
+ #define SFML_SYSTEM_NETBSD
+
#else
#elif defined(__OpenBSD__)
// Unsupported UNIX system
// OpenBSD

View File

@ -1,13 +1,13 @@
$NetBSD$
--- include/SFML/OpenGL.hpp.orig 2015-08-24 16:01:06.000000000 +0000
--- include/SFML/OpenGL.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ include/SFML/OpenGL.hpp
@@ -45,7 +45,7 @@
#include <GL/gl.h>
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD)
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#if defined(SFML_OPENGL_ES)
#include <GLES/gl.h>

View File

@ -1,13 +1,13 @@
$NetBSD$
--- include/SFML/Window/WindowHandle.hpp.orig 2015-08-24 16:01:06.000000000 +0000
--- include/SFML/Window/WindowHandle.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ include/SFML/Window/WindowHandle.hpp
@@ -46,7 +46,7 @@ namespace sf
@@ -42,7 +42,7 @@ namespace sf
// Window handle is HWND (HWND__*) on Windows
typedef HWND__* WindowHandle;
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD)
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
// Window handle is Window (unsigned long) on Unix - X11
typedef unsigned long WindowHandle;

View File

@ -1,13 +1,13 @@
$NetBSD$
--- src/SFML/System/CMakeLists.txt.orig 2015-08-24 16:01:06.000000000 +0000
--- src/SFML/System/CMakeLists.txt.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/System/CMakeLists.txt
@@ -84,7 +84,7 @@ else()
endif()
@@ -90,7 +90,7 @@ sfml_add_library(sfml-system
SOURCES ${SRC} ${PLATFORM_SRC})
# build the list of external libraries to link
# setup dependencies
-if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_MACOSX)
+if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OS_MACOSX)
list(APPEND SYSTEM_EXT_LIBS pthread)
target_link_libraries(sfml-system PRIVATE pthread)
endif()
if(SFML_OS_LINUX)

View File

@ -1,17 +1,17 @@
$NetBSD$
--- src/SFML/Window/CMakeLists.txt.orig 2017-02-08 11:29:16.000000000 +0000
--- src/SFML/Window/CMakeLists.txt.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/CMakeLists.txt
@@ -69,7 +69,7 @@ if(SFML_OS_WINDOWS)
@@ -79,7 +79,7 @@ if(SFML_OS_WINDOWS)
# make sure that we use the Unicode version of the Win API functions
add_definitions(-DUNICODE -D_UNICODE)
-elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD)
+elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD)
-elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
+elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OS_OPENBSD)
set(PLATFORM_SRC
${SRCROOT}/Unix/Display.cpp
${SRCROOT}/Unix/Display.hpp
@@ -96,7 +96,7 @@ elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD)
${SRCROOT}/Unix/CursorImpl.hpp
${SRCROOT}/Unix/CursorImpl.cpp
@@ -110,7 +110,7 @@ elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD
${SRCROOT}/Unix/JoystickImpl.cpp
${SRCROOT}/Unix/JoystickImpl.hpp
)
@ -20,21 +20,21 @@ $NetBSD$
set(PLATFORM_SRC
${PLATFORM_SRC}
${SRCROOT}/FreeBSD/JoystickImpl.cpp
@@ -193,7 +193,7 @@ elseif(SFML_OS_ANDROID)
@@ -235,7 +235,7 @@ if ((NOT BUILD_SHARED_LIBS) AND SFML_OS_
endif()
# find external libraries
-if(SFML_OS_LINUX OR SFML_OS_FREEBSD)
+if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD)
find_package(X11 REQUIRED)
if(NOT X11_FOUND)
message(FATAL_ERROR "X11 library not found")
@@ -226,7 +226,7 @@ if(SFML_OS_WINDOWS)
list(APPEND WINDOW_EXT_LIBS winmm gdi32)
elseif(SFML_OS_LINUX)
list(APPEND WINDOW_EXT_LIBS ${X11_X11_LIB} ${X11_Xrandr_LIB} ${UDEV_LIBRARIES})
# find and setup usage for external libraries
-if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OPENBSD)
+if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OPENBSD)
sfml_find_package(X11 INCLUDE "X11_INCLUDE_DIR" LINK "X11_X11_LIB" "X11_Xrandr_LIB")
target_link_libraries(sfml-window PRIVATE X11)
endif()
@@ -277,7 +277,7 @@ if(SFML_OS_LINUX)
target_link_libraries(sfml-window PRIVATE UDev)
elseif(SFML_OS_WINDOWS)
target_link_libraries(sfml-window PRIVATE winmm gdi32)
-elseif(SFML_OS_FREEBSD)
+elseif(SFML_OS_FREEBSD OR SFML_OS_NETBSD)
list(APPEND WINDOW_EXT_LIBS ${X11_X11_LIB} ${X11_Xrandr_LIB} usbhid)
target_link_libraries(sfml-window PRIVATE usbhid)
elseif(SFML_OS_MACOSX)
list(APPEND WINDOW_EXT_LIBS "-framework Foundation -framework AppKit -framework IOKit -framework Carbon")
target_link_libraries(sfml-window PRIVATE "-framework Foundation" "-framework AppKit" "-framework IOKit" "-framework Carbon")

View File

@ -0,0 +1,13 @@
$NetBSD$
--- src/SFML/Window/ClipboardImpl.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/ClipboardImpl.hpp
@@ -32,7 +32,7 @@
#if defined(SFML_SYSTEM_WINDOWS)
#include <SFML/Window/Win32/ClipboardImpl.hpp>
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#include <SFML/Window/Unix/ClipboardImpl.hpp>
#elif defined(SFML_SYSTEM_MACOS)
#include <SFML/Window/OSX/ClipboardImpl.hpp>

View File

@ -0,0 +1,13 @@
$NetBSD$
--- src/SFML/Window/CursorImpl.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/CursorImpl.hpp
@@ -34,7 +34,7 @@
#include <SFML/Window/Win32/CursorImpl.hpp>
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#include <SFML/Window/Unix/CursorImpl.hpp>

View File

@ -1,13 +1,13 @@
$NetBSD$
--- src/SFML/Window/GlContext.cpp.orig 2015-08-24 16:01:06.000000000 +0000
--- src/SFML/Window/GlContext.cpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/GlContext.cpp
@@ -42,7 +42,7 @@
@@ -49,7 +49,7 @@
#include <SFML/Window/Win32/WglContext.hpp>
typedef sf::priv::WglContext ContextType;
- #elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD)
+ #elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD)
- #elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+ #elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#include <SFML/Window/Unix/GlxContext.hpp>
typedef sf::priv::GlxContext ContextType;

View File

@ -1,13 +1,13 @@
$NetBSD$
--- src/SFML/Window/InputImpl.hpp.orig 2015-08-24 16:01:06.000000000 +0000
--- src/SFML/Window/InputImpl.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/InputImpl.hpp
@@ -32,7 +32,7 @@
#if defined(SFML_SYSTEM_WINDOWS)
#include <SFML/Window/Win32/InputImpl.hpp>
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD)
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#include <SFML/Window/Unix/InputImpl.hpp>
#elif defined(SFML_SYSTEM_MACOS)
#include <SFML/Window/OSX/InputImpl.hpp>

View File

@ -1,13 +1,13 @@
$NetBSD$
--- src/SFML/Window/SensorImpl.hpp.orig 2015-08-24 16:01:06.000000000 +0000
--- src/SFML/Window/SensorImpl.hpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/SensorImpl.hpp
@@ -35,7 +35,7 @@
#include <SFML/Window/Win32/SensorImpl.hpp>
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD)
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#include <SFML/Window/Unix/SensorImpl.hpp>

View File

@ -1,13 +1,13 @@
$NetBSD$
--- src/SFML/Window/WindowImpl.cpp.orig 2015-08-24 16:01:06.000000000 +0000
--- src/SFML/Window/WindowImpl.cpp.orig 2018-10-15 19:41:39.000000000 +0000
+++ src/SFML/Window/WindowImpl.cpp
@@ -38,7 +38,7 @@
#include <SFML/Window/Win32/WindowImplWin32.hpp>
typedef sf::priv::WindowImplWin32 WindowImplType;
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD)
-#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_OPENBSD)
+#elif defined(SFML_SYSTEM_LINUX) || defined(SFML_SYSTEM_FREEBSD) || defined(SFML_SYSTEM_NETBSD) || defined(SFML_SYSTEM_OPENBSD)
#include <SFML/Window/Unix/WindowImplX11.hpp>
typedef sf::priv::WindowImplX11 WindowImplType;