flashrom: remove, newer version in HEAD

This commit is contained in:
nia 2020-01-23 01:18:45 +00:00
parent 37af1a1296
commit 0c6b3c4d4e
7 changed files with 0 additions and 123 deletions

View File

@ -822,7 +822,6 @@ SUBDIR+= firefox69-2019Q4
SUBDIR+= firehose
SUBDIR+= flam3-svn
SUBDIR+= flang-git
SUBDIR+= flashrom
SUBDIR+= flasm
SUBDIR+= flexdock
SUBDIR+= flexdump

View File

@ -1 +0,0 @@
Flashrom is a utility which can be used to detect, read, and write BIOS chips.

View File

@ -1,48 +0,0 @@
# $NetBSD: Makefile,v 1.9 2016/02/26 10:24:12 jperkin Exp $
#
DISTNAME= flashrom-0.9.9
PKGNAME= ${DISTNAME:S/-r/pre/}
CATEGORIES= sysutils
MASTER_SITES= http://download.flashrom.org/releases/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= jakllsch@NetBSD.org
HOMEPAGE= http://www.flashrom.org/
COMMENT= Universal (coreboot/LinuxBIOS) flash utility
LICENSE= gnu-gpl-v2
USE_TOOLS+= gmake pkg-config
.include "../../mk/bsd.prefs.mk"
.if ${MACHINE_ARCH} == "i386" || ${MACHINE_ARCH} == "x86_64"
DEPENDS+= dmidecode-[0-9]*:../../sysutils/dmidecode
.endif
SUBST_CLASSES.NetBSD+= pciutils
SUBST_CLASSES.SunOS+= pciutils
SUBST_FILES.pciutils= Makefile
SUBST_FILES.pciutils+= hwaccess.h
SUBST_MESSAGE.pciutils= adjusting pciutils headers
SUBST_STAGE.pciutils= pre-configure
SUBST_SED.pciutils+= -e 's,<pci/pci.h>,<pciutils/pci.h>,g'
.if ${OPSYS} == "NetBSD" || ${OPSYS} == "SunOS"
LDFLAGS+= -lpci
CPPFLAGS+= -I/${PREFIX}/include
.endif
LDFLAGS.SunOS+= -lsocket -lnsl
MAKE_ENV.SunOS+= WARNERROR=0
INSTALLATION_DIRS= sbin ${PKGMANDIR}/man8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/flashrom ${DESTDIR}${PREFIX}/sbin/flashrom
${INSTALL_MAN} ${WRKSRC}/flashrom.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8/flashrom.8
.include "../../devel/libftdi/buildlink3.mk"
.include "../../devel/libusb1/buildlink3.mk"
.include "../../sysutils/pciutils/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/10/23 15:56:19 jakllsch Exp $
man/man8/flashrom.8
sbin/flashrom

View File

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.10 2016/12/22 21:07:17 joerg Exp $
SHA1 (flashrom-0.9.9.tar.bz2) = f083c61dcfcb1c794d5238a479cb42aca33558cd
RMD160 (flashrom-0.9.9.tar.bz2) = 1dc23e946bfcd0381068a36c3c7d0fdd6f676e21
SHA512 (flashrom-0.9.9.tar.bz2) = 155445ce7acab97f91596aad704aa2211da1c3f71fb463fc65c621dfea41e44b5de7db801c5b5cfc37450e8a8cfed5b202553715d999710422c830a0c38ae153
Size (flashrom-0.9.9.tar.bz2) = 495199 bytes
SHA1 (patch-hwaccess.c) = 666c0266eaf94782ba8ce033b599f975a103932b
SHA1 (patch-platform.h) = efefdfcaa9e893c65b3b7e01b26a599d5c28a8df

View File

@ -1,31 +0,0 @@
$NetBSD: patch-hwaccess.c,v 1.1 2016/12/22 21:07:17 joerg Exp $
It is UB whether define() is not handled inside macro expansions.
--- hwaccess.c.orig 2016-03-06 22:32:16.000000000 +0000
+++ hwaccess.c
@@ -37,9 +37,21 @@
#error "Unknown operating system"
#endif
-#define USE_IOPL (IS_LINUX || IS_MACOSX || defined(__NetBSD__) || defined(__OpenBSD__))
-#define USE_DEV_IO (defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__))
-#define USE_IOPERM (defined(__gnu_hurd__))
+#if IS_LINUX || IS_MACOSX || defined(__NetBSD__) || defined(__OpenBSD__)
+#define USE_IOPL 1
+#else
+#define USE_IOPL 0
+#endif
+#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)
+#define USE_DEV_IO 1
+#else
+#define USE_DEV_IO 0
+#endif
+#if defined(__gnu_hurd__)
+#define USE_IOPERM 1
+#else
+#define USE_IOPERM 0
+#endif
#if USE_IOPERM
#include <sys/io.h>

View File

@ -1,31 +0,0 @@
$NetBSD$
Macro expansion producing 'defined' has undefined behavior
--- platform.h.orig 2016-02-25 20:10:26.000000000 +0000
+++ platform.h
@@ -25,9 +25,21 @@
#define __PLATFORM_H__ 1
// Helper defines for operating systems
-#define IS_LINUX (defined(__gnu_linux__) || defined(__linux__))
-#define IS_MACOSX (defined(__APPLE__) && defined(__MACH__)) /* yes, both. */
-#define IS_WINDOWS (defined(_WIN32) || defined(_WIN64) || defined(__WIN32__) || defined(__WINDOWS__))
+#if defined(__gnu_linux__) || defined(__linux__)
+#define IS_LINUX 1
+#else
+#define IS_LINUX 0
+#endif
+#if defined(__APPLE__) && defined(__MACH__) /* yes, both. */
+#define IS_MACOSX 1
+#else
+#define IS_MACOSX 0
+#endif
+#if defined(_WIN32) || defined(_WIN64) || defined(__WIN32__) || defined(__WINDOWS__)
+#define IS_WINDOWS 1
+#else
+#define IS_WINDOWS 0
+#endif
// Likewise for target architectures
#if defined (__i386__) || defined (__x86_64__) || defined(__amd64__)