routersploit: Update to 3.4.0

Changes:
3.4.0
-----
- Fixing setup.py resources
- Switching to pycroptodome
- Fixing communication API
- Adding exploits/routers/asus/asuswrt_lan_rce.py module
- Fixing exploits/routers/asus/infosvr_backdoor_rce.py module
- Adding credentials used by Mirai botnet
- Fixing 3com Officeconnect RCE module
- Fixing exploits/routers/billion/billion_5200w_rce.py module
- Fixing exploits/routers/cisco/catalyst_2960_rocem.py module
- Fixing exploits/routers/cisco/firepower_management60_rce.py module
- Fixing exploits/routers/dlink/dir_815_850l_rce.py module
- Fixing exploits/routers/multi/tcp_32764_rce.py module
- Fixing exploits/routers/ubiquiti/airos_6_x.py module
- Adding OptEncoder option
- Fixing use command issue
- Adding tests tests/exploits/cameras/cisco/test_video_surv_path_traversal.py
- Adding tests for modules default values
- Adding tests tests/exploits/routers/asus/test_infosvr_backdoor_rce.py
- Adding tests tests/exploits/routers/billion/test_billion_5200w_rce.py
- Adding tests tests/exploits/routers/cisco/test_firepower_management60_rce.py
- Adding tests tests/exploits/routers/cisco/test_secure_acs_bypass.py
- Adding tests tests/exploits/routers/dlink/test_dcs_930l_auth_rce.py
- Adding tests tests/exploits/routers/technicolor/test_tg784_authbypass.py
- Adding tests tests/exploits/routers/dlink/test_dsl_2730b_2780b_526b_dns_change.py
- Fixing exploits/routers/ipfire/ipfire_proxy_rce.py module
- Fixing exploits/routers/ipfire/ipfire_shellshock.py module
- Adding exploits/routers/linksys/eseries_themoon_rce.py module
This commit is contained in:
Leonardo Taccari 2018-12-22 23:43:34 +01:00
parent a4007ef120
commit 0ceff5155b
5 changed files with 57 additions and 38 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.4 2017/09/14 12:43:54 leot Exp $
DISTNAME= routersploit-3.3.0
DISTNAME= routersploit-3.4.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GITHUB:=threat9/}
GITHUB_TAG= v${PKGVERSION_NOREV}
@ -13,7 +13,7 @@ LICENSE= modified-bsd
DEPENDS+= ${PYPKGPREFIX}-future-[0-9]*:../../devel/py-future
DEPENDS+= ${PYPKGPREFIX}-requests-[0-9]*:../../devel/py-requests
DEPENDS+= ${PYPKGPREFIX}-paramiko-[0-9]*:../../security/py-paramiko
DEPENDS+= ${PYPKGPREFIX}-crypto-[0-9]*:../../security/py-crypto
DEPENDS+= ${PYPKGPREFIX}-cryptodome-[0-9]*:../../security/py-cryptodome
DEPENDS+= ${PYPKGPREFIX}-snmp-[0-9]*:../../wip/py-snmp
USE_LANGUAGES= # none
@ -22,18 +22,6 @@ REPLACE_PYTHON+= rsf.py
PYTHON_VERSIONS_INCOMPATIBLE= 27
#
# - Add a MANIFEST.in in order to install all routersploit/resources package
# data files
# - Add an (empty) __init__.py in order to correctly pick up Python code in
# routersploit/resources subdirectories
#
# Shared upstream via <https://github.com/threat9/routersploit/pull/494>
#
post-extract:
${CP} ${FILESDIR}/MANIFEST.in ${WRKSRC}
${RUN} cd ${WRKSRC} && ${TOUCH} routersploit/resources/__init__.py
.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -818,6 +818,12 @@ ${PYSITELIB}/routersploit/modules/exploits/cameras/brickcom/corp_network_cameras
${PYSITELIB}/routersploit/modules/exploits/cameras/brickcom/users_cgi_creds_disclosure.py
${PYSITELIB}/routersploit/modules/exploits/cameras/brickcom/users_cgi_creds_disclosure.pyc
${PYSITELIB}/routersploit/modules/exploits/cameras/brickcom/users_cgi_creds_disclosure.pyo
${PYSITELIB}/routersploit/modules/exploits/cameras/cisco/__init__.py
${PYSITELIB}/routersploit/modules/exploits/cameras/cisco/__init__.pyc
${PYSITELIB}/routersploit/modules/exploits/cameras/cisco/__init__.pyo
${PYSITELIB}/routersploit/modules/exploits/cameras/cisco/video_surv_path_traversal.py
${PYSITELIB}/routersploit/modules/exploits/cameras/cisco/video_surv_path_traversal.pyc
${PYSITELIB}/routersploit/modules/exploits/cameras/cisco/video_surv_path_traversal.pyo
${PYSITELIB}/routersploit/modules/exploits/cameras/dlink/__init__.py
${PYSITELIB}/routersploit/modules/exploits/cameras/dlink/__init__.pyc
${PYSITELIB}/routersploit/modules/exploits/cameras/dlink/__init__.pyo
@ -950,6 +956,9 @@ ${PYSITELIB}/routersploit/modules/exploits/routers/asmax/ar_804_gu_rce.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/asus/__init__.py
${PYSITELIB}/routersploit/modules/exploits/routers/asus/__init__.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/asus/__init__.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/asus/asuswrt_lan_rce.py
${PYSITELIB}/routersploit/modules/exploits/routers/asus/asuswrt_lan_rce.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/asus/asuswrt_lan_rce.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/asus/infosvr_backdoor_rce.py
${PYSITELIB}/routersploit/modules/exploits/routers/asus/infosvr_backdoor_rce.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/asus/infosvr_backdoor_rce.pyo
@ -1022,9 +1031,6 @@ ${PYSITELIB}/routersploit/modules/exploits/routers/cisco/ucs_manager_rce.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/cisco/unified_multi_path_traversal.py
${PYSITELIB}/routersploit/modules/exploits/routers/cisco/unified_multi_path_traversal.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/cisco/unified_multi_path_traversal.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/cisco/video_surv_path_traversal.py
${PYSITELIB}/routersploit/modules/exploits/routers/cisco/video_surv_path_traversal.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/cisco/video_surv_path_traversal.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/comtrend/__init__.py
${PYSITELIB}/routersploit/modules/exploits/routers/comtrend/__init__.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/comtrend/__init__.pyo
@ -1151,6 +1157,9 @@ ${PYSITELIB}/routersploit/modules/exploits/routers/linksys/1500_2500_rce.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/__init__.py
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/__init__.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/__init__.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/eseries_themoon_rce.py
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/eseries_themoon_rce.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/eseries_themoon_rce.pyo
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/smartwifi_password_disclosure.py
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/smartwifi_password_disclosure.pyc
${PYSITELIB}/routersploit/modules/exploits/routers/linksys/smartwifi_password_disclosure.pyo
@ -1519,6 +1528,12 @@ ${PYSITELIB}/tests/__init__.pyo
${PYSITELIB}/tests/conftest.py
${PYSITELIB}/tests/conftest.pyc
${PYSITELIB}/tests/conftest.pyo
${PYSITELIB}/tests/core/__init__.py
${PYSITELIB}/tests/core/__init__.pyc
${PYSITELIB}/tests/core/__init__.pyo
${PYSITELIB}/tests/core/test_option.py
${PYSITELIB}/tests/core/test_option.pyc
${PYSITELIB}/tests/core/test_option.pyo
${PYSITELIB}/tests/creds/__init__.py
${PYSITELIB}/tests/creds/__init__.pyc
${PYSITELIB}/tests/creds/__init__.pyo
@ -2194,6 +2209,12 @@ ${PYSITELIB}/tests/exploits/cameras/brickcom/test_corp_network_cameras_conf_disc
${PYSITELIB}/tests/exploits/cameras/brickcom/test_users_cgi_creds_disclosure.py
${PYSITELIB}/tests/exploits/cameras/brickcom/test_users_cgi_creds_disclosure.pyc
${PYSITELIB}/tests/exploits/cameras/brickcom/test_users_cgi_creds_disclosure.pyo
${PYSITELIB}/tests/exploits/cameras/cisco/__init__.py
${PYSITELIB}/tests/exploits/cameras/cisco/__init__.pyc
${PYSITELIB}/tests/exploits/cameras/cisco/__init__.pyo
${PYSITELIB}/tests/exploits/cameras/cisco/test_video_surv_path_traversal.py
${PYSITELIB}/tests/exploits/cameras/cisco/test_video_surv_path_traversal.pyc
${PYSITELIB}/tests/exploits/cameras/cisco/test_video_surv_path_traversal.pyo
${PYSITELIB}/tests/exploits/cameras/dlink/__init__.py
${PYSITELIB}/tests/exploits/cameras/dlink/__init__.pyc
${PYSITELIB}/tests/exploits/cameras/dlink/__init__.pyo
@ -2266,6 +2287,12 @@ ${PYSITELIB}/tests/exploits/routers/asmax/test_ar_804_gu_rce.pyo
${PYSITELIB}/tests/exploits/routers/asus/__init__.py
${PYSITELIB}/tests/exploits/routers/asus/__init__.pyc
${PYSITELIB}/tests/exploits/routers/asus/__init__.pyo
${PYSITELIB}/tests/exploits/routers/asus/test_asuswrt_lan_rce.py
${PYSITELIB}/tests/exploits/routers/asus/test_asuswrt_lan_rce.pyc
${PYSITELIB}/tests/exploits/routers/asus/test_asuswrt_lan_rce.pyo
${PYSITELIB}/tests/exploits/routers/asus/test_infosvr_backdoor_rce.py
${PYSITELIB}/tests/exploits/routers/asus/test_infosvr_backdoor_rce.pyc
${PYSITELIB}/tests/exploits/routers/asus/test_infosvr_backdoor_rce.pyo
${PYSITELIB}/tests/exploits/routers/asus/test_rt_n16_password_disclosure.py
${PYSITELIB}/tests/exploits/routers/asus/test_rt_n16_password_disclosure.pyc
${PYSITELIB}/tests/exploits/routers/asus/test_rt_n16_password_disclosure.pyo
@ -2299,6 +2326,9 @@ ${PYSITELIB}/tests/exploits/routers/bhu/test_bhu_urouter_rce.pyo
${PYSITELIB}/tests/exploits/routers/billion/__init__.py
${PYSITELIB}/tests/exploits/routers/billion/__init__.pyc
${PYSITELIB}/tests/exploits/routers/billion/__init__.pyo
${PYSITELIB}/tests/exploits/routers/billion/test_billion_5200w_rce.py
${PYSITELIB}/tests/exploits/routers/billion/test_billion_5200w_rce.pyc
${PYSITELIB}/tests/exploits/routers/billion/test_billion_5200w_rce.pyo
${PYSITELIB}/tests/exploits/routers/billion/test_billion_7700n4_password_disclosure.py
${PYSITELIB}/tests/exploits/routers/billion/test_billion_7700n4_password_disclosure.pyc
${PYSITELIB}/tests/exploits/routers/billion/test_billion_7700n4_password_disclosure.pyo
@ -2311,9 +2341,15 @@ ${PYSITELIB}/tests/exploits/routers/cisco/test_dpc2420_info_disclosure.pyo
${PYSITELIB}/tests/exploits/routers/cisco/test_firepower_management60_path_traversal.py
${PYSITELIB}/tests/exploits/routers/cisco/test_firepower_management60_path_traversal.pyc
${PYSITELIB}/tests/exploits/routers/cisco/test_firepower_management60_path_traversal.pyo
${PYSITELIB}/tests/exploits/routers/cisco/test_firepower_management60_rce.py
${PYSITELIB}/tests/exploits/routers/cisco/test_firepower_management60_rce.pyc
${PYSITELIB}/tests/exploits/routers/cisco/test_firepower_management60_rce.pyo
${PYSITELIB}/tests/exploits/routers/cisco/test_ios_http_authorization_bypass.py
${PYSITELIB}/tests/exploits/routers/cisco/test_ios_http_authorization_bypass.pyc
${PYSITELIB}/tests/exploits/routers/cisco/test_ios_http_authorization_bypass.pyo
${PYSITELIB}/tests/exploits/routers/cisco/test_secure_acs_bypass.py
${PYSITELIB}/tests/exploits/routers/cisco/test_secure_acs_bypass.pyc
${PYSITELIB}/tests/exploits/routers/cisco/test_secure_acs_bypass.pyo
${PYSITELIB}/tests/exploits/routers/cisco/test_ucm_info_disclosure.py
${PYSITELIB}/tests/exploits/routers/cisco/test_ucm_info_disclosure.pyc
${PYSITELIB}/tests/exploits/routers/cisco/test_ucm_info_disclosure.pyo
@ -2332,6 +2368,9 @@ ${PYSITELIB}/tests/exploits/routers/comtrend/test_ct_5361t_password_disclosure.p
${PYSITELIB}/tests/exploits/routers/dlink/__init__.py
${PYSITELIB}/tests/exploits/routers/dlink/__init__.pyc
${PYSITELIB}/tests/exploits/routers/dlink/__init__.pyo
${PYSITELIB}/tests/exploits/routers/dlink/test_dcs_930l_auth_rce.py
${PYSITELIB}/tests/exploits/routers/dlink/test_dcs_930l_auth_rce.pyc
${PYSITELIB}/tests/exploits/routers/dlink/test_dcs_930l_auth_rce.pyo
${PYSITELIB}/tests/exploits/routers/dlink/test_dir_300_320_600_615_info_disclosure.py
${PYSITELIB}/tests/exploits/routers/dlink/test_dir_300_320_600_615_info_disclosure.pyc
${PYSITELIB}/tests/exploits/routers/dlink/test_dir_300_320_600_615_info_disclosure.pyo
@ -2368,6 +2407,9 @@ ${PYSITELIB}/tests/exploits/routers/dlink/test_dns_320l_327l_rce.pyo
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2730_2750_path_traversal.py
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2730_2750_path_traversal.pyc
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2730_2750_path_traversal.pyo
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2730b_2780b_526b_dns_change.py
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2730b_2780b_526b_dns_change.pyc
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2730b_2780b_526b_dns_change.pyo
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2750b_info_disclosure.py
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2750b_info_disclosure.pyc
${PYSITELIB}/tests/exploits/routers/dlink/test_dsl_2750b_info_disclosure.pyo
@ -2422,6 +2464,9 @@ ${PYSITELIB}/tests/exploits/routers/ipfire/test_ipfire_shellshock.pyo
${PYSITELIB}/tests/exploits/routers/linksys/__init__.py
${PYSITELIB}/tests/exploits/routers/linksys/__init__.pyc
${PYSITELIB}/tests/exploits/routers/linksys/__init__.pyo
${PYSITELIB}/tests/exploits/routers/linksys/test_eseries_themoon_rce.py
${PYSITELIB}/tests/exploits/routers/linksys/test_eseries_themoon_rce.pyc
${PYSITELIB}/tests/exploits/routers/linksys/test_eseries_themoon_rce.pyo
${PYSITELIB}/tests/exploits/routers/linksys/test_smartwifi_password_disclosure.py
${PYSITELIB}/tests/exploits/routers/linksys/test_smartwifi_password_disclosure.pyc
${PYSITELIB}/tests/exploits/routers/linksys/test_smartwifi_password_disclosure.pyo
@ -2509,6 +2554,9 @@ ${PYSITELIB}/tests/exploits/routers/technicolor/test_tc7200_password_disclosure.
${PYSITELIB}/tests/exploits/routers/technicolor/test_tc7200_password_disclosure_v2.py
${PYSITELIB}/tests/exploits/routers/technicolor/test_tc7200_password_disclosure_v2.pyc
${PYSITELIB}/tests/exploits/routers/technicolor/test_tc7200_password_disclosure_v2.pyo
${PYSITELIB}/tests/exploits/routers/technicolor/test_tg784_authbypass.py
${PYSITELIB}/tests/exploits/routers/technicolor/test_tg784_authbypass.pyc
${PYSITELIB}/tests/exploits/routers/technicolor/test_tg784_authbypass.pyo
${PYSITELIB}/tests/exploits/routers/thomson/__init__.py
${PYSITELIB}/tests/exploits/routers/thomson/__init__.pyc
${PYSITELIB}/tests/exploits/routers/thomson/__init__.pyo

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.3 2017/09/14 12:43:54 leot Exp $
SHA1 (routersploit-3.3.0.tar.gz) = dab95597688bdf1bdf22e7ae9a26ecb01414158e
RMD160 (routersploit-3.3.0.tar.gz) = eaa39a4753c874b1ed438811af660afc6b9395ee
SHA512 (routersploit-3.3.0.tar.gz) = fc43c9df65a543f6fff95a2e6b3c65f1c96e06bcfbe7c6d6b6fc319a2c57f57a999ca9f320e3cbba335f470ac4d8d4cacc7712b44c25888d80ac85355bc0136e
Size (routersploit-3.3.0.tar.gz) = 454798 bytes
SHA1 (routersploit-3.4.0.tar.gz) = a614706c1367fa576e55642d4696faec205d66d8
RMD160 (routersploit-3.4.0.tar.gz) = a568e886b85896d574065c9b04b96471253606b0
SHA512 (routersploit-3.4.0.tar.gz) = 9182598105c4d1c971dc63ac24059469dd1862af204f59994cfc85012091663a85faee4c7c04cce573eef1fa91525b44a3963b8c24460d3b31595c4ef6a6c4e5
Size (routersploit-3.4.0.tar.gz) = 465082 bytes
SHA1 (patch-setup.py) = b58c5b6a56036cfd27a7ae3fc2262fcebe767893

View File

@ -1,3 +0,0 @@
recursive-include routersploit/resources/ssh_keys *.json *.key
recursive-include routersploit/resources/vendors *.dat
recursive-include routersploit/resources/wordlists *.txt

View File

@ -1,14 +0,0 @@
$NetBSD$
Install rsf.py.
--- setup.py.orig 2018-07-09 19:09:31.000000000 +0000
+++ setup.py
@@ -15,6 +15,7 @@ setup(
download_url="https://github.com/threat9/routersploit/",
packages=find_packages(),
include_package_data=True,
+ scripts=('rsf.py',),
entry_points={},
install_requires=[
"future",