neko: avoid uselocale on netbsd

This commit is contained in:
Maya Rashish 2019-11-02 17:00:14 +02:00
parent 610a727cff
commit 110db68b65
2 changed files with 16 additions and 0 deletions

View File

@ -5,3 +5,4 @@ RMD160 (neko-2.2.0.tar.gz) = a91e97a7234e4d8d54156f38cb6192d61296d399
SHA512 (neko-2.2.0.tar.gz) = 4bc89fddf4a5ae94e73843b06a3b6fe8de59d72922764276a5bd9d56daf6570525e842039bf704598b41e1de4a5fe08931adc4ca9730fe3333be0beb7a1ccaed
Size (neko-2.2.0.tar.gz) = 510643 bytes
SHA1 (patch-CMakeLists.txt) = 76c56efa8c8f5a2f6d04932085592c606dee03c5
SHA1 (patch-libs_std_sys.c) = a4fd0296d8716ced3e62b041ffa3caf44278bd73

View File

@ -0,0 +1,15 @@
$NetBSD$
Workaround no uselocale on netbsd. (there's setlocale, though)
--- libs/std/sys.c.orig 2017-12-19 06:38:08.000000000 +0000
+++ libs/std/sys.c
@@ -133,7 +133,7 @@ static value sys_sleep( value f ) {
<doc>Set the locale for LC_TIME, returns true on success</doc>
**/
static value set_time_locale( value l ) {
-#ifdef NEKO_POSIX
+#if defined(NEKO_POSIX) && !defined(__NetBSD__)
locale_t lc, old;
val_check(l,string);
lc = newlocale(LC_TIME_MASK,val_string(l),NULL);