rawdog: update to rawdog-2.23

- rawdog 2.23

rawdog now requires Python 2.7. Python 2.6 doesn't build with current
toolchains, and hasn't been included in Debian for several releases, so
I can't test against it any more.

When automatically updating the config file in response to an HTTP
redirect fails, produce a more sensible error message (including the URL
of the feed in question).

Add the --find option, which shows what feedscanner returns for a given
URL (as --dump does for feedparser).

The location of BASE_OPTIONS has changed in pytidylib 0.3.2; rather than
trying to change it, override the corresponding options explicitly.
The meaning of tidylib's wrap option has also changed, so set a sensible
default value.

Support the current development version of feedparser (which will
presumably be the 5.3 release eventually), which has been restructured
into multiple modules, and raises network exceptions (e.g. timeouts)
directly from feedparser.parse rather than putting them in
bozo_exception.

rawdog's exception-handling code has been cleaned up as a result of the
above, and should work consistently for old and new versions of
feedparser. In the feedparser result dict, "bozo_exception" is now
converted to "rawdog_exception" for network errors, and "rawdog_timeout"
is set if a timeout exception occurred. For compatibility with existing
plugins, an empty "feed" is also provided on a timeout.

Update COPYING and the GPL v2 license notices to the FSF's current
recommended text.
This commit is contained in:
Yorick Hardy 2018-12-30 22:32:59 +02:00
parent 843fd81e66
commit 14dbc53d77
3 changed files with 9 additions and 9 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD$
DISTNAME= rawdog-2.22
DISTNAME= rawdog-2.23
CATEGORIES= news
MASTER_SITES= http://offog.org/files/

View File

@ -1,7 +1,7 @@
$NetBSD$
SHA1 (rawdog-2.22.tar.gz) = 024084f32102b047598a2034b5aad767a6093971
RMD160 (rawdog-2.22.tar.gz) = 83005768f0d986572b5602b2ab01a1697d882040
SHA512 (rawdog-2.22.tar.gz) = 27d4140713b0bc5fd6acf70e0377653266422e74201bb895b622a1abe03607704bf16e83a8135f9b0594b8f9566b84fc969c6f197f26d2e463dc5821fd5816d4
Size (rawdog-2.22.tar.gz) = 68777 bytes
SHA1 (patch-setup.py) = 819de407c40e2b5711aa0c474201bef600cef9dc
SHA1 (rawdog-2.23.tar.gz) = 171520c909fae81ac8ec0e063e7ca36593aae372
RMD160 (rawdog-2.23.tar.gz) = 16f24b14db39805554bc27e3daf678fcc941f989
SHA512 (rawdog-2.23.tar.gz) = ab3406b2dff754e425ce22bc1fe0c4773a43babe7b10bfb63e38b545baa1ea00e8cba62d106d3d9724809df3eb78efd9cbde12923443858031953099ea191e56
Size (rawdog-2.23.tar.gz) = 69542 bytes
SHA1 (patch-setup.py) = fd31cbe4ec9d87a8721a9ef832e36d1b917650a9

View File

@ -2,7 +2,7 @@ $NetBSD$
Fix manual page directory.
--- setup.py.orig 2016-10-11 18:38:08.000000000 +0000
--- setup.py.orig 2018-12-26 10:06:37.000000000 +0000
+++ setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
@ -11,8 +11,8 @@ Fix manual page directory.
-import sys
+import sys, os
if sys.version_info < (2, 6) or sys.version_info >= (3,):
print("rawdog requires Python 2.6 or later, and not Python 3.")
if sys.version_info < (2, 7) or sys.version_info >= (3,):
print("rawdog requires Python 2.7 or later, and not Python 3.")
@@ -14,7 +14,7 @@ setup(name="rawdog",
author_email="ats@offog.org",
url="http://offog.org/code/rawdog/",