audacity-cmake: fix a compilation warning

Fix some dependencies.

Still fails to build

/scratch/wip/audacity-cmake/work/audacity-Audacity-2.4.2/src/AboutDialog.cpp:66:10: fatal error: RevisionIdent.h: No such file or directory
 #include <RevisionIdent.h>
          ^~~~~~~~~~~~~~~~~
This commit is contained in:
Thomas Klausner 2020-06-29 20:55:46 +02:00
parent cc14441ce8
commit 1522010205
4 changed files with 26 additions and 2 deletions

View File

@ -13,6 +13,8 @@ LICENSE= gnu-gpl-v2 # AND cc-by-v3.0-license
WRKSRC= ${WRKDIR}/audacity-${GITHUB_PROJECT}-${PKGVERSION_NOREV}
BUILD_DEPENDS+= nasm-[0-9]*:../../devel/nasm
USE_CMAKE= yes
USE_TOOLS+= pkg-config msgfmt msgmerge
USE_LANGUAGES= c c++
@ -48,6 +50,8 @@ CMAKE_ARGS+= -Daudacity_use_twolame=system
CMAKE_ARGS+= -Daudacity_use_vamp=system
CMAKE_ARGS+= -Daudacity_use_vorbis=system
CMAKE_ARGS+= -Daudacity_use_wxwidgets=system
# pre-compiled headers don't work well on some systems
CMAKE_ARGS+= -Daudacity_use_pch=no
CMAKE_ARGS+= -DLIB_avcodec=${PREFIX}/lib/ffmpeg4/libavcodec.so
CMAKE_ARGS+= -DLIB_avformat=${PREFIX}/lib/ffmpeg4/libavformat.so
@ -78,7 +82,7 @@ CXXFLAGS+= -march=i586
CFLAGS.SunOS+= -fPIC
PYTHON_VERSIONS_ACCEPTED= 27
PYTHON_VERSIONS_INCOMPATIBLE= 27
PYTHON_FOR_BUILD_ONLY= tool
pre-configure:

View File

@ -1 +1,5 @@
Fails to start.
Fails to compile:
/scratch/wip/audacity-cmake/work/audacity-Audacity-2.4.2/src/AboutDialog.cpp:66:10: fatal error: RevisionIdent.h: No such file or directory
#include <RevisionIdent.h>
^~~~~~~~~~~~~~~~~

View File

@ -12,6 +12,7 @@ SHA1 (patch-cmake-proxies_portmidi_CMakeLists.txt) = 661dd5714908299fea9b8612a76
SHA1 (patch-lib-src_header-substitutes_allegro.h) = e25aa6f348eb52f500099ce829347b7601ba13be
SHA1 (patch-lib-src_libnyquist_nyquist_cmupv_src_cmupv.c) = 3d6cb845d82b1bcbe31dabd4bad30cb1f7ea27d5
SHA1 (patch-lib-src_libnyquist_nyquist_sys_unix_switches.h) = d313f137f11d3e0fafa383ddeccbc89021e9ddee
SHA1 (patch-lib-src_libnyquist_nyquist_xlisp_security.c) = 2712a9b0a89a0154fe6b2c59cbd3ad3654d6c3d2
SHA1 (patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h) = 2d4558f059d86633a1fcdda22ef0c914758b35a0
SHA1 (patch-src_AudioIO.cpp) = 1b44c68c4233b24a5fa4e17515eb237fee0e283a
SHA1 (patch-src_CMakeLists.txt) = 7f88c6433e70b900d401f04871a4591b6c991983

View File

@ -0,0 +1,15 @@
$NetBSD$
unistd is also needed on NetBSD.
--- lib-src/libnyquist/nyquist/xlisp/security.c.orig 2020-06-19 15:16:47.000000000 +0000
+++ lib-src/libnyquist/nyquist/xlisp/security.c
@@ -4,7 +4,7 @@
*/
#include <stdlib.h>
-#if defined(UNIX) || defined(__APPLE__) || defined(__CYGWIN__)
+#if defined(UNIX) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__NetBSD__)
#include <unistd.h>
#endif
#ifdef WIN32