mosquitto: Adjust man installation paths

Use the GNU coding standards module, and use the standard variable.
This commit is contained in:
Greg Troxel 2018-10-08 21:28:09 -04:00
parent ca0d17456a
commit 1621506e25
3 changed files with 19 additions and 9 deletions

View File

@ -22,10 +22,10 @@ USE_TOOLS+= gmake
post-extract:
${RM} ${WRKSRC}/config.mk
CONF_FILES= share/examples/mosquitto/pskfile.example \
share/examples/mosquitto/pwfile.example \
share/examples/mosquitto/mosquitto.conf \
share/examples/mosquitto/aclfile.example
CONF_FILES= ${PREFIX}/share/examples/mosquitto/pskfile.example \
${PREFIX}/share/examples/mosquitto/pwfile.example \
${PREFIX}/share/examples/mosquitto/mosquitto.conf \
${PREFIX}/share/examples/mosquitto/aclfile.example
SUBST_CLASSES+= ldconfig

View File

@ -4,7 +4,7 @@ SHA1 (mosquitto-1.5.3.tar.gz) = f61a2fcf814c3c1c28320be2a71d04e5dbbe28b1
RMD160 (mosquitto-1.5.3.tar.gz) = 91b6695d40742db02d6243716e494ae1044dc3ca
SHA512 (mosquitto-1.5.3.tar.gz) = 8aa4f85914316c2dc08908a649779946ab33b23ea669c6f7eed0d8a1af7ae26381cfe1a50c32d220658f8693ef6a86045690824af4b7ca0271426ff3455e7796
Size (mosquitto-1.5.3.tar.gz) = 425844 bytes
SHA1 (patch-CMakeLists.txt) = c23d6f014f64603dc0120ef74694fec6ee161215
SHA1 (patch-CMakeLists.txt) = b440be07073a7603d8740abece10afd43a541b22
SHA1 (patch-lib_CMakeLists.txt) = 9ab510e09f5099e595129b8bacf1a348b0868271
SHA1 (patch-mosquitto.conf) = faa7e77c30a58105bd678d510f1f545345f6ce0b
SHA1 (patch-src_CMakeLists.txt) = 908f439f7e04d31f5e7ab7ab2ee5b6e5ff23145d

View File

@ -1,10 +1,20 @@
$NetBSD$
In cmake build, adjust paths to pkgsrc norms. (From OpenBSD.)
In cmake build, adjust paths to pkgsrc norms. (Originally from
OpenBSD.)
--- CMakeLists.txt.orig 2018-08-16 16:05:26.000000000 +0000
--- CMakeLists.txt.orig 2018-09-25 15:27:43.000000000 +0000
+++ CMakeLists.txt
@@ -30,17 +30,12 @@ if (WIN32)
@@ -15,6 +15,8 @@ set (VERSION 1.5.3)
add_definitions (-DCMAKE -DVERSION=\"${VERSION}\")
+include(GNUInstallDirs)
+
if (WIN32)
set (BINDIR .)
set (SBINDIR .)
@@ -30,17 +32,12 @@ if (WIN32)
else (WIN32)
set (BINDIR bin)
set (SBINDIR sbin)
@ -20,7 +30,7 @@ In cmake build, adjust paths to pkgsrc norms. (From OpenBSD.)
set (INCLUDEDIR include)
set (DATAROOTDIR share)
- set (MANDIR "${DATAROOTDIR}/man")
+ set (MANDIR "man")
+ set (MANDIR ${CMAKE_INSTALL_MANDIR})
set (SHAREDIR "${DATAROOTDIR}/mosquitto")
set (PKGCONFIGDIR "${LIBDIR}/pkgconfig")
endif (WIN32)