dosbox-x: update to dosbox-x-0.82.17

0.82.17
  - Fixed yellowish tint of tv3x scaler on SDL1 builds of
    Mac OS X.
  - Fixed hq2x/hq3x and the various sai render scalers to
    render correctly on SDL1 builds of Mac OS X (where the
    odd BGRA color order is used). Prior to this fix the
    scaler output had a very strong yellow tint (missing
    or misrendered blue channel).
  - Fixed basic scaler template code to render correct RGBA
    colors in SDL1 builds for Mac OS X.
  - New grayscale scaler option, to emulate monochrome VGA
    monitors (frank-deng)
  - Menu handling cleanup from within Pause loop, including
    Mac OS X menu problems when invoking pause from the
    menu bar.
  - Shell welcome text fixed to show consistent first line in
    both IBM PC and PC-98 mode.
  - Pause mode fixed to handle mouse input while paused, so that
    SDL drawn menus (on Linux or HX DOS) continue to work while
    paused.
  - Added dosbox.conf option (off by default) to add the
    NEC PC-98 copyright string at E800:0DD8 for games and
    applications that require it.
  - Debugger can now show guest MS-DOS kernel MCB chain if you
    boot an MS-DOS floppy or hard disk image using
    BOOT --boothax msdos. For use with MS-DOS 3.3 or higher
    including the real mode MS-DOS environment of Windows 95.

    WARNING: Use boothax msdos ONLY with real mode MS-DOS, do
    not use with the protected mode environment (desktop) of
    Windows 95 especially a DOS VM within Windows. Use with
    MS-DOS and a DOS extender (DOS4GW, etc) should be OK.

  - Added "--boothax <mode>" option to BOOT command. At this
    time <mode> is limited to "msdos" to instruct the emulation
    to intercept specific INT 21h calls to locate the MS-DOS
    kernel's List of List and MCB chain structures for use with
    the debugger.
  - "TV" scaler updated to render dimmer alternate scanlines
    in CGA graphics modes (frank-deng)
  - Direct3D output no longer leaves DOS screen frozen when
    Direct3D device is "lost" (such as hitting CTRL+ALT+DEL
    to bring up the Windows C+A+D screen).
  - Page fault handling on by default now for dynamic core,
    DOS games and Windows 3.1 seem to handle it OK.
  - Page fault handling no longer use non-recursive page fault
    method with dynamic core, no matter what. It's too unreliable.
  - PC-98 mode now switches PIT Timer 2 clock gate ON by default
    to satisfy delay loops in Sunsoft "Photo Genic" and allow it
    to run. Note that PIT Timer 2 drives the baud rate clock of
    the RS-232C port.
  - IDE emulation bug fixed that prevented BIOS to IDE
    geometry translation when BIOS head count == 255. This
    fix also allows Windows 95 to use it's IDE driver with
    >= 4GB hard drives instead of running in MS-DOS compatibility
    mode.
  - Disk image support fixed to allow 4GB or larger hard disk
    images to work again.
  - FPU x86 core no longer calls E_Exit if the FPU stack
    overflows or underflows.
  - Updated build-debug scripts to accept "32" on the command
    line as a sign to compile 32-bit (i686) on a 64-bit (x86_64)
    system. You will need a multilib-capable GCC and 32-bit
    libraries installed on your system for this to work.
  - SDL2 OpenGL fixed color order issue
  - OpenGL is now supported in SDL2 builds.
  - Changed MPU-401 reset duration (DOSBox SVN).
This commit is contained in:
Yorick Hardy 2019-04-07 11:25:01 +02:00
parent ca60a73833
commit 163e000877
4 changed files with 21 additions and 21 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD$
GITHUB_PROJECT= dosbox-x
PKGNAME= dosbox-x-0.82.16
PKGNAME= dosbox-x-0.82.17
DISTNAME= ${GITHUB_TAG}
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GITHUB:=joncampbell123/}

View File

@ -1,9 +1,9 @@
$NetBSD$
SHA1 (dosbox-x-v0.82.16.tar.gz) = bd267fc691da294a34e4a8cc9374d35eff982534
RMD160 (dosbox-x-v0.82.16.tar.gz) = 6eaef94d111a3d9c6a708902e07f95f2b4c1c0be
SHA512 (dosbox-x-v0.82.16.tar.gz) = 31aeb4123b7af63d564f9dbb8715fffdfd64ab9719a10e806cf3beab005605e2918335cbf58a610cc858986e48b4387295ea132b7227784fd6eeb4ce94bd66ac
Size (dosbox-x-v0.82.16.tar.gz) = 36623732 bytes
SHA1 (patch-configure.ac) = a4d8074596a186227bfefe51d5443dd45e6cb719
SHA1 (dosbox-x-v0.82.17.tar.gz) = d24e45e20f5ef9a62debfc67936eecd6bd1d4671
RMD160 (dosbox-x-v0.82.17.tar.gz) = 7ba64a200e769e7a31796d8d489a4f4eea3369ed
SHA512 (dosbox-x-v0.82.17.tar.gz) = 721b6421d2ad8ed7197e6a7edf905f47e42069706d9ab1c85c46ab6beef971e73e0b25c02330e0df716ec52078d535fd04bf9c3402c8ea0740c67a4f9b2317fa
Size (dosbox-x-v0.82.17.tar.gz) = 35987890 bytes
SHA1 (patch-configure.ac) = 9f4501c638557deed0757d08e4db5298a2622bfc
SHA1 (patch-include_byteorder.h) = 86eccfbc2318ddc8d71a6de8723947a48d98a126
SHA1 (patch-include_dos__inc.h) = a2b8589b7dcb4430267af7948b0d31d3c4aca2c9
SHA1 (patch-include_dos__inc.h) = 26ba2b11dcfa923085f3745b0f8aca542f5dc692

View File

@ -2,7 +2,7 @@ $NetBSD$
Fix == test in configure script.
--- configure.ac.orig 2019-03-02 01:06:32.000000000 +0000
--- configure.ac.orig 2019-04-06 04:12:19.000000000 +0000
+++ configure.ac
@@ -171,7 +171,7 @@ CFLAGS=["`echo $CFLAGS' ' | sed -e 's/-O
CXXFLAGS=["`echo $CXXFLAGS' ' | sed -e 's/-O[^ ]* //g'`"]
@ -85,7 +85,7 @@ Fix == test in configure script.
dnl NASM (Netwide Assembler)
AC_PATH_PROG([NASM], [nasm])
@@ -1005,7 +1005,7 @@ else
@@ -1000,7 +1000,7 @@ else
AC_MSG_RESULT(no)
fi

View File

@ -2,16 +2,16 @@ $NetBSD$
Use ftello and fseeko on NetBSD.
--- include/dos_inc.h.orig 2018-06-01 19:29:54.000000000 +0000
--- include/dos_inc.h.orig 2019-04-06 04:12:19.000000000 +0000
+++ include/dos_inc.h
@@ -295,6 +295,10 @@ static INLINE Bit16u DOS_PackDate(Bit16u
#define ftello64 ftell
#define fseeko64 fseek
#endif
+#elif defined(__NetBSD__)
+ #define fopen64 fopen
+ #define ftello64 ftello
+ #define fseeko64 fseeko
#endif
/* Dos Error Codes */
@@ -290,6 +290,10 @@ static INLINE Bit16u DOS_PackDate(Bit16u
#define fopen64 fopen
#define ftello64 ftello
#define fseeko64 fseeko
+#elif defined (__NetBSD__)
+ #define fopen64 fopen
+ #define ftello64 ftello
+ #define fseeko64 fseeko
#elif defined (_MSC_VER)
#define fopen64 fopen
#if (_MSC_VER >= 1400)