endless-sky: import endless-sky-0.9.8 as wip/endless-sky

Explore other star systems. Earn money by trading, carrying
passengers, or completing missions. Use your earnings to buy a
better ship or to upgrade the weapons and engines on your current
one. Blow up pirates. Take sides in a civil war. Or leave human
space behind and hope to find some friendly aliens whose culture
is more civilized than your own...

Endless Sky is a sandbox-style space exploration game similar to
Elite, Escape Velocity, or Star Control. You start out as the
captain of a tiny space ship and can choose what to do from there.
The game includes a major plot line and many minor missions, but
you can choose whether you want to play through the plot or strike
out on your own as a merchant or bounty hunter or explorer.
This commit is contained in:
Yorick Hardy 2019-04-17 21:03:25 +02:00
parent f09bc6ef63
commit 1735f80f13
6 changed files with 2579 additions and 0 deletions

View File

@ -721,6 +721,7 @@ SUBDIR+= emirror
SUBDIR+= emokit
SUBDIR+= emovix
SUBDIR+= empathy
SUBDIR+= endless-sky
SUBDIR+= engauge-digitizer
SUBDIR+= enigma2000
SUBDIR+= enlightenment0224

13
endless-sky/DESCR Normal file
View File

@ -0,0 +1,13 @@
Explore other star systems. Earn money by trading, carrying
passengers, or completing missions. Use your earnings to buy a
better ship or to upgrade the weapons and engines on your current
one. Blow up pirates. Take sides in a civil war. Or leave human
space behind and hope to find some friendly aliens whose culture
is more civilized than your own...
Endless Sky is a sandbox-style space exploration game similar to
Elite, Escape Velocity, or Star Control. You start out as the
captain of a tiny space ship and can choose what to do from there.
The game includes a major plot line and many minor missions, but
you can choose whether you want to play through the plot or strike
out on your own as a merchant or bounty hunter or explorer.

54
endless-sky/Makefile Normal file
View File

@ -0,0 +1,54 @@
# $NetBSD$
GITHUB_PROJECT= endless-sky
PKGNAME= ${GITHUB_PROJECT}-0.9.8
DISTNAME= ${GITHUB_TAG}
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=endless-sky/}
DIST_SUBDIR= ${GITHUB_PROJECT}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://endless-sky.github.io/
COMMENT= Space exploration and combat game similar to Escape Velocity
LICENSE= gnu-gpl-v3 AND cc-by-sa-v4.0 AND cc-by-sa-v3.0 AND public-domain
WRKSRC= ${WRKDIR}/endless-sky-${PKGVERSION_NOREV}
USE_LANGUAGES= c++
BUILD_DEPENDS+= scons-[0-9]*:../../devel/scons
SCONS= ${PREFIX}/bin/scons
SCONS_ARGS+= -C ${WRKSRC} DESTDIR=${DESTDIR} PREFIX=${PREFIX}
SUBST_CLASSES+= fix-png
SUBST_STAGE.fix-png= pre-configure
SUBST_MESSAGE.fix-png= Fixing -lpng
SUBST_FILES.fix-png= SConstruct
SUBST_SED.fix-png= -e 's,"png","png16",g'
SUBST_CLASSES+= fix-paths
SUBST_STAGE.fix-paths= pre-configure
SUBST_MESSAGE.fix-paths= Fixing installation paths
SUBST_FILES.fix-paths= SConstruct source/Files.cpp
SUBST_SED.fix-paths= -e 's@/share/games/@/share/@g'
SUBST_SED.fix-paths+= -e 's@/games@/bin@g'
SUBST_SED.fix-paths+= -e 's@/share/man/@/${PKGMANDIR}/@g'
SUBST_SED.fix-paths+= -e 's,@PREFIX@,${PREFIX},g'
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${SCONS} ${SCONS_ARGS}
do-install:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${SCONS} ${SCONS_ARGS} install
JPEG_ACCEPTED= libjpeg-turbo
.include "../../audio/libmad/buildlink3.mk"
.include "../../audio/openal-soft/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../graphics/glew/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2481
endless-sky/PLIST Normal file

File diff suppressed because it is too large Load Diff

7
endless-sky/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (endless-sky/v0.9.8.tar.gz) = 4a1b2c3f17fb95963f3997c36314028cb7b0379e
RMD160 (endless-sky/v0.9.8.tar.gz) = 18c572471df372c3531ad8d69eaac1fd416ce336
SHA512 (endless-sky/v0.9.8.tar.gz) = 521026cb70372fd380b14a1a1d296f86015e5999dc233f4d9c05d958092e1f3982d2f12e913a435d5827fb45945bd4b60bbae293c2c90685024cdae96e352078
Size (endless-sky/v0.9.8.tar.gz) = 74476053 bytes
SHA1 (patch-source_Files.cpp) = f21b4d4ca9d4c5df56a8c50b887c163673d747a5

View File

@ -0,0 +1,23 @@
$NetBSD$
Also test for NetBSD.
Search for data in installation path.
--- source/Files.cpp.orig 2015-12-14 04:39:54.000000000 +0000
+++ source/Files.cpp
@@ -105,12 +105,12 @@ void Files::Init(const char * const *arg
#endif
if(resources.back() != '/')
resources += '/';
-#if defined __linux__ || defined __FreeBSD__ || defined __DragonFly__
+#if defined __linux__ || defined __FreeBSD__ || defined __DragonFly__ || defined __NetBSD__
// Special case, for Linux: the resource files are not in the same place as
// the executable, but are under the same prefix (/usr or /usr/local).
static const string LOCAL_PATH = "/usr/local/";
- static const string STANDARD_PATH = "/usr/";
- static const string RESOURCE_PATH = "share/games/endless-sky/";
+ static const string STANDARD_PATH = "@PREFIX@/";
+ static const string RESOURCE_PATH = "share/endless-sky/";
if(!resources.compare(0, LOCAL_PATH.length(), LOCAL_PATH))
resources = LOCAL_PATH + RESOURCE_PATH;
else if(!resources.compare(0, STANDARD_PATH.length(), STANDARD_PATH))