dosbox-staging: import dosbox-staging-0.76.0 as wip/dosbox-staging

DOSBox Staging is an attempt to revitalize DOSBox's development
process. It's not a rewrite, but a continuation and improvement on
the existing DOSBox codebase while leveraging modern development
tools and practices.
This commit is contained in:
Yorick Hardy 2020-12-24 14:13:14 +02:00
parent 94a2196666
commit 1d3fe31e87
7 changed files with 90 additions and 0 deletions

View File

@ -649,6 +649,7 @@ SUBDIR+= dolphin-plugins
SUBDIR+= dolphin5
SUBDIR+= doomlegacy-devel
SUBDIR+= doorman
SUBDIR+= dosbox-staging
SUBDIR+= dosbox-svn
SUBDIR+= dosemu2
SUBDIR+= dotproject

4
dosbox-staging/DESCR Normal file
View File

@ -0,0 +1,4 @@
DOSBox Staging is an attempt to revitalize DOSBox's development
process. It's not a rewrite, but a continuation and improvement on
the existing DOSBox codebase while leveraging modern development
tools and practices.

34
dosbox-staging/Makefile Normal file
View File

@ -0,0 +1,34 @@
# $NetBSD$
GITHUB_PROJECT= dosbox-staging
GITHUB_TAG= v0.76.0
DISTNAME= v0.76.0
PKGNAME= ${GITHUB_PROJECT}-${DISTNAME:S,^v,,}
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GITHUB:=dosbox-staging/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://dosbox-staging.github.io/
COMMENT= DOS/x86 emulator focusing on ease of use
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/dosbox-staging-0.76.0
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
USE_TOOLS= aclocal automake autoconf gmake pkg-config
NOT_PAX_MPROTECT_SAFE= bin/dosbox_staging
pre-configure:
${MV} ${WRKSRC}/docs/dosbox.1 ${WRKSRC}/docs/dosbox_staging.1
set -e; cd ${WRKSRC}; \
aclocal; autoheader; automake -a --foreign -i; autoconf
.include "../../audio/fluidsynth/buildlink3.mk"
.include "../../audio/opusfile/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../net/SDL2_net/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
dosbox-staging/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/dosbox_staging
man/man1/dosbox_staging.1

8
dosbox-staging/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD$
SHA1 (dosbox-staging/v0.76.0.tar.gz) = ca64bc6285a7f5d7c88fb23671e3639c23f3ed30
RMD160 (dosbox-staging/v0.76.0.tar.gz) = 3cc9aa389bc8a906cbf5a899992e9b9364884775
SHA512 (dosbox-staging/v0.76.0.tar.gz) = 8c0357bcec08cac2cd2b306edd8b51ad05e16a3c3efb1f4c77e1d942f285493cae8aab45f1633e9c168c0b4b45aa289cf3ffc72685dc004d83127cdb6c76ae9d
Size (dosbox-staging/v0.76.0.tar.gz) = 1908605 bytes
SHA1 (patch-docs_Makefile.am) = 1a10779a5abf2329359683b5d1bf3da9ac888747
SHA1 (patch-src_Makefile.am) = ead30d4bcebcafae531d2c3e0bdededa59ae32f2

View File

@ -0,0 +1,14 @@
$NetBSD$
Install as "dosbox_staging" to avoid a conflict with emulators dosbox.
--- docs/Makefile.am.orig 2020-12-03 18:36:19.000000000 +0000
+++ docs/Makefile.am
@@ -1,6 +1,6 @@
# Main Makefile for DOSBox
-man_MANS = dosbox.1
+man_MANS = dosbox_staging.1
EXTRA_DIST = $(man_MANS) README.video PORTING

View File

@ -0,0 +1,26 @@
$NetBSD$
Install as "dosbox_staging" to avoid a conflict with emulators dosbox.
--- src/Makefile.am.orig 2020-12-03 18:36:19.000000000 +0000
+++ src/Makefile.am
@@ -2,7 +2,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include
SUBDIRS = cpu debug dos fpu gui hardware libs ints midi misc shell platform
-bin_PROGRAMS = dosbox
+bin_PROGRAMS = dosbox_staging
if HAVE_WINDRES
ico_stuff = winres.rc
@@ -11,8 +11,8 @@ endif
.rc.o:
$(WINDRES) -o $@ $<
-dosbox_SOURCES = dosbox.cpp $(ico_stuff)
-dosbox_LDADD = cpu/libcpu.a \
+dosbox_staging_SOURCES = dosbox.cpp $(ico_stuff)
+dosbox_staging_LDADD = cpu/libcpu.a \
debug/libdebug.a \
dos/libdos.a \
fpu/libfpu.a \