spidermonkey185: remove, pkgsrc version exists and is better maintained

This commit is contained in:
Thomas Klausner 2020-04-13 21:33:23 +02:00
parent abc1203dd9
commit 20b94794d3
9 changed files with 2 additions and 268 deletions

View File

@ -818,7 +818,7 @@ SUBDIR+= filepp
SUBDIR+= filerunner
SUBDIR+= filevercmp
SUBDIR+= findcrcs
SUBDIR+= fio
SUBDIR+= fio
SUBDIR+= firebird
SUBDIR+= fireflysung-ttf
SUBDIR+= firefox-hg
@ -1035,7 +1035,6 @@ SUBDIR+= gdal-grass
SUBDIR+= gdb
SUBDIR+= gdb-git
SUBDIR+= gdb-netbsd
SUBDIR+= gdb-netbsd-wip
SUBDIR+= gdb5
SUBDIR+= gdb6
SUBDIR+= gde
@ -1205,6 +1204,7 @@ SUBDIR+= googlecl
SUBDIR+= gopass
SUBDIR+= gopher-validator-git
SUBDIR+= gopkgdep
SUBDIR+= gopls
SUBDIR+= gpak
SUBDIR+= gplbasic
SUBDIR+= gpsbabel
@ -3004,7 +3004,6 @@ SUBDIR+= pointless
SUBDIR+= pokerth
SUBDIR+= polarssl11
SUBDIR+= polipo
SUBDIR+= polkit-git
SUBDIR+= polkit-kde-agent
SUBDIR+= polyclipping
SUBDIR+= polylib
@ -4587,7 +4586,6 @@ SUBDIR+= spfmilter
SUBDIR+= spice-gtk
SUBDIR+= spice-html5
SUBDIR+= spice-vdagent
SUBDIR+= spidermonkey185
SUBDIR+= spidermonkey24
SUBDIR+= spidermonkey31
SUBDIR+= splix

View File

@ -1,2 +0,0 @@
SpiderMonkey is the code-name for the Mozilla's C implementation of
JavaScript.

View File

@ -1,74 +0,0 @@
# $NetBSD: Makefile,v 1.5 2014/02/03 13:52:52 fhajny Exp $
#
DISTNAME= js185-1.0.0
PKGNAME= ${DISTNAME:S/js/spidermonkey/}
PKGREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_MOZILLA:=js/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://developer.mozilla.org/en/SpiderMonkey
COMMENT= Standalone JavaScript implementation in C
LICENSE= mpl-1.1
WRKSRC= ${WRKDIR}/js-1.8.5/js/src
USE_TOOLS+= gmake pkg-config perl:build zip:build
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-system-nspr
CONFIGURE_ARGS+= --with-pthreads
CONFIGURE_ARGS+= --enable-threadsafe
SUBST_CLASSES+= js-config pc
SUBST_STAGE.js-config= pre-configure
SUBST_STAGE.pc= pre-configure
SUBST_MESSAGE.js-config= Adjust CFLAGS in js-config
SUBST_MESSAGE.pc= Adjust CFLAGS in mozjs185.pc
SUBST_FILES.js-config= js-config.in
SUBST_FILES.pc= mozjs185.pc.in
SUBST_SED.js-config+= -e '/includedir/ s,js,js-1.8.5,g'
SUBST_SED.pc+= -e '/Cflags:/ s,js,js-1.8.5,g'
# XXX: workaround for js-config command and mozjs185.pc
CONFIGURE_ENV+= MOZILLA_VERSION=4.0
PKGCONFIG_OVERRIDE+= ctypes/libffi/libffi.pc.in
PKGCONFIG_OVERRIDE+= mozjs185.pc.in
.include "../../mk/bsd.prefs.mk"
.if ${MACHINE_ARCH} == "arm"
PLIST_SUBST+= ARCH=ARM
.elif ${MACHINE_ARCH} == "mips"
PLIST_SUBST+= ARCH=MIPS
.elif ${MACHINE_ARCH} == "powerpc"
PLIST_SUBST+= ARCH=PPC
.elif ${MACHINE_ARCH} == "sparc"
PLIST_SUBST+= ARCH=Sparc
.elif ${MACHINE_ARCH} == "x86_64"
PLIST_SUBST+= ARCH=X64
.else
PLIST_SUBST+= ARCH=${MACHINE_ARCH}
.endif
TEST_TARGET= check
# o Install js interpreter
# o Install the binaries and headers with a proper version suffix
# o Adjust headers permissions
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/js ${DESTDIR}${PREFIX}/bin/js185
${MV} ${DESTDIR}${PREFIX}/bin/js-config ${DESTDIR}${PREFIX}/bin/js185-config
${MV} ${DESTDIR}${PREFIX}/include/js ${DESTDIR}${PREFIX}/include/js-1.8.5
${CHMOD} -x ${DESTDIR}${PREFIX}/include/js-1.8.5/*
# Python is only needed for the test target
PYTHON_FOR_BUILD_ONLY= yes
.include "../../lang/python/application.mk"
.include "../../devel/nspr/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,102 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2012/11/03 15:07:33 thomasklausner Exp $
bin/js185
bin/js185-config
include/js-1.8.5/Allocator.h
include/js-1.8.5/Assembler.h
include/js-1.8.5/CodeAlloc.h
include/js-1.8.5/Containers.h
include/js-1.8.5/Fragmento.h
include/js-1.8.5/LIR.h
include/js-1.8.5/LIRopcode.tbl
include/js-1.8.5/Native.h
include/js-1.8.5/NativeCommon.h
include/js-1.8.5/Native${ARCH}.h
include/js-1.8.5/RegAlloc.h
include/js-1.8.5/VMPI.h
include/js-1.8.5/Writer.h
include/js-1.8.5/avmplus.h
include/js-1.8.5/js-config.h
include/js-1.8.5/js.msg
include/js-1.8.5/jsanalyze.h
include/js-1.8.5/jsapi.h
include/js-1.8.5/jsarena.h
include/js-1.8.5/jsarray.h
include/js-1.8.5/jsatom.h
include/js-1.8.5/jsautocfg.h
include/js-1.8.5/jsautokw.h
include/js-1.8.5/jsbit.h
include/js-1.8.5/jsbool.h
include/js-1.8.5/jsbuiltins.h
include/js-1.8.5/jscell.h
include/js-1.8.5/jsclist.h
include/js-1.8.5/jsclone.h
include/js-1.8.5/jscntxt.h
include/js-1.8.5/jscompartment.h
include/js-1.8.5/jscompat.h
include/js-1.8.5/jsdate.h
include/js-1.8.5/jsdbgapi.h
include/js-1.8.5/jsdhash.h
include/js-1.8.5/jsdtoa.h
include/js-1.8.5/jsemit.h
include/js-1.8.5/jsfriendapi.h
include/js-1.8.5/jsfun.h
include/js-1.8.5/jsgc.h
include/js-1.8.5/jsgcchunk.h
include/js-1.8.5/jsgcstats.h
include/js-1.8.5/jshash.h
include/js-1.8.5/jshashtable.h
include/js-1.8.5/jshotloop.h
include/js-1.8.5/jsinterp.h
include/js-1.8.5/jsinttypes.h
include/js-1.8.5/jsiter.h
include/js-1.8.5/jslock.h
include/js-1.8.5/jslong.h
include/js-1.8.5/jsmath.h
include/js-1.8.5/jsobj.h
include/js-1.8.5/jsobjinlines.h
include/js-1.8.5/json.h
include/js-1.8.5/jsopcode.h
include/js-1.8.5/jsopcode.tbl
include/js-1.8.5/jsopcodeinlines.h
include/js-1.8.5/jsotypes.h
include/js-1.8.5/jsparse.h
include/js-1.8.5/jsperf.h
include/js-1.8.5/jsprf.h
include/js-1.8.5/jsprobes.h
include/js-1.8.5/jspropertycache.h
include/js-1.8.5/jspropertycacheinlines.h
include/js-1.8.5/jspropertytree.h
include/js-1.8.5/jsproto.tbl
include/js-1.8.5/jsproxy.h
include/js-1.8.5/jsprvtd.h
include/js-1.8.5/jspubtd.h
include/js-1.8.5/jsreflect.h
include/js-1.8.5/jsregexp.h
include/js-1.8.5/jsscan.h
include/js-1.8.5/jsscope.h
include/js-1.8.5/jsscript.h
include/js-1.8.5/jsscriptinlines.h
include/js-1.8.5/jsstaticcheck.h
include/js-1.8.5/jsstdint.h
include/js-1.8.5/jsstr.h
include/js-1.8.5/jstl.h
include/js-1.8.5/jstracer.h
include/js-1.8.5/jstypedarray.h
include/js-1.8.5/jstypes.h
include/js-1.8.5/jsutil.h
include/js-1.8.5/jsval.h
include/js-1.8.5/jsvalue.h
include/js-1.8.5/jsvector.h
include/js-1.8.5/jsversion.h
include/js-1.8.5/jswrapper.h
include/js-1.8.5/jsxdrapi.h
include/js-1.8.5/jsxml.h
include/js-1.8.5/nanojit.h
include/js-1.8.5/njconfig.h
include/js-1.8.5/njcpudetect.h
include/js-1.8.5/prmjtime.h
lib/libmozjs185-1.0.a
lib/libmozjs185.so
lib/libmozjs185.so.1.0
lib/libmozjs185.so.1.0.0
lib/pkgconfig/mozjs185.pc

View File

@ -1,14 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/08/04 10:39:02 ryo-on Exp $
BUILDLINK_TREE+= spidermonkey185
.if !defined(SPIDERMONKEY185_BUILDLINK3_MK)
SPIDERMONKEY185_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.spidermonkey185+= spidermonkey185>=1.0.0
BUILDLINK_PKGSRCDIR.spidermonkey185?= ../../wip/spidermonkey185
.include "../../devel/nspr/buildlink3.mk"
.endif # SPIDERMONKEY185_BUILDLINK3_MK
BUILDLINK_TREE+= -spidermonkey185

View File

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.2 2014/02/03 13:52:52 fhajny Exp $
SHA1 (js185-1.0.0.tar.gz) = 52a01449c48d7a117b35f213d3e4263578d846d6
RMD160 (js185-1.0.0.tar.gz) = 23e6ddc81d5b63e015aecc1a104b2d3d3ced5005
Size (js185-1.0.0.tar.gz) = 6164605 bytes
SHA1 (patch-configure) = 77366fff7e8b766b5691d0432b8740d4c8c362a6
SHA1 (patch-v8-dtoa_platform.cc) = 24670e996fcc7ca0d1e7b1b3765a67ac05e9a661
SHA1 (patch-v8-dtoa_platform.h) = 1d618d8f51e3ee169606297950d3030fcf72abbc

View File

@ -1,28 +0,0 @@
$NetBSD: patch-configure,v 1.1.1.1 2011/08/04 10:39:02 ryo-on Exp $
* Improve compatibility
--- configure.orig 2011-03-31 19:08:36.000000000 +0000
+++ configure
@@ -3234,7 +3234,7 @@ fi
echo "$ac_t""$ac_cv_have_std__Throw" 1>&6
- if test "$ac_cv_have_std__Throw" == "yes"; then
+ if test "$ac_cv_have_std__Throw" = "yes"; then
echo $ac_n "checking for |class __declspec(dllimport) exception| bug""... $ac_c" 1>&6
echo "configure:3240: checking for |class __declspec(dllimport) exception| bug" >&5
if eval "test \"`echo '$''{'ac_cv_have_dllimport_exception_bug'+set}'`\" = set"; then
@@ -8093,6 +8093,12 @@ EOF
EOF
;;
+*-netbsd*)
+ cat >> confdefs.h <<\EOF
+#define AVMPLUS_UNIX 1
+EOF
+
+ ;;
*-gnu*)
cat >> confdefs.h <<\EOF
#define AVMPLUS_UNIX 1

View File

@ -1,20 +0,0 @@
$NetBSD: patch-v8-dtoa_platform.cc,v 1.1 2014/02/03 13:52:53 fhajny Exp $
fpclassify is defined on Illumos.
--- v8-dtoa/platform.cc.orig 2011-03-31 19:08:36.000000000 +0000
+++ v8-dtoa/platform.cc
@@ -111,6 +111,7 @@ int fpclassify(double x) {
#endif // _MSC_VER
#ifdef SOLARIS
+#ifndef fpclassify
#include <ieeefp.h>
@@ -134,4 +135,5 @@ int fpclassify(double x) {
}
}
+#endif fpclassify
#endif // SOLARIS

View File

@ -1,16 +0,0 @@
$NetBSD: patch-v8-dtoa_platform.h,v 1.1 2014/02/03 13:52:53 fhajny Exp $
fpclassify is defined on Illumos.
--- v8-dtoa/platform.h.orig 2011-03-31 19:08:36.000000000 +0000
+++ v8-dtoa/platform.h
@@ -67,7 +67,9 @@ int strncasecmp(const char* s1, const ch
#endif // WIN32
#ifdef SOLARIS
+#ifndef fpclassify
int fpclassify(double x);
+#endif // fpclassify
#endif // SOLARIS
// GCC specific stuff