New package, xpipe-20200113.

The xpipe command reads input from stdin and splits it
by the given number of bytes, lines, or if matching
the given pattern.  It then invokes the given utility
repeatedly, feeding it the generated data chunks as
input.

You can think of it as a Unix love-child of the
split(1), tee(1), and xargs(1) commands.
This commit is contained in:
Benny Siegert 2020-01-13 13:35:54 +00:00
parent 790c2b7844
commit 20fcf1e4a3
5 changed files with 50 additions and 0 deletions

8
xpipe/DESCR Normal file
View File

@ -0,0 +1,8 @@
The xpipe command reads input from stdin and splits it
by the given number of bytes, lines, or if matching
the given pattern. It then invokes the given utility
repeatedly, feeding it the generated data chunks as
input.
You can think of it as a Unix love-child of the
split(1), tee(1), and xargs(1) commands.

16
xpipe/Makefile Normal file
View File

@ -0,0 +1,16 @@
# $NetBSD$
GITHUB_PROJECT= xpipe
GITHUB_TAG= 1b1bc2a
DISTNAME= xpipe-20200113
CATEGORIES= sysutils wip
MASTER_SITES= ${MASTER_SITE_GITHUB:=jschauma/}
MAINTAINER= bsiegert@NetBSD.org
HOMEPAGE= https://github.com/jschauma/xpipe/
COMMENT= Split input and feed it to the given utility
#LICENSE= # TODO: (see mk/license.mk)
WRKSRC= ${WRKDIR}/xpipe-1b1bc2a2b3ebc5afa9bc842f6b1ac18620a83cd6
.include "../../mk/bsd.pkg.mk"

3
xpipe/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/xpipe
share/man/man1/xpipe.1

7
xpipe/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (xpipe-20200113-1b1bc2a.tar.gz) = 47e2a629096b83acbee4c1eabb8bd1c8f95771b9
RMD160 (xpipe-20200113-1b1bc2a.tar.gz) = f6c0c565ea6ba83d8909a3e6335d7eff651d1db4
SHA512 (xpipe-20200113-1b1bc2a.tar.gz) = b59f2ba0171fc5c37b120ecab1ac02abf0b21f1164f706aa60370b4af9d7acdc9db72c716f0a4417617be6b0043dc4f7a9f18bb27744024e49b45e2570fa38df
Size (xpipe-20200113-1b1bc2a.tar.gz) = 12420 bytes
SHA1 (patch-Makefile) = 3f756f30d5842c48ea94decf48d0b75121e23fbc

View File

@ -0,0 +1,16 @@
$NetBSD$
Add destdir support (jschauma/xpipe#1).
--- Makefile.orig 2020-01-13 04:26:40.000000000 +0000
+++ Makefile
@@ -32,6 +32,6 @@ test: ${NAME}
done
install: ${NAME}
- mkdir -p ${PREFIX}/bin ${PREFIX}/share/man/man1
- install -c -m 555 ${NAME} ${PREFIX}/bin/${NAME}
- install -c -m 444 doc/${NAME}.1 ${PREFIX}/share/man/man1/${NAME}.1
+ mkdir -p ${DESTDIR}${PREFIX}/bin ${DESTDIR}${PREFIX}/share/man/man1
+ install -c -m 555 ${NAME} ${DESTDIR}${PREFIX}/bin/${NAME}
+ install -c -m 444 doc/${NAME}.1 ${DESTDIR}${PREFIX}/share/man/man1/${NAME}.1