py-{eth-hash,rlp}: remove dependency on setuptools-markdown

This commit is contained in:
Pierre Pronchery 2020-09-18 05:54:44 +02:00
parent c4fe084442
commit 22dd138c61
6 changed files with 45 additions and 2 deletions

View File

@ -24,7 +24,6 @@ BUILD_DEPENDS+= ${PYPKGPREFIX}-flake8-[0-9]*:../../devel/py-flake8
BUILD_DEPENDS+= ${PYPKGPREFIX}-isort-[0-9]*:../../devel/py-isort
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx-[0-9]*:../../textproc/py-sphinx
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx-rtd-theme-[0-9]*:../../textproc/py-sphinx-rtd-theme
BUILD_DEPENDS+= # TODO: setuptools-markdown>=0
USE_LANGUAGES= # none

View File

@ -4,3 +4,4 @@ SHA1 (eth-hash/v0.2.0.tar.gz) = 330eb3b14bfc138715dc1ed0a61fdb8f6b6a4d9b
RMD160 (eth-hash/v0.2.0.tar.gz) = 257e5d7c48d90b130a3b9059c6f9c51ab2a40b83
SHA512 (eth-hash/v0.2.0.tar.gz) = 6ab1a2b91934ac20ca54da6cd572f97cae911ccbd729c0b11b42cf0b4cdb178bd6524e2b7908a6608d8da6692c0bb56b20aeec288fa2c3a7507b08868d967ff4
Size (eth-hash/v0.2.0.tar.gz) = 16446 bytes
SHA1 (patch-setup.py) = 15cea63e75e9f0fa20202cb2fc95bb3bdd4af1c2

View File

@ -0,0 +1,22 @@
$NetBSD$
Remove dependency on py-setuptools-markdown
--- setup.py.orig 2018-09-05 22:42:35.000000000 +0000
+++ setup.py
@@ -46,14 +46,13 @@ setup(
# *IMPORTANT*: Don't manually change the version here. Use `make bump`, as described in readme
version='0.2.0',
description="""eth-hash: The Ethereum hashing function, keccak256, sometimes (erroneously) called sha3""",
- long_description_markdown_filename='README.md',
+ long_description_content_type='text/markdown',
author='Jason Carver',
author_email='ethcalibur+pip@gmail.com',
url='https://github.com/ethereum/eth-hash',
include_package_data=True,
install_requires=[
],
- setup_requires=['setuptools-markdown'],
python_requires='>=3.5, <4',
extras_require=extras_require,
py_modules=['eth_hash'],

View File

@ -26,7 +26,6 @@ BUILD_DEPENDS+= ${PYPKGPREFIX}-hypothesis-[0-9]*:../../devel/py-hypothesis
BUILD_DEPENDS+= ${PYPKGPREFIX}-flake8-[0-9]*:../../devel/py-flake8
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx-[0-9]*:../../textproc/py-sphinx
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx-rtd-theme-[0-9]*:../../textproc/py-sphinx-rtd-theme
BUILD_DEPENDS+= # TODO: setuptools-markdown>=0
DEPENDS+= ${PYPKGPREFIX}-eth-utils-[0-9]*:../../wip/py-eth-utils
USE_LANGUAGES= # none

View File

@ -4,3 +4,4 @@ SHA1 (pyrlp/v1.2.0.tar.gz) = bebc1163631e21b30b529c0058838b741fca5047
RMD160 (pyrlp/v1.2.0.tar.gz) = 50abca33a77eedb2d7095fef6ab67de66b0485a9
SHA512 (pyrlp/v1.2.0.tar.gz) = 19fe6ce84ad43111f74807f6d4dfdde6dfe58eec0a36cce111083cd03ae2766494a66d3b211cd3593783b5f03bf7471961ae346beb8bdd917539b83fff435abe
Size (pyrlp/v1.2.0.tar.gz) = 38972 bytes
SHA1 (patch-setup.py) = a26d8c5bfad30f1ed15c69f14f58d452614a0485

View File

@ -0,0 +1,21 @@
$NetBSD$
Remove dependency on py-setuptools-markdown
--- setup.py.orig 2019-12-02 17:00:58.000000000 +0000
+++ setup.py
@@ -44,13 +44,12 @@ setup(
# *IMPORTANT*: Don't manually change the version here. See README for more.
version='1.2.0',
description="A package for Recursive Length Prefix encoding and decoding",
- long_description_markdown_filename='README.md',
+ long_description_content_type='text/markdown',
author="jnnk",
author_email='jnnknnj@gmail.com',
url='https://github.com/ethereum/pyrlp',
packages=find_packages(exclude=["tests", "tests.*"]),
include_package_data=True,
- setup_requires=['setuptools-markdown'],
install_requires=[
"eth-utils>=1.0.2,<2",
],