Import OpenJazz 20180522 as wip/openjazz.

OpenJazz is a free, open-source version of the classic Jazz Jackrabbit™
games.

OpenJazz can be compiled on a wide range of operating systems, including
Windows, macOS, GNU/Linux and *BSD. Also ports are available for some
homebrew platforms, for example Wii and PSP.

To play, you will need the files from one of the original games.
This commit is contained in:
Charlotte Koch 2018-11-22 09:15:45 -08:00
parent 9959e8835a
commit 24307ed73b
6 changed files with 68 additions and 0 deletions

View File

@ -2397,6 +2397,7 @@ SUBDIR+= opendchub
SUBDIR+= openerp-server
SUBDIR+= openfodder
SUBDIR+= openh264
SUBDIR+= openjazz
SUBDIR+= openjdk8-openjfx-hg
SUBDIR+= openlogos
SUBDIR+= openmpi

8
openjazz/DESCR Normal file
View File

@ -0,0 +1,8 @@
OpenJazz is a free, open-source version of the classic Jazz Jackrabbit™
games.
OpenJazz can be compiled on a wide range of operating systems, including
Windows, macOS, GNU/Linux and *BSD. Also ports are available for some
homebrew platforms, for example Wii and PSP.
To play, you will need the files from one of the original games.

26
openjazz/Makefile Normal file
View File

@ -0,0 +1,26 @@
# $NetBSD$
DISTNAME= openjazz
PKGNAME= openjazz-20180522
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=AlisterT/}
GITHUB_PROJECT= openjazz
GITHUB_TAG= ${PKGVERSION_NOREV}
MAINTAINER= cfkoch@edgebsd.org
COMMENT= Open source reimplementation of the Jazz Jackrabbit games
LICENSE= gnu-gpl-v2
EXTRACT_USING= gtar
USE_LANGUAGES= c c++
GNU_CONFIGURE= yes
USE_TOOLS+= automake autoconf autoreconf pkg-config
pre-configure:
${RUN} cd ${WRKSRC} && autoreconf -fiv
.include "../../audio/libmodplug/buildlink3.mk"
.include "../../audio/libxmp/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

6
openjazz/PLIST Normal file
View File

@ -0,0 +1,6 @@
@comment $NetBSD$
bin/OpenJazz
share/applications/OpenJazz.desktop
share/icons/hicolor/48x48/apps/OpenJazz.png
share/icons/hicolor/scalable/apps/OpenJazz.svg
share/openjazz/openjazz.000

7
openjazz/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (openjazz-20180522.tar.gz) = 480c42f6a046070f7670d9df4dc3296974d3f174
RMD160 (openjazz-20180522.tar.gz) = 6fcca3578df216db3e3b68d011f98a1f6f273f8f
SHA512 (openjazz-20180522.tar.gz) = 77e2cadcab9c9746e8ae40884362c6a9206a57f9c62436c568bcb7f6479694c62103cba79c36ec4c7e0a8bd85ffc6741194a3e4a05efa3e4e1f86c1470808d80
Size (openjazz-20180522.tar.gz) = 213388 bytes
SHA1 (patch-src_io_network.cpp) = cee2ab953997dfbaa4fb73020e44c6ffdfb038d1

View File

@ -0,0 +1,20 @@
$NetBSD$
--- ./src/io/network.cpp.orig 2018-05-22 08:17:03.000000000 -0700
+++ ./src/io/network.cpp 2018-11-21 23:17:27.447313979 -0800
@@ -60,6 +60,7 @@
#include <arpa/inet.h>
#endif
+#include <sys/time.h>
/**
* Initialise networking.
@@ -172,7 +173,7 @@
#ifdef USE_SOCKETS
sockaddr_in sockAddr;
fd_set writefds;
- timeval timeouttv;
+ struct timeval timeouttv;
unsigned int timeout;
int sock, con;