ltrace: update to 0.7.3

The old version was not available anymore on the mirror servers.
This commit is contained in:
Roland Illig 2020-01-07 21:43:29 +00:00
parent 4a0c9513dc
commit 2571fb2332
7 changed files with 23 additions and 62 deletions

View File

@ -1,32 +1,25 @@
# $NetBSD: Makefile,v 1.4 2012/10/03 09:10:44 asau Exp $
#
DISTNAME= ltrace_0.3.36.orig
PKGNAME= ${DISTNAME:S/_/-/:S/.orig//}
DISTNAME= ltrace-0.7.3
CATEGORIES= sysutils devel
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/l/ltrace/}
LICENSE= gnu-gpl-v2
DISTFILES= ${DISTNAME:S,-,_,}.orig.tar.bz2
MAINTAINER= reed@reedmedia.net
HOMEPAGE= http://ltrace.alioth.debian.org/
COMMENT= Track runtime library calls in dynamically linked programs
LICENSE= gnu-gpl-v2
# see configure.ac, keyword host-os
ONLY_FOR_PLATFORM= Linux-*-*
WRKSRC= ${WRKDIR}/ltrace-0.3.36
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
# maybe following should be done in devel/libelf/buildlink3.mk instead
#CFLAGS+= -I${BUILDLINK_PREFIX.libelf}/include/libelf
CPPFLAGS+= -I${BUILDLINK_PREFIX.libelf}/include/libelf
#CPPFLAGS+= -I${BUILDLINK_DIR}/include/libelf
#CFLAGS+= -I${BUILDLINK_DIR}/include/libelf
# if this uses BUILDLINK_INCDIRS or CFLAGS for this. the build fails because
# it uses -I- which makes it ignore this include directory
#BUILDLINK_INCDIRS.libelf+= include/libelf
INSTALLATION_DIRS+= share/examples/ltrace
CHECK_PORTABILITY_SKIP= testsuite/run-my-tests.sh
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --docdir=${PREFIX}/share/doc/ltrace
CPPFLAGS+= -I${BUILDLINK_PREFIX.libelf}/include/libelf
AUTO_MKDIRS= yes
CONF_FILES= ${PREFIX}/share/examples/ltrace/ltrace.conf ${PKG_SYSCONFDIR}/ltrace.conf
@ -34,5 +27,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/etc/ltrace.conf ${PREFIX}/share/examples/ltrace
.include "../../devel/libelf/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1 +0,0 @@
ltrace.conf is not documented

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/12/17 05:51:55 jeremy-c-reed Exp $
SHA1 (ltrace_0.3.36.orig.tar.gz) = 49589bccb9d32e220166e7df8c22a4c2ec7b0730
RMD160 (ltrace_0.3.36.orig.tar.gz) = 949971c47c5affb0b0c5797a1c4049a0aecb1d59
Size (ltrace_0.3.36.orig.tar.gz) = 122098 bytes
SHA1 (patch-aa) = 9aa0d897fafe11858fbe787fa7df20bad7840dfb
SHA1 (ltrace_0.7.3.orig.tar.bz2) = 8df2acc8bc135a229917de6ef814f416d38124ca
RMD160 (ltrace_0.7.3.orig.tar.bz2) = 27610d6334a5b1de0f3320131834545079bd80f0
SHA512 (ltrace_0.7.3.orig.tar.bz2) = a842b16dcb81da869afa0bddc755fdff0d57b35672505bf2c7164fd983b1938d28b126714128930994cc1230ced69d779456d0cfc16f4008c9b6d19f0852285d
Size (ltrace_0.7.3.orig.tar.bz2) = 482658 bytes

View File

@ -1,26 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/12/17 05:51:55 jeremy-c-reed Exp $
--- Makefile.in.orig 2004-11-09 15:12:03.000000000 -0800
+++ Makefile.in 2005-12-13 17:06:16.205329000 -0800
@@ -11,10 +11,10 @@
sysconfdir = @sysconfdir@
bindir = $(prefix)/bin
mandir = @mandir@
-docdir = $(prefix)/doc/ltrace
+docdir = @datadir@/doc/ltrace
CC = @CC@
-CPPFLAGS = -I$(TOPDIR) -I$(TOPDIR)/sysdeps/$(OS) -I- @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)\"
+CPPFLAGS = -I$(TOPDIR) -I$(TOPDIR)/sysdeps/$(OS) -I- @CPPFLAGS@ @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)\"
CFLAGS = -Wall @CFLAGS@
LDFLAGS =
LIBS = @LIBS@
@@ -57,7 +57,7 @@
$(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(docdir) $(DESTDIR)$(mandir)/man1
$(INSTALL_DIR) $(DESTDIR)$(sysconfdir)
$(INSTALL_PROGRAM) ltrace $(DESTDIR)$(bindir)
- $(INSTALL_FILE) etc/ltrace.conf $(DESTDIR)$(sysconfdir)
+# $(INSTALL_FILE) etc/ltrace.conf $(DESTDIR)$(sysconfdir)
$(INSTALL_FILE) COPYING README TODO BUGS ChangeLog $(DESTDIR)$(docdir)
$(INSTALL_FILE) ltrace.1 $(DESTDIR)$(mandir)/man1

View File

@ -1,5 +0,0 @@
AI::Prolog is a pure Perl predicate logic engine.
In predicate logic, instead of telling the computer
how to do something, you tell the computer what
something is and let it figure out how to do it.
Conceptually this is similar to regular expressions.

View File

@ -1,19 +1,19 @@
# $NetBSD: Makefile,v 1.6 2013/03/30 19:54:45 jgoamakf Exp $
#
# $NetBSD$
DISTNAME= AI-Prolog-0.741
PKGNAME= p5-${DISTNAME}
CATEGORIES= perl5 lang
CATEGORIES= wip
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=AI/}
MAINTAINER= athaba@users.sourceforge.net
HOMEPAGE= https://metacpan.org/release/AI-Prolog
COMMENT= Pure Perl predicate logic engine
LICENSE= ${PERL5_LICENSE}
MAINTAINER= INSERT_YOUR_MAIL_ADDRESS_HERE
HOMEPAGE= https://cpan.perl.org/CPAN/modules/by-module/AI/
COMMENT= TODO: Short description of the package
#LICENSE= # TODO: (see mk/license.mk)
DEPENDS+= p5-Clone>=0.15:../../devel/p5-Clone
DEPENDS+= p5-Exporter-Tidy>=0.06:../../wip/p5-Exporter-Tidy
DEPENDS+= p5-Hash-AsObject>=0.05:../../wip/p5-Hash-AsObject
DEPENDS+= p5-Pod-Usage>=1.12:../../devel/p5-Pod-Usage
DEPENDS+= p5-Regexp-Common>=2.119:../../textproc/p5-Regexp-Common
DEPENDS+= p5-Term-ReadKey>=2.21:../../devel/p5-Term-ReadKey
DEPENDS+= p5-Term-ReadLine>=1.01:../../devel/p5-Term-ReadLine

View File

@ -2,5 +2,6 @@ $NetBSD: distinfo,v 1.3 2013/03/30 19:54:45 jgoamakf Exp $
SHA1 (AI-Prolog-0.741.tar.gz) = c5db1d77908b226074d6e64c3200b71be2d4bddf
RMD160 (AI-Prolog-0.741.tar.gz) = 6053a28432cbf31109b4ad360ffbcdea605d5a95
SHA512 (AI-Prolog-0.741.tar.gz) = c878393bb816c6ad93164eb211e1db32cbccca4ff168a079e7c1596c29b958b6882a8a4e76346cd6d98918270d88db6a2112161c2876f55ca4ae3d838aca7012
Size (AI-Prolog-0.741.tar.gz) = 69834 bytes
SHA1 (patch-aa) = d1c06727e4f705140fd3ec6b5d7c16f0f05391cd