fastx-toolkit: CLI tools for Short-Reads FASTA/FASTQ files preprocessing

This commit is contained in:
Jason Bacon 2019-01-07 19:56:46 -06:00
parent 672ceff503
commit 27648ff947
6 changed files with 88 additions and 0 deletions

View File

@ -758,6 +758,7 @@ SUBDIR+= fastool
SUBDIR+= fastqc
SUBDIR+= fastrpc
SUBDIR+= fasttree
SUBDIR+= fastx-toolkit
SUBDIR+= fbida
SUBDIR+= fbpager
SUBDIR+= fbpanel

2
fastx-toolkit/DESCR Normal file
View File

@ -0,0 +1,2 @@
The FASTX-Toolkit is a collection of command line tools for Short-Reads
FASTA/FASTQ files preprocessing.

31
fastx-toolkit/Makefile Normal file
View File

@ -0,0 +1,31 @@
# $NetBSD$
#
###########################################################
# Generated by fbsd2pkg #
# Mon Jan 7 19:28:31 CST 2019 #
###########################################################
DISTNAME= fastx_toolkit-0.0.14
CATEGORIES= biology
MASTER_SITES= ${MASTER_SITE_GITHUB:=agordon/}
GITHUB_PROJECT= fastx_toolkit
MAINTAINER= bacon@NetBSD.org
HOMEPAGE= http://hannonlab.cshl.edu/fastx_toolkit/
COMMENT= CLI tools for Short-Reads FASTA/FASTQ files preprocessing
LICENSE= gnu-agpl-v3
USE_LANGUAGES= c c++
USE_TOOLS+= autoconf automake autoreconf bash pkg-config perl:run
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
REPLACE_PERL+= scripts/*.pl
REPLACE_BASH+= scripts/fastq_quality_boxplot_graph.sh
REPLACE_BASH+= scripts/fastx_nucleotide_distribution_graph.sh
REPLACE_BASH+= scripts/fastx_nucleotide_distribution_line_graph.sh
pre-configure:
cd ${WRKSRC} && autoreconf -if
.include "../../wip/gtextutils/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

24
fastx-toolkit/PLIST Normal file
View File

@ -0,0 +1,24 @@
@comment $NetBSD$
bin/fasta_clipping_histogram.pl
bin/fasta_formatter
bin/fasta_nucleotide_changer
bin/fastq_masker
bin/fastq_quality_boxplot_graph.sh
bin/fastq_quality_converter
bin/fastq_quality_filter
bin/fastq_quality_trimmer
bin/fastq_to_fasta
bin/fastx_artifacts_filter
bin/fastx_barcode_splitter.pl
bin/fastx_clipper
bin/fastx_collapser
bin/fastx_nucleotide_distribution_graph.sh
bin/fastx_nucleotide_distribution_line_graph.sh
bin/fastx_quality_stats
bin/fastx_renamer
bin/fastx_reverse_complement
bin/fastx_trimmer
bin/fastx_uncollapser
share/aclocal/ax_c_long_long.m4
share/aclocal/ax_cxx_compile_stdcxx_11.m4
share/aclocal/ax_cxx_header_stdcxx_tr1.m4

7
fastx-toolkit/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (fastx_toolkit-0.0.14.tar.gz) = ce008d34469afd48f4012d37797f91972a8f72cf
RMD160 (fastx_toolkit-0.0.14.tar.gz) = 759a34c6e30f96eeef415dc832ec4a518866be09
SHA512 (fastx_toolkit-0.0.14.tar.gz) = d8e18a3622dcdb5b543fcb787818ac468b26341d5d4409326c951b504862eb44226f625228985bec6fb2e02c45f9a127591a312dadd53415337a7c09f6229708
Size (fastx_toolkit-0.0.14.tar.gz) = 259576 bytes
SHA1 (patch-src_libfastx_fastx.h) = 5a387ac575a5269bc03e3f09ab752889efb8870c

View File

@ -0,0 +1,23 @@
$NetBSD$
# Limit packing to this one structure to avoid compatibility issues
--- src/libfastx/fastx.h.orig 2018-05-16 14:50:08 UTC
+++ src/libfastx/fastx.h
@@ -58,7 +58,7 @@ typedef enum {
OUTPUT_SAME_AS_INPUT=3
} OUTPUT_FILE_TYPE;
-#pragma pack(1)
+#pragma pack(push,1)
typedef struct
{
/* Record data - common for FASTA/FASTQ */
@@ -115,6 +115,7 @@ typedef struct
FILE* input;
FILE* output;
} FASTX ;
+#pragma pack(pop)
void fastx_init_reader(FASTX *pFASTX, const char* filename,