Add sauerbraten.

Mostly seems to work (besides configuration not being saved and
there being no application entries). Everyone else is shipping an
older version though, I wonder if there's a reason or if they're
just lazy.

Cube 2: Sauerbraten is a free multiplayer & singleplayer first
person shooter, the successor of the Cube FPS.

Much like the original Cube, the aim of this game is fun, old school
deathmatch gameplay and also to allow map/geometry editing to be
done cooperatively in-game.

The engine supporting the game is entirely original in code &
design, and its code is Open Source (ZLIB license, read the docs
for more on how you can use the engine).
This commit is contained in:
nia 2019-05-25 17:03:50 +01:00
parent 7eb153c5eb
commit 2880d83922
7 changed files with 6367 additions and 0 deletions

View File

@ -4371,6 +4371,7 @@ SUBDIR+= samhain
SUBDIR+= samtools0119
SUBDIR+= sara
SUBDIR+= sarf
SUBDIR+= sauerbraten
SUBDIR+= sbcl-git
SUBDIR+= scantailor
SUBDIR+= scare

10
sauerbraten/DESCR Normal file
View File

@ -0,0 +1,10 @@
Cube 2: Sauerbraten is a free multiplayer & singleplayer first
person shooter, the successor of the Cube FPS.
Much like the original Cube, the aim of this game is fun, old school
deathmatch gameplay and also to allow map/geometry editing to be
done cooperatively in-game.
The engine supporting the game is entirely original in code &
design, and its code is Open Source (ZLIB license, read the docs
for more on how you can use the engine).

56
sauerbraten/Makefile Normal file
View File

@ -0,0 +1,56 @@
# $NetBSD$
DISTNAME= sauerbraten_2013_04_04_collect_edition_linux
PKGNAME= sauerbraten-2013_04_04
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=sauerbraten/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://sauerbraten.org/
COMMENT= First-person shooter game based on Cube 2
LICENSE= zlib AND cc-by-nc-sa-v3.0-license
USE_TOOLS+= gmake pkg-config pax
USE_LANGUAGES= c c++03
WRKSRC= ${WRKDIR}/sauerbraten
BUILD_DIRS+= src
LDFLAGS.NetBSD+= -lrt
INSTALLATION_DIRS+= bin
INSTALLATION_DIRS+= libexec
INSTALLATION_DIRS+= share/doc/sauerbraten
INSTALLATION_DIRS+= share/sauerbraten/data
INSTALLATION_DIRS+= share/sauerbraten/packages
pre-configure:
${SED} -e 's,@PREFIX@,${PREFIX},g' \
< ${FILESDIR}/sauerbraten.sh.in > \
${WRKDIR}/sauer_client
${SED} -e 's,@PREFIX@,${PREFIX},g' \
< ${FILESDIR}/sauerbraten.sh.in > \
${WRKDIR}/sauer_server
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/sauer_client \
${DESTDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKDIR}/sauer_server \
${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/sauer_client \
${DESTDIR}${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/src/sauer_server \
${DESTDIR}${PREFIX}/libexec
cd ${WRKSRC}/docs && ${PAX} -rw -pp . ${DESTDIR}${PREFIX}/share/doc/sauerbraten
cd ${WRKSRC}/data && ${PAX} -rw -pp . ${DESTDIR}${PREFIX}/share/sauerbraten/data
cd ${WRKSRC}/packages && ${PAX} -rw -pp . ${DESTDIR}${PREFIX}/share/sauerbraten/packages
.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../net/enet/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

6231
sauerbraten/PLIST Normal file

File diff suppressed because it is too large Load Diff

7
sauerbraten/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (sauerbraten_2013_04_04_collect_edition_linux.tar.bz2) = 95a35e40060afc247d2857c0052eee2ebd76a4fb
RMD160 (sauerbraten_2013_04_04_collect_edition_linux.tar.bz2) = 73f8a6be6fb037977699bb76ad7128e561577b63
SHA512 (sauerbraten_2013_04_04_collect_edition_linux.tar.bz2) = e1ee397a3846ec1aad9113e1a5490a883496d8bd4eb81e0d9bd1b8a440fd4d1f0f9411a86abf22478a7edf25908712adbaacfe95b6eaeefe339778d45e77cda7
Size (sauerbraten_2013_04_04_collect_edition_linux.tar.bz2) = 589959852 bytes
SHA1 (patch-src_Makefile) = b1a74df8880478c6aca863e42534f3d3a0c8eb09

View File

@ -0,0 +1,2 @@
#!/bin/sh
cd "@PREFIX@/share/sauerbraten" && exec "@PREFIX@/libexec/${0##*/}" "$@"

View File

@ -0,0 +1,60 @@
$NetBSD$
Do not override CFLAGS/CXXFLAGS.
Use libenet from pkgsrc.
--- src/Makefile.orig 2012-08-28 05:30:07.000000000 +0000
+++ src/Makefile
@@ -1,10 +1,9 @@
-CXXFLAGS= -O3 -fomit-frame-pointer
-override CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
+CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
PLATFORM= $(shell uname -s)
PLATFORM_PREFIX= native
-INCLUDES= -Ishared -Iengine -Ifpsgame -Ienet/include
+INCLUDES= -Ishared -Iengine -Ifpsgame $$(pkg-config --cflags libenet)
STRIP=
ifeq (,$(findstring -g,$(CXXFLAGS)))
@@ -37,7 +36,7 @@ endif
CLIENT_LIBS= -mwindows $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lSDL -lSDL_image -lSDL_mixer -lzlib1 -lopengl32 -lenet -lws2_32 -lwinmm
else
CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
-CLIENT_LIBS= -Lenet/.libs -lenet -L/usr/X11R6/lib -lX11 `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
+CLIENT_LIBS= $$(pkg-config --libs libenet) -L/usr/X11R6/lib -lX11 `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
endif
ifeq ($(PLATFORM),Linux)
CLIENT_LIBS+= -lrt
@@ -106,7 +105,7 @@ SERVER_LIBS= -mwindows $(STD_LIBS) -L$(W
MASTER_LIBS= $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lzlib1 -lenet -lws2_32 -lwinmm
else
SERVER_INCLUDES= -DSTANDALONE $(INCLUDES)
-SERVER_LIBS= -Lenet/.libs -lenet -lz
+SERVER_LIBS= $$(pkg-config --libs libenet) -lz
MASTER_LIBS= $(SERVER_LIBS)
endif
SERVER_OBJS= \
@@ -176,14 +175,14 @@ master: $(MASTER_OBJS)
install: all
else
-client: libenet $(CLIENT_OBJS)
- $(CXX) $(CXXFLAGS) -o sauer_client $(CLIENT_OBJS) $(CLIENT_LIBS)
+client: $(CLIENT_OBJS)
+ $(CXX) $(LDFLAGS) -o sauer_client $(CLIENT_OBJS) $(CLIENT_LIBS)
-server: libenet $(SERVER_OBJS)
- $(CXX) $(CXXFLAGS) -o sauer_server $(SERVER_OBJS) $(SERVER_LIBS)
+server: $(SERVER_OBJS)
+ $(CXX) $(LDFLAGS) -o sauer_server $(SERVER_OBJS) $(SERVER_LIBS)
-master: libenet $(MASTER_OBJS)
- $(CXX) $(CXXFLAGS) -o sauer_master $(MASTER_OBJS) $(MASTER_LIBS)
+master: $(MASTER_OBJS)
+ $(CXX) $(LDFLAGS) -o sauer_master $(MASTER_OBJS) $(MASTER_LIBS)
shared/cube2font.o: shared/cube2font.c
$(CXX) $(CXXFLAGS) -c -o $@ $< `freetype-config --cflags`