Add haxe version 4.0.0

Haxe is an open source toolkit that allows you to easily build
cross-platform tools and applications that target many mainstream
platforms. The Haxe toolkit includes:

 -  The Haxe programming language, a modern, high-level, strictly-typed
    programming language
 -  The Haxe cross-compiler, a state-of-the-art, lightning-speed
    compiler for many targets
 -  The Haxe standard library, a complete, cross-platform library of
    common functionality
This commit is contained in:
Maya Rashish 2019-11-02 17:10:41 +02:00
parent da615277d9
commit 2b0df28733
7 changed files with 2545 additions and 0 deletions

10
haxe/DESCR Normal file
View File

@ -0,0 +1,10 @@
Haxe is an open source toolkit that allows you to easily build
cross-platform tools and applications that target many mainstream
platforms. The Haxe toolkit includes:
- The Haxe programming language, a modern, high-level, strictly-typed
programming language
- The Haxe cross-compiler, a state-of-the-art, lightning-speed
compiler for many targets
- The Haxe standard library, a complete, cross-platform library of
common functionality

48
haxe/Makefile Normal file
View File

@ -0,0 +1,48 @@
# $NetBSD: Makefile,v 1.20 2019/08/27 19:56:03 schmonz Exp $
GITHUB_PROJECT= haxe
DISTNAME= haxe-4.0.0
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GITHUB:=HaxeFoundation/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/ocaml-community/sedlex
COMMENT= Programming language that produces cross-platofrm binaries
LICENSE= isc
DIST_SUBDIR= ${PKGBASE}
HAXELIB= haxelib
HAXELIB_TAG= 4.0.0
SITES.${HAXELIB}-${HAXELIB_TAG}.tar.gz= \
-https://codeload.github.com/HaxeFoundation/haxelib/tar.gz/${HAXELIB_TAG}
HXCOMPAT= hx3compat
HXCOMPAT_TAG= ae0d8a85666199b52aed8987c9feaf297c3f66d4
SITES.${HXCOMPAT_TAG}.tar.gz= \
-https://codeload.github.com/HaxeFoundation/hx3compat/tar.gz/${HXCOMPAT_TAG}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${HAXELIB}-${HAXELIB_TAG}.tar.gz ${HXCOMPAT_TAG}.tar.gz
USE_TOOLS+= gmake
SUBST_CLASSES+= pcreinc
SUBST_STAGE.pcreinc= pre-configure
SUBST_FILES.pcreinc= libs/pcre/Makefile
SUBST_VARS.pcreinc= PREFIX
MAKE_JOBS_SAFE= no
post-extract:
${CP} -pR ${WRKDIR}/${HAXELIB}-${HAXELIB_TAG}/* ${WRKSRC}/extra/haxelib_src/
${CP} -pR ${WRKDIR}/${HXCOMPAT}-${HXCOMPAT_TAG}/* ${WRKSRC}/extra/haxelib_src/hx3compat
DEPENDS+= neko-[0-9]*:../../wip/neko
.include "../../wip/ocaml-ptmap/buildlink3.mk"
.include "../../wip/ocaml-sha/buildlink3.mk"
.include "../../wip/ocaml-sedlex/buildlink3.mk"
.include "../../lang/ocaml/buildlink3.mk"
.include "../../devel/ocaml-dune/buildlink3.mk"
.include "../../devel/pcre/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2424
haxe/PLIST Normal file

File diff suppressed because it is too large Load Diff

17
haxe/distinfo Normal file
View File

@ -0,0 +1,17 @@
$NetBSD: distinfo,v 1.8 2019/05/15 09:01:03 jaapb Exp $
SHA1 (haxe/ae0d8a85666199b52aed8987c9feaf297c3f66d4.tar.gz) = 1fe37e7d12835b8a79202e7e3c8152f040a2c007
RMD160 (haxe/ae0d8a85666199b52aed8987c9feaf297c3f66d4.tar.gz) = 32e25fb3968a1f7c74d15a76bf7919377f2c0ad1
SHA512 (haxe/ae0d8a85666199b52aed8987c9feaf297c3f66d4.tar.gz) = 2915b3d4933086ee323cddd666d6102e7cab97c05971aa5f13652f640b12a662ab0c735e7a8831ebcf22df1db2bebf5f32061a87bafca6e2e0e128d141067d07
Size (haxe/ae0d8a85666199b52aed8987c9feaf297c3f66d4.tar.gz) = 44432 bytes
SHA1 (haxe/haxe-4.0.0.tar.gz) = 6003a7659a6930902f6e47e5672cfe0befcc219e
RMD160 (haxe/haxe-4.0.0.tar.gz) = 95e7ffd7148d894ad6056f5a3c32a29dd801f009
SHA512 (haxe/haxe-4.0.0.tar.gz) = c7561a0b297c46224b01a8510cc17f0ed5204f2f308132cbc1295336f5455eb6c29618644550186cfb05c304bd2f462c116012f7034e28b1d3446a55381a803c
Size (haxe/haxe-4.0.0.tar.gz) = 8420309 bytes
SHA1 (haxe/haxelib-4.0.0.tar.gz) = bb94e14b59169f56419f019eebabc6376149a3b1
RMD160 (haxe/haxelib-4.0.0.tar.gz) = 8068d862852f9dcb7ee0ab9a22fb2870bc812e37
SHA512 (haxe/haxelib-4.0.0.tar.gz) = 359b70e0a3f6569eea8b4adacbd392a35264430c551de0ff30dd957c69b30e95e94bdfedcbf071f1e8a02e61b5197c034a7923442b19d70b54a71c05c893a330
Size (haxe/haxelib-4.0.0.tar.gz) = 356348 bytes
SHA1 (patch-Makefile) = 05468ec9c8e9b56622a9e585aaa930f5d46dc34d
SHA1 (patch-libs_extc_process__stubs.c) = a2928bb946c34e0151d5faa8f8f93318d0ac32b4
SHA1 (patch-libs_pcre_Makefile) = d5fac6961a555ebb2ce7492b2d3bb3392339884f

View File

@ -0,0 +1,16 @@
$NetBSD$
Support variable PREFIX (without modification)
--- Makefile.orig 2019-10-25 23:09:16.000000000 +0000
+++ Makefile
@@ -10,7 +10,8 @@
#
.SUFFIXES : .ml .mli .cmo .cmi .cmx .mly
-INSTALL_DIR=/usr/local
+PREFIX?=/usr/local
+INSTALL_DIR=$(PREFIX)
INSTALL_BIN_DIR=$(INSTALL_DIR)/bin
INSTALL_LIB_DIR=$(INSTALL_DIR)/lib/haxe
INSTALL_STD_DIR=$(INSTALL_DIR)/share/haxe/std

View File

@ -0,0 +1,16 @@
$NetBSD$
NetBSD support
--- libs/extc/process_stubs.c.orig 2019-10-25 23:09:16.000000000 +0000
+++ libs/extc/process_stubs.c
@@ -37,7 +37,8 @@
# include <errno.h>
# include <string.h>
# ifndef __APPLE__
-# if defined(__FreeBSD__) || defined(__DragonFly__)
+# if defined(__FreeBSD__) || defined(__DragonFly__) \
+ || defined(__NetBSD__)
# include <sys/wait.h>
# else
# include <wait.h>

View File

@ -0,0 +1,14 @@
$NetBSD$
Look for pcre in PREFIX/include.
Done this way because ocamlc wants a space between -I and the argument,
and the libpcre pkg-config file doesn't have the space.
--- libs/pcre/Makefile.orig 2019-10-25 23:09:16.000000000 +0000
+++ libs/pcre/Makefile
@@ -1,4 +1,4 @@
-ALL_CFLAGS = $(CFLAGS) -I pcre
+ALL_CFLAGS = $(CFLAGS) -I @@PREFIX@@/include
LIBS =
OCAMLOPT=ocamlopt
OCAMLC=ocamlc