Also remove the package for DeforaOS Terminal

This commit is contained in:
Pierre Pronchery 2020-01-31 02:25:59 +01:00
parent 9a7abf9db2
commit 2bc532d0cd
8 changed files with 0 additions and 81 deletions

View File

@ -573,7 +573,6 @@ SUBDIR+= deforaos-desktop
SUBDIR+= deforaos-framer
SUBDIR+= deforaos-init
SUBDIR+= deforaos-probe
SUBDIR+= deforaos-terminal
SUBDIR+= deluge
SUBDIR+= delve
SUBDIR+= denyhosts

View File

@ -15,6 +15,5 @@ META_PACKAGE= yes
DEPENDS+= deforaos-accessories>=0.0.3:../../wip/deforaos-accessories
DEPENDS+= deforaos-framer>=0.0.0:../../wip/deforaos-framer
DEPENDS+= deforaos-terminal>=0.0.0:../../wip/deforaos-terminal
.include "../../mk/bsd.pkg.mk"

View File

@ -1,3 +0,0 @@
DeforaOS desktop terminal emulator
This is the GTK3 version.

View File

@ -1,38 +0,0 @@
# $NetBSD: Makefile,v 1.1 2013/03/05 00:53:36 khorben Exp $
#
DISTNAME= Terminal-0.0.0
PKGNAME= deforaos-terminal-0.0.0
CATEGORIES= sysutils
MASTER_SITES= https://www.defora.org/os/download/download/4281/
MAINTAINER= khorben@defora.org
HOMEPAGE= https://www.defora.org/
COMMENT= DeforaOS desktop terminal emulator
LICENSE= gnu-gpl-v3
USE_TOOLS+= pkg-config
USE_TOOLS+= xgettext
BUILD_DEPENDS+= libxslt-[0-9]*:../../textproc/libxslt
BUILD_DEPENDS+= docbook-xsl-[0-9]*:../../textproc/docbook-xsl
MAKE_FLAGS+= DESTDIR=${DESTDIR}
MAKE_FLAGS+= PREFIX=${PREFIX}
AUTO_MKDIRS= yes
DEPENDS+= xterm-[0-9]*:../../x11/xterm
CONFLICTS= xfce4-terminal-[0-9]*
post-install:
${MV} ${DESTDIR}${PREFIX}/share/man/man1/terminal.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/terminal.1
${RMDIR} ${DESTDIR}${PREFIX}/share/man/man1
${RMDIR} ${DESTDIR}${PREFIX}/share/man
.include "options.mk"
.include "../../x11/deforaos-libdesktop/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,6 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2013/03/05 00:53:36 khorben Exp $
bin/terminal
man/man1/terminal.1
share/applications/terminal.desktop
share/doc/html/Terminal/terminal.html
share/locale/fr/LC_MESSAGES/Terminal.mo

View File

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.2 2013/03/05 01:07:05 khorben Exp $
SHA1 (Terminal-0.0.0.tar.gz) = 43e1cdd665d1b8139b7624ff188d6045ac5db6f8
RMD160 (Terminal-0.0.0.tar.gz) = c9b816953916749df0a3d4eea4975d4969785653
Size (Terminal-0.0.0.tar.gz) = 9285 bytes
SHA1 (patch-src_terminal.c) = 89c8d7118645b7316510e815917d47f2b8b868a2

View File

@ -1,10 +0,0 @@
# $NetBSD: options.mk,v 1.1 2013/03/05 00:53:36 khorben Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.deforaos-terminal
PKG_SUPPORTED_OPTIONS= embedded
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Membedded)
MAKE_FLAGS+= CPPFLAGS=-DEMBEDDED
.endif

View File

@ -1,16 +0,0 @@
$NetBSD: patch-src_terminal.c,v 1.1 2013/03/05 01:07:05 khorben Exp $
Fixes build with Gtk+ 3
--- src/terminal.c.orig 2013-02-24 03:45:06.000000000 +0000
+++ src/terminal.c
@@ -26,6 +26,9 @@ char const _license[] =
#include <libintl.h>
#include <gtk/gtk.h>
#include <gdk/gdkkeysyms.h>
+#if GTK_CHECK_VERSION(3, 0, 0)
+# include <gtk/gtkx.h>
+#endif
#include <System.h>
#include <Desktop.h>
#include "terminal.h"