modular-xorg-server: update to 1.19.99.905.

More bugfixes, and streams support for Xwayland. This will almost
certainly be the last RC.
This commit is contained in:
Thomas Klausner 2018-04-25 06:58:55 +02:00
parent efc5659989
commit 34b08ee6b0
3 changed files with 5 additions and 33 deletions

View File

@ -2,7 +2,7 @@
# used by x11/modular-xorg-server/Makefile
# used by x11/modular-xorg-xephyr/Makefile
XORG_VERSION= 1.19.99.904
XORG_VERSION= 1.19.99.905
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XORG:=xserver/}
EXTRACT_SUFX= .tar.bz2

View File

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.87 2018/01/25 15:06:10 jperkin Exp $
SHA1 (xorg-server-1.19.99.904.tar.bz2) = 5bfe19ab814ab8b973c0c4b53547de4e951d3679
RMD160 (xorg-server-1.19.99.904.tar.bz2) = bbed08900bd60cb2892ac9473b403811eb07e2a3
SHA512 (xorg-server-1.19.99.904.tar.bz2) = b9dccc777d0a30c6b40bddffe1f359dde4103539c6598f04bf8cf5f59e6770229221a199c1866b4eba0cf8d2d87fe878985bbd2e3c6ec5b65e3f16195ea8d57e
Size (xorg-server-1.19.99.904.tar.bz2) = 6083787 bytes
SHA1 (xorg-server-1.19.99.905.tar.bz2) = 03db7ca162a907debb8230e207a02274a711c17e
RMD160 (xorg-server-1.19.99.905.tar.bz2) = 7470d0f0e1dfecfc6f480244fdbeb58f6276109f
SHA512 (xorg-server-1.19.99.905.tar.bz2) = 9a6f173835989f7562debfbadae0077d75e35bfad5be1f78931fe46ac43df20591162950b27e2c813fd857114f98247be28d357566e45e5d3ac6b60873d94466
Size (xorg-server-1.19.99.905.tar.bz2) = 6088508 bytes
SHA1 (patch-configure) = 9e9f497f14d563ef66f25c637a14b0bea2243c3f
SHA1 (patch-hw_xfree86_common_xf86pciBus.c) = 896825ba12646431cba603938d118acbdde305dd
SHA1 (patch-hw_xfree86_common_xf86sbusBus.h) = f56f87336b2f669413ebb1005a2b64568a111f92
@ -15,5 +15,4 @@ SHA1 (patch-hw_xfree86_os-support_bus_Sbus.c) = 0035b970bdae1bab51b8ca6bfeed060e
SHA1 (patch-hw_xfree86_os-support_solaris_solaris-amd64.S) = 088a3118deb7567194e08dd46e34cb6edba38400
SHA1 (patch-hw_xfree86_os-support_xf86_OSproc.h) = e1c049857893d2f050d5fb297a3e8ef86f0b1d7e
SHA1 (patch-hw_xfree86_os_support_bus_xf86Sbus.h) = 0e0a243b737f8f762c9f8f24a2265d1b6aefb544
SHA1 (patch-hw_xfree86_sdksyms.sh) = deb79139bb1974f8c8cb160c45398480c64be98e
SHA1 (patch-os_xstrans.c) = 489a4f4b226ecd361b922895204fb9041b065d4e

View File

@ -1,27 +0,0 @@
$NetBSD: patch-hw_xfree86_sdksyms.sh,v 1.1 2016/04/10 07:35:20 tnn Exp $
Kludge sdksyms.c generator to not fail on GetClientPid.
It returns pid_t which on NetBSD is #define pid_t __pid_t
This slightly alters the GCC preprocessor output which this fragile
code could not deal with when using GCC 5+
--- hw/xfree86/sdksyms.sh.orig 2018-04-10 19:46:09.000000000 +0000
+++ hw/xfree86/sdksyms.sh
@@ -373,6 +373,17 @@ BEGIN {
n = 1;
}
}
+ # hack: pid_t becomes __pid_t on NetBSD, same for uint32_t -> __uint32_t.
+ # GCC 5 inserts additional lines around this.
+ if (($1 == "__pid_t" || $1 == "__uint32_t") && NF == 1) {
+ getline;
+ n++;
+ # skip line numbers GCC 5 adds (after typedef return type?)
+ while ($n == "" || $0 ~ /^# [0-9]+ "/) {
+ getline;
+ n = 1;
+ }
+ }
# type specifier may not be set, as in
# extern _X_EXPORT unsigned name(...)