slack-libpurple: Import slack-libpurple-0.0.20201029 as wip/slack-libpurple

A Slack protocol plugin for libpurple IM clients.

Here's how slack concepts are mapped to purple:

  * Your "open" channels (on the slack bar) are mapped to the buddy list:
    joining a channel is equivalent to creating a buddy
  * Which conversations are open in purple is up to you, and has no effect
    on slack... (how to deal with activity in open channels with no
    conversation?)
  * For bitlbee IRC connections, Slack channels are "chat channels" that
    can be added to your configuration with
    "`chat add <account id> #<channel>`"
This commit is contained in:
Leonardo Taccari 2020-11-15 22:49:28 +01:00
parent 9e84cafca2
commit 385ec2c537
6 changed files with 76 additions and 0 deletions

View File

@ -4740,6 +4740,7 @@ SUBDIR+= sjg-mk-files
SUBDIR+= skinlf
SUBDIR+= skippy-xd
SUBDIR+= skype4
SUBDIR+= slack-libpurple
SUBDIR+= slack-term
SUBDIR+= slackpkg2pkgsrc
SUBDIR+= slashem

12
slack-libpurple/DESCR Normal file
View File

@ -0,0 +1,12 @@
A Slack protocol plugin for libpurple IM clients.
Here's how slack concepts are mapped to purple:
* Your "open" channels (on the slack bar) are mapped to the buddy list:
joining a channel is equivalent to creating a buddy
* Which conversations are open in purple is up to you, and has no effect
on slack... (how to deal with activity in open channels with no
conversation?)
* For bitlbee IRC connections, Slack channels are "chat channels" that
can be added to your configuration with
"`chat add <account id> #<channel>`"

18
slack-libpurple/Makefile Normal file
View File

@ -0,0 +1,18 @@
# $NetBSD$
DISTNAME= slack-libpurple-0.0.20201029
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=dylex/}
GITHUB_TAG= fbbd414ba03821cdfc8f91ee40a722c5bdd4dcc5
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/dylex/slack-libpurple/
COMMENT= Slack protocol plugin for libpurple IM clients
LICENSE= gnu-gpl-v2
USE_TOOLS+= gmake pkg-config
USE_LANGUAGES= c99
.include "../../chat/libpurple/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

5
slack-libpurple/PLIST Normal file
View File

@ -0,0 +1,5 @@
@comment $NetBSD$
lib/purple-2/libslack.so
share/pixmaps/pidgin/protocols/16/slack.png
share/pixmaps/pidgin/protocols/22/slack.png
share/pixmaps/pidgin/protocols/48/slack.png

7
slack-libpurple/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (slack-libpurple-0.0.20201029-fbbd414ba03821cdfc8f91ee40a722c5bdd4dcc5.tar.gz) = 4ab577e9956f4e961b4b2dd0ab2818f4c3c81191
RMD160 (slack-libpurple-0.0.20201029-fbbd414ba03821cdfc8f91ee40a722c5bdd4dcc5.tar.gz) = 1d45f9d856118f7fc9bc388442e3ca2418025420
SHA512 (slack-libpurple-0.0.20201029-fbbd414ba03821cdfc8f91ee40a722c5bdd4dcc5.tar.gz) = 11c01989d76a8df0236cf1de561d16820a3bf31425f86b43ec5686a64274e58b8bcb4fced537635de2ba94f449803dd8b4c2fd48f99778e230b9229d298da93d
Size (slack-libpurple-0.0.20201029-fbbd414ba03821cdfc8f91ee40a722c5bdd4dcc5.tar.gz) = 54847 bytes
SHA1 (patch-Makefile) = 7262c4409f9e459d1153272873a2fc92289182d4

View File

@ -0,0 +1,33 @@
$NetBSD$
Honors user's {C,LD}FLAGS.
--- Makefile.orig 2020-10-29 13:36:16.000000000 +0000
+++ Makefile
@@ -35,7 +35,7 @@ CC = $(WIN32_DEV_TOP)/mingw-4.7.2/bin/gc
DATA_ROOT_DIR_PURPLE:="$(PROGFILES32)/Pidgin"
PLUGIN_DIR_PURPLE:="$(DATA_ROOT_DIR_PURPLE)/plugins"
-CFLAGS = \
+CFLAGS += \
-g \
-O2 \
-Wall \
@@ -54,7 +54,7 @@ PLUGIN_DIR_PURPLE:=$(DESTDIR)$(shell pkg
DATA_ROOT_DIR_PURPLE:=$(DESTDIR)$(shell pkg-config --variable=datarootdir $(PURPLE_MOD))
PKGS=$(PURPLE_MOD) glib-2.0 gobject-2.0
-CFLAGS = \
+CFLAGS += \
-g \
-O2 \
-Wall \
@@ -72,7 +72,7 @@ endif
.PHONY: all
all: $(LIBNAME)
-LDFLAGS = -shared
+LDFLAGS += -shared
json.%: json-parser/json.%
cp $< $@