py-adb: Remove, imported

This commit is contained in:
nia 2020-04-04 01:39:18 +01:00
parent daeb78b380
commit 3d28e918b4
8 changed files with 0 additions and 115 deletions

View File

@ -3091,7 +3091,6 @@ SUBDIR+= py-Xlib
SUBDIR+= py-achemkit
SUBDIR+= py-acq4
SUBDIR+= py-adal
SUBDIR+= py-adb
SUBDIR+= py-addons
SUBDIR+= py-adsbibdesk
SUBDIR+= py-aerocalc

View File

@ -1,2 +0,0 @@
bin/pyadb @PREFIX@/bin/pyadb-@PYVERSSUFFIX@
bin/pyfastboot @PREFIX@/bin/pyfastboot-@PYVERSSUFFIX@

View File

@ -1,14 +0,0 @@
This repository contains a pure-python implementation of the Android
ADB and Fastboot protocols, using libusb1 for USB communications.
This is a complete replacement and rearchitecture of the Android
project's ADB and fastboot code available at
https://github.com/android/platform_system_core/tree/master/adb
This code is mainly targeted to users that need to communicate with
Android devices in an automated fashion, such as in automated
testing. It does not have a daemon between the client and the
device, and therefore does not support multiple simultaneous commands
to the same device. It does support any number of devices and never
communicates with a device that it wasn't intended to, unlike the
Android project's ADB.

View File

@ -1,23 +0,0 @@
# $NetBSD: Makefile,v 1.1 2017/04/14 12:10:26 leot Exp $
DISTNAME= adb-1.3.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=a/adb/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/google/python-adb
COMMENT= Pure Python implementation of the Android ADB and Fastboot protocols
LICENSE= apache-2.0
DEPENDS+= ${PYPKGPREFIX}-rsa-[0-9]*:../../security/py-rsa
DEPENDS+= ${PYPKGPREFIX}-libusb1>=1.0.16:../../wip/py-libusb1
USE_LANGUAGES= # none
post-install:
${MV} ${DESTDIR}${PREFIX}/bin/pyadb ${DESTDIR}${PREFIX}/bin/pyadb-${PYVERSSUFFIX} || ${TRUE}
${MV} ${DESTDIR}${PREFIX}/bin/pyfastboot ${DESTDIR}${PREFIX}/bin/pyfastboot-${PYVERSSUFFIX} || ${TRUE}
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,48 +0,0 @@
@comment $NetBSD$
bin/pyadb-${PYVERSSUFFIX}
bin/pyfastboot-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/adb/__init__.py
${PYSITELIB}/adb/__init__.pyc
${PYSITELIB}/adb/__init__.pyo
${PYSITELIB}/adb/adb_commands.py
${PYSITELIB}/adb/adb_commands.pyc
${PYSITELIB}/adb/adb_commands.pyo
${PYSITELIB}/adb/adb_debug.py
${PYSITELIB}/adb/adb_debug.pyc
${PYSITELIB}/adb/adb_debug.pyo
${PYSITELIB}/adb/adb_protocol.py
${PYSITELIB}/adb/adb_protocol.pyc
${PYSITELIB}/adb/adb_protocol.pyo
${PYSITELIB}/adb/common.py
${PYSITELIB}/adb/common.pyc
${PYSITELIB}/adb/common.pyo
${PYSITELIB}/adb/common_cli.py
${PYSITELIB}/adb/common_cli.pyc
${PYSITELIB}/adb/common_cli.pyo
${PYSITELIB}/adb/fastboot.py
${PYSITELIB}/adb/fastboot.pyc
${PYSITELIB}/adb/fastboot.pyo
${PYSITELIB}/adb/fastboot_debug.py
${PYSITELIB}/adb/fastboot_debug.pyc
${PYSITELIB}/adb/fastboot_debug.pyo
${PYSITELIB}/adb/filesync_protocol.py
${PYSITELIB}/adb/filesync_protocol.pyc
${PYSITELIB}/adb/filesync_protocol.pyo
${PYSITELIB}/adb/sign_m2crypto.py
${PYSITELIB}/adb/sign_m2crypto.pyc
${PYSITELIB}/adb/sign_m2crypto.pyo
${PYSITELIB}/adb/sign_pycryptodome.py
${PYSITELIB}/adb/sign_pycryptodome.pyc
${PYSITELIB}/adb/sign_pycryptodome.pyo
${PYSITELIB}/adb/sign_pythonrsa.py
${PYSITELIB}/adb/sign_pythonrsa.pyc
${PYSITELIB}/adb/sign_pythonrsa.pyo
${PYSITELIB}/adb/usb_exceptions.py
${PYSITELIB}/adb/usb_exceptions.pyc
${PYSITELIB}/adb/usb_exceptions.pyo

View File

@ -1,6 +0,0 @@
At the moment this package was only tested using attaching ADB via
the network.
It would be nice to also test it using USB before importing but
unfortunately I have no device adb-able via USB.
-- leot (2018/04/11)

View File

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.1 2017/04/14 12:10:26 leot Exp $
SHA1 (adb-1.3.0.tar.gz) = 5a5ebffbfaffeeba2b36d519ab8bad212c218506
RMD160 (adb-1.3.0.tar.gz) = aa708a57ba992168e43d99f40c7d03783de0ca73
SHA512 (adb-1.3.0.tar.gz) = 0ec5c2acee688498c065cfd136491594631e5410121f9f856cf9d0818af238bbf41f2646bf50b8503873bbd48e9bc97065638d3f4af35ba82681a0c84a26139c
Size (adb-1.3.0.tar.gz) = 27050 bytes
SHA1 (patch-adb_common.py) = 40490613f464bdf28d179ee62bd20b245797254e

View File

@ -1,14 +0,0 @@
$NetBSD$
This fails on NetBSD too.
--- adb/common.py.orig 2018-05-31 08:43:12.000000000 +0000
+++ adb/common.py
@@ -118,6 +118,7 @@ class UsbHandle(object):
iface_number = self._setting.getNumber()
try:
if (platform.system() != 'Windows'
+ and platform.system() != 'NetBSD'
and handle.kernelDriverActive(iface_number)):
handle.detachKernelDriver(iface_number)
except libusb1.USBError as e: