telegram-desktop: added some patches

This commit is contained in:
AcidBear 2020-02-26 17:57:17 +03:00
parent 8d4a92370e
commit 40d4fdb873
16 changed files with 198 additions and 0 deletions

View File

@ -16,9 +16,14 @@ SHA1 (patch-base_platform_url_scheme.h) = a5bc6ea1845572f326fa19af51f5f7a87554e6
SHA1 (patch-build_config.h) = 17bccca2d70671fe0f8345af8a7710c2caa3db19
SHA1 (patch-call_delayed.h) = 935062178537df05e44a2e651bef2030faa613f3
SHA1 (patch-concurrent_timer.h) = 8b2356cbf705bfb9e19af2725475dd9bcd6a33d7
SHA1 (patch-export_api_wrap.h) = 2a492eb102225f05731567106932c7a91f8cd548
SHA1 (patch-export_data_types.h) = 01fa2c695e892172144fa254c7513d087f5e4a9d
SHA1 (patch-export_settings.h) = ffc21f6d2ab3afccacd1dc67a9902f0c54333e80
SHA1 (patch-last_user_input.h) = 961f5a2a308ec973bc8037658c5658ce145627ef
SHA1 (patch-lib_base-CMakeLists.txt) = 940672a38a1168e2cb9835f84aecd3ad0ef041f4
SHA1 (patch-lib_base-crash_report_header.h) = dc48f472c54d91132d2c48ac6e6628bb7ef4cda1
SHA1 (patch-lib_base-openssl_help.h) = 145e29381d9b7b6f3095db0cfc0d380fd3603f8e
SHA1 (patch-lib_export.cmake) = 70d41d6a858fe029b781174940c50eba6a20d9e9
SHA1 (patch-lib_mtproto.cmake) = b82484ff782d10366696f5d40912f17d5d2f6583
SHA1 (patch-lib_storage-CMakeLists.txt) = ef770e3f50f075d251262fc511ef21313f5edab1
SHA1 (patch-libtgvoip-audio-AudioIO.cpp) = 96b482354b3ad6321b3ea95767d0d55ba63dab38
@ -27,10 +32,20 @@ SHA1 (patch-libtgvoip-audio-AudioOutput.cpp) = ec83d33d1158c0e3e8ada0e0458c84347
SHA1 (patch-libtgvoip-threading.h) = 929bd84af9515d15eff00866237df5044912f5e3
SHA1 (patch-libtgvoip-webrtc_dsp-platform_thread_types.cc) = 0c2d20a9ba95acae349519507dc9515fdb7a6cec
SHA1 (patch-libtgvoip-webrtc_dsp-rtc_base-stringutils.h) = fb3f30dac740098d467562b75239fef9fbaa810d
SHA1 (patch-mime_type.h) = ff521f65aa5b858cfdffd68d5f47186692a19802
SHA1 (patch-mtproto-dc_options.h) = 7cd2ee9458755333ca090c6307c4ba68a1451597
SHA1 (patch-mtproto-mtproto_abstract_socket.h) = e5eb4114a4e4095ee2681e4bd143f753139762b2
SHA1 (patch-mtproto-mtproto_bound_key_creator.h) = e93f5415a93fba0a0ab38a0e4132d98795b967ce
SHA1 (patch-mtproto-mtproto_proxy_data.h) = 6819e4faf65eac4d0056b05eef96d76b84516c9f
SHA1 (patch-mtproto_auth_key.h) = 3adc37f261b4ed201405dabca5c18b8dc1f08284
SHA1 (patch-mtproto_dc_key_creator.h) = 20aa938154094e7d6fecef198503c3452d3ba104
SHA1 (patch-mtproto_dcenter.h) = 4ead420e0ecf1b722f868f270ca54f284fccd4d1
SHA1 (patch-mtproto_dh_utils.h) = c41b9f24a785791b4a0b9fb804373454e57dc8ff
SHA1 (patch-mtproto_domain_resolver.h) = a330674e816fa00da9c3459ec3c14c269dcb791b
SHA1 (patch-mtproto_received_ids_manager.h) = a91c498c85a140dfa79fe4973a53c36717da8a8c
SHA1 (patch-mtproto_rpc_sender.h) = 028c7ff9bf8ca0e30f28ce2b40a40773fb120026
SHA1 (patch-mtproto_rsa_public_key.h) = 15dc450b998eae7643dad5bd185f49e4cd66e3f1
SHA1 (patch-mtproto_serialized_request.h) = ea4093416d563168b5ec7d22cdb1c774be175239
SHA1 (patch-observer.h) = 023e0aa9caa7efe3db575db1dc4af7227d84c29c
SHA1 (patch-parse_helper.h) = da283461c598d06bc60e084798ffa207a963e49a
SHA1 (patch-qthelp_url.h) = 2611720a38f9ff4422c9a64f17067ca8bd5f2ec8

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/export/export_api_wrap.h.orig 2020-02-22 15:24:22.773948270 +0000
+++ Telegram/SourceFiles/export/export_api_wrap.h
@@ -7,6 +7,7 @@ https://github.com/telegramdesktop/tdesk
*/
#pragma once
+#include "base/base_pch.h"
#include "mtproto/mtproto_concurrent_sender.h"
namespace Export {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/export/data/export_data_types.h.orig 2020-02-22 19:55:11.523863973 +0000
+++ Telegram/SourceFiles/export/data/export_data_types.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include "scheme.h"
+#include "base/base_pch.h"
#include "base/optional.h"
#include "base/variant.h"

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/export/export_settings.h.orig 2020-01-28 17:45:49.000000000 +0000
+++ Telegram/SourceFiles/export/export_settings.h
@@ -9,6 +9,7 @@ https://github.com/telegramdesktop/tdesk
#include "base/flags.h"
#include "base/flat_map.h"
+#include "mtproto/mtproto_pch.h"
namespace Export {
namespace Output {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/lib_base/base/openssl_help.h.orig 2020-02-20 00:55:39.755225659 +0000
+++ Telegram/lib_base/base/openssl_help.h
@@ -8,6 +8,7 @@
#include "base/bytes.h"
#include "base/algorithm.h"
+#include "base/base_pch.h"
#include "base/basic_types.h"
extern "C" {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/cmake/lib_export.cmake.orig 2020-02-22 02:08:05.861129396 +0000
+++ Telegram/cmake/lib_export.cmake
@@ -8,7 +8,6 @@ add_library(lib_export OBJECT)
init_target(lib_export)
add_library(tdesktop::lib_export ALIAS lib_export)
-target_precompile_headers(lib_export PRIVATE ${src_loc}/export/export_pch.h)
nice_target_sources(lib_export ${src_loc}
PRIVATE
export/export_api_wrap.cpp

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/core/mime_type.h.orig 2020-01-28 17:45:49.000000000 +0000
+++ Telegram/SourceFiles/core/mime_type.h
@@ -6,6 +6,7 @@ For license and copyright information pl
https://github.com/telegramdesktop/tdesktop/blob/master/LEGAL
*/
#pragma once
+#include "export/export_pch.h"
#include <QtCore/QString>
#include <QtCore/QStringList>

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/mtproto_auth_key.h.orig 2020-02-19 20:48:36.335845360 +0000
+++ Telegram/SourceFiles/mtproto/mtproto_auth_key.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include "base/bytes.h"
+#include "mtproto/mtproto_pch.h"
#include <array>
#include <memory>

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/details/mtproto_dc_key_creator.h.orig 2020-02-19 23:58:17.922620995 +0000
+++ Telegram/SourceFiles/mtproto/details/mtproto_dc_key_creator.h
@@ -9,6 +9,7 @@ https://github.com/telegramdesktop/tdesk
#include "mtproto/core_types.h"
#include "mtproto/mtproto_auth_key.h"
+#include "mtproto/mtproto_pch.h"
#include "mtproto/connection_abstract.h"
#include "base/basic_types.h"
#include "base/expected.h"

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/details/mtproto_dcenter.h.orig 2020-02-19 22:44:42.763730721 +0000
+++ Telegram/SourceFiles/mtproto/details/mtproto_dcenter.h
@@ -7,6 +7,7 @@ https://github.com/telegramdesktop/tdesk
*/
#pragma once
+#include "mtproto/mtproto_pch.h"
#include <QtCore/QReadWriteLock>
namespace MTP {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/mtproto_dh_utils.h.orig 2020-02-21 01:46:16.168677004 +0000
+++ Telegram/SourceFiles/mtproto/mtproto_dh_utils.h
@@ -9,6 +9,7 @@ https://github.com/telegramdesktop/tdesk
#include "base/bytes.h"
#include "base/openssl_help.h"
+#include "mtproto/mtproto_pch.h"
namespace MTP {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/details/mtproto_domain_resolver.h.orig 2020-02-20 00:13:03.782166716 +0000
+++ Telegram/SourceFiles/mtproto/details/mtproto_domain_resolver.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include "base/weak_ptr.h"
+#include "mtproto/mtproto_pch.h"
#include <QtCore/QPointer>
#include <QtNetwork/QNetworkReply>

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/details/mtproto_received_ids_manager.h.orig 2020-02-20 00:39:01.478695047 +0000
+++ Telegram/SourceFiles/mtproto/details/mtproto_received_ids_manager.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include "base/flat_map.h"
+#include "mtproto/mtproto_pch.h"
namespace MTP::details {

View File

@ -0,0 +1,15 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/mtproto_rpc_sender.h.orig 2020-01-28 17:45:49.000000000 +0000
+++ Telegram/SourceFiles/mtproto/mtproto_rpc_sender.h
@@ -7,7 +7,10 @@ https://github.com/telegramdesktop/tdesk
*/
#pragma once
+#include "base/basic_types.h"
#include "base/flat_set.h"
+#include "mtproto/mtproto_pch.h"
+
class RPCError {
public:

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/details/mtproto_rsa_public_key.h.orig 2020-02-20 23:33:11.121488512 +0000
+++ Telegram/SourceFiles/mtproto/details/mtproto_rsa_public_key.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include "base/bytes.h"
+#include "mtproto/mtproto_pch.h"
namespace MTP::details {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/mtproto/details/mtproto_serialized_request.h.orig 2020-02-20 23:55:56.201313743 +0000
+++ Telegram/SourceFiles/mtproto/details/mtproto_serialized_request.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include "mtproto/core_types.h"
+#include "mtproto/mtproto_pch.h"
#include <crl/crl_time.h>