libwebsockets: remove, newer version in HEAD

This commit is contained in:
nia 2020-11-02 20:20:51 +01:00
parent 74a3ee88f9
commit 431e0bfa56
8 changed files with 0 additions and 106 deletions

View File

@ -1991,7 +1991,6 @@ SUBDIR+= libvirt
SUBDIR+= libvirt-glib
SUBDIR+= libvterm
SUBDIR+= libwbxml2-patched
SUBDIR+= libwebsockets
SUBDIR+= libxc
SUBDIR+= libxdiff
SUBDIR+= libxml++3

View File

@ -1,22 +0,0 @@
Libwebsockets is a lightweight pure C library built to use minimal CPU and
memory resources, and provide fast throughput in both directions as client or
server.
libwebsockets features
- Provides server and client APIs for RFC6455 v13 ws:// and wss://
websocket protocol, along with http:// and https://
- Can be configured to use OpenSSL, CyaSSL, or WolfSSL to provide fully
encrypted client and server links - including client certificate support
- Lightweight and fast even at 250K connections per thread and beyond -
- performance per byte and performance per MIPS many times better than
traditional solutions
- CMake based project that has been used in a variety of OS contexts including
Linux (uclibc and glibc), ARM-based embedded boards, MBED3, MIPS / OpenWRT,
Windows, Android, Apple iOS and even Tivo. It's used all over the place
including The New York Times customer-facing servers and BMW.
- It includes a stub webserver that is enough to deliver your scripts to the
browser that open websocket connections back to the same server, so it can
solve the entire server side, ws://, wss://, http://, and https:// in one
step. Apache, Java or any other server-side support is not needed.
- Compliant browsers from the last few years are supported on any platform.
- Full-strength SSL suport (test server is A+ on SSLLABS test)

View File

@ -1,18 +0,0 @@
# $NetBSD$
DISTNAME= libwebsockets-1.7.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GITHUB:=warmcat/}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/warmcat/libwebsockets/
COMMENT= Lightweight C library for websocket clients and servers
# LGPL-2.1 with static link exceptions
LICENSE= gnu-lgpl-v2.1
USE_CMAKE= yes
USE_LANGUAGES= c c++
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,9 +0,0 @@
@comment $NetBSD$
include/libwebsockets.h
include/lws_config.h
lib/cmake/libwebsockets/LibwebsocketsConfig.cmake
lib/cmake/libwebsockets/LibwebsocketsConfigVersion.cmake
lib/libwebsockets.a
lib/libwebsockets.so
lib/libwebsockets.so.7
lib/pkgconfig/libwebsockets.pc

View File

@ -1,14 +0,0 @@
# $NetBSD$
BUILDLINK_TREE+= libwebsockets
.if !defined(LIBWEBSOCKETS_BUILDLINK3_MK)
LIBWEBSOCKETS_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libwebsockets+= libwebsockets>=1.7.2
BUILDLINK_PKGSRCDIR.libwebsockets?= ../../wip/libwebsocket
.include "../../security/openssl/buildlink3.mk"
.endif # LIBWEBSOCKETS_BUILDLINK3_MK
BUILDLINK_TREE+= -libwebsockets

View File

@ -1,8 +0,0 @@
$NetBSD$
SHA1 (libwebsockets-1.7.2.tar.gz) = aa5df5138ffd1568cd07c22c5e7c84e8458c71d3
RMD160 (libwebsockets-1.7.2.tar.gz) = 16e89ed29c78c3be14adf99b410592717cb82a3d
SHA512 (libwebsockets-1.7.2.tar.gz) = 4293b06d5586e1742c247697402a92359a3851caad3bb945644c3ab35399e11a1772249ac7ceaa7da9c5d00e5c2d1b723021300a3057aeeb7747dfe05b3e8630
Size (libwebsockets-1.7.2.tar.gz) = 2908161 bytes
SHA1 (patch-lib_libwebsockets.h) = cdde2a026a7ff891753c66d61eba97bc9e699a25
SHA1 (patch-test-server_fuzxy.c) = 04a280a19f6246624b3c7647b4ed598f282ff932

View File

@ -1,15 +0,0 @@
$NetBSD$
--- lib/libwebsockets.h.orig 2016-02-25 02:11:01.000000000 +0000
+++ lib/libwebsockets.h
@@ -140,6 +140,10 @@ struct sockaddr_in;
#else /* NOT WIN32 */
#include <unistd.h>
+#if defined(__NetBSD__)
+#include <netinet/in.h>
+#endif
+
#define LWS_INLINE inline
#define LWS_O_RDONLY O_RDONLY

View File

@ -1,19 +0,0 @@
$NetBSD$
--- test-server/fuzxy.c.orig 2016-02-25 02:11:01.000000000 +0000
+++ test-server/fuzxy.c
@@ -61,6 +61,9 @@
#include <unistd.h>
#include <sys/socket.h>
#endif
+#ifdefined(__NetBSD__)
+#include <netinet/in.h>
+#endif
#define MAX_FUZZ_BUF (1024 * 1024)
@@ -953,4 +956,3 @@ bail1:
return 0;
}
-