tokei: update to 12.0.4a.

Tokei 12 comes with some of the biggest user facing changes since 1.0, now in
the latest version tokei will now **analyse and count multiple languages
embedded in your source code** as well as adding support for
**Jupyter Notebooks**. Now for the first time is able to handle and display
different languages contained in a single source file. This currently available
for a limited set of languages, with plans to add more support for more in the
future. The currently supported languages are;

Tokei will now analyse and report the source code contained in `<script>`,
`<style>`, and `<template>` tags in HTML and other similar languages. Tokei will
read the value of the`type` attribute from the `<script>` tag and detects the
appropriate language based on its mime type or JavaScript if not present. Tokei
will do the same for `<style>` and `<template>` except reading the `lang`
attribute instead of `type` and defaulting to CSS and HTML each respectively.

Tokei will now read Jupyter Notebook files (`.ipynb`) and will read the source
code and markdown from Jupyter's JSON and output the analysed result.

Tokei will now detect any code blocks marked with specified source language and
count each as their respective languages or as Markdown if not present or not
found. Now you can easily see how many code examples are included in
your documentation.

Tokei will now detect blocks of rustdoc documentation  (e.g. `///`/`//!`) and
parse them as markdown.

Tokei is now also capable of handling "verbatim" strings, which are strings that
do not accept escape sequences like `\`. Thanks to @NickHackman for providing
the implementation! This is initially supported for C++, C#, F#, and Rust.

To be able to show these new features, tokei's output has been changed to look
like below. For brevity the CLI only displays one level deep in each language,
however the library's parser is fully recursive and you can get access to the
complete report using the library or by outputting the JSON format.

```
===============================================================================
 Language            Files        Lines         Code     Comments       Blanks
===============================================================================
 BASH                    4           49           30           10            9
 JSON                    1         1332         1332            0            0
 Shell                   1           49           38            1           10
 TOML                    2           77           64            4            9
-------------------------------------------------------------------------------
 Markdown                5         1230            0          965          265
 |- JSON                 1           41           41            0            0
 |- Rust                 2           53           42            6            5
 |- Shell                1           22           18            0            4
 (Total)                           1346          101          971          274
-------------------------------------------------------------------------------
 Rust                   19         3349         2782          116          451
 |- Markdown            12          351            5          295           51
 (Total)                           3700         2787          411          502
===============================================================================
 Total                  32         6553         4352         1397          804
===============================================================================
```

This feature is not just limited to the default output of tokei. You can see it
broken down by each file with the `--files` option.

```
===============================================================================
 Language            Files        Lines         Code     Comments       Blanks
===============================================================================
 Markdown                5         1230            0          965          265
 |- JSON                 1           41           41            0            0
 |- Rust                 2           53           42            6            5
 |- Shell                1           22           18            0            4
 (Total)                           1346          101          971          274
-------------------------------------------------------------------------------
 ./CODE_OF_CONDUCT.md                46            0           28           18
 ./CHANGELOG.md                     570            0          434          136
-- ./markdown.md --------------------------------------------------------------
 |- Markdown                          4            0            3            1
 |- Rust                              6            4            1            1
 |- (Total)                          10            4            4            2
-- ./README.md ----------------------------------------------------------------
 |- Markdown                        498            0          421           77
 |- Shell                            22           18            0            4
 |- (Total)                         520           18          421           81
-- ./CONTRIBUTING.md ----------------------------------------------------------
 |- Markdown                        112            0           79           33
 |- JSON                             41           41            0            0
 |- Rust                             46           38            4            4
 |- (Total)                         200           79           84           37
===============================================================================
 Total                   5         1346          101          971          274
===============================================================================
```

- The JSON Output and format of `Languages` has changed.
- The JSON feature has been removed and is now included by default.
- `Stats` has been split into `Report` and `CodeStats` to better represent the
  separation between analysing a file versus a blob of code.

- @alexmaco Added shebang and env detection for Crystal.
- @NickHackman Updated both Vue and HTML to count CSS & JS comments as comments.
- @XAMPPRocky renamed Perl6's display name to Rakudo.
- @dbackeus Added `erb` extension for Ruby HTML.
- @kobataiwan Tokei will now check for a configuration file in your home
  directory as well as your current and configuration directory.
- @dependabot Updated dependencies

**Added Languages**
- @alexmaco Dhall
- @NickHackman Svelte
- @athas Futhark
- @morphy2k Gohtml
- @LucasMW Headache
- @rosasynstylae Tsx
- @XAMPPRocky OpenType Feature Files

**Added Languages**

- @rubdos Arduino
- @LuqueDaniel Pan
- @itkovian Ren'Py

- Added `LanguageType::shebangs`, `LanguageType::from_file_extension`, and
  `LanguageType::from_shebang`. (@solanav)

**Added languages**

- @bwidawsk GNU Assembly, GDB Script
- @isker Dust, Apache Velocity
- @andreblanke FreeMarker

Thanks to some major internal refactoring, Tokei has received significant
performance improvements, and is now one of the fastest code counters across any
size of codebase. With Tokei 11 showing up to 40–60% faster results than tokei's
previous version. To showcase the improvements I've highlighted benchmarks
of counting five differently sized codebases. Redis (~220k lines), Rust (~16M
lines), and the Unreal Engine (~37.5M lines). In every one of these benchmarks
Tokei 11 performed the best by a noticeable margin.

*All benchmarks were done on a 15-inch MacBook Pro, with a 2.7GHz Intel Core i7
processor and 16GB 2133 MHz LPDDR3 RAM running macOS Catalina 10.15.3. Your
mileage may vary, All benchmarks were done using [hyperfine], using default
settings for all programs.*

[hyperfine]: https://github.com/sharkdp/hyperfine

**Note** This benchmark is not accurate due to `tokei` and `loc` both taking
less than 5ms to complete, there is a high degree of error between the times and
should mostly be considered equivalent. However it is included because it is
notable that `scc` takes nearly 3x as long to complete on smaller codebases
(~5k lines).
![Graph comparing programs running on the tokei source code](https://docs.google.com/spreadsheets/d/e/2PACX-1vRN2Um3G9Mn4Bg6UVWwgntsMy4faZMIP3EDjAfY5Y6Tav7T5z1TxVKmPu7wUNIpUSsSJDfCNH0SAKBB/pubchart?oid=1242634543&format=image)

![Graph comparing programs running on the redis source code](https://docs.google.com/spreadsheets/d/e/2PACX-1vRN2Um3G9Mn4Bg6UVWwgntsMy4faZMIP3EDjAfY5Y6Tav7T5z1TxVKmPu7wUNIpUSsSJDfCNH0SAKBB/pubchart?oid=2009389097&format=image)

![Graph comparing programs running on the rust source code](https://docs.google.com/spreadsheets/d/e/2PACX-1vRN2Um3G9Mn4Bg6UVWwgntsMy4faZMIP3EDjAfY5Y6Tav7T5z1TxVKmPu7wUNIpUSsSJDfCNH0SAKBB/pubchart?oid=424069399&format=image)

![Graph comparing programs running on the unreal source code](https://docs.google.com/spreadsheets/d/e/2PACX-1vRN2Um3G9Mn4Bg6UVWwgntsMy4faZMIP3EDjAfY5Y6Tav7T5z1TxVKmPu7wUNIpUSsSJDfCNH0SAKBB/pubchart?oid=439405321&format=image)

- Added `pyw` extension to Python.
- Updated dependencies

- Fixed `.tokeignore` always working even when `--no-ignore` is present.
- Updated dependencies

**Added languages**

- @erikaxel Gherkin (Cucumber)

- Added `cjsx` extension to CoffeeScript.
- Tokei will now recognise files with `#!/usr/bin/env ruby` as Ruby.
- Updated dependencies.
- Tokei now uses `crossbeam` channels over `std::mpsc`, which should have a
  noticeable performance improvement on large repos.
- Improved documentation for `libtokei`.

**Added languages**

- @lzybkr PowerShell
- @turbo MoonScript
- @dtolnay Thrift
- @Tranzystorek FlatBuffers
- @NieDzejkob Emojicode
- @DanteFalzone0 HolyC
- @sci4me Odin
- @fkarg Rusty Object Notation (RON)
This commit is contained in:
Thomas Klausner 2020-11-09 12:15:03 +01:00
parent c83099e840
commit 4953d0f6cf
6 changed files with 709 additions and 658 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD$
DISTNAME= tokei-10.0.1
DISTNAME= tokei-12.0.4a
CATEGORIES= devel textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=XAMPPRocky/}
DIST_SUBDIR= ${GITHUB_PROJECT}
@ -12,148 +12,15 @@ HOMEPAGE= https://github.com/XAMPPRocky/tokei/
COMMENT= Displays statistics about code
LICENSE= apache-2.0 AND mit
CARGO_CRATE_DEPENDS+= aho-corasick-0.7.3
CARGO_CRATE_DEPENDS+= ansi_term-0.11.0
CARGO_CRATE_DEPENDS+= argon2rs-0.2.5
CARGO_CRATE_DEPENDS+= arrayvec-0.4.10
CARGO_CRATE_DEPENDS+= atty-0.2.11
CARGO_CRATE_DEPENDS+= autocfg-0.1.4
CARGO_CRATE_DEPENDS+= backtrace-0.3.30
CARGO_CRATE_DEPENDS+= backtrace-sys-0.1.28
CARGO_CRATE_DEPENDS+= bitflags-1.1.0
CARGO_CRATE_DEPENDS+= blake2-rfc-0.2.18
CARGO_CRATE_DEPENDS+= block-buffer-0.7.3
CARGO_CRATE_DEPENDS+= block-padding-0.1.4
CARGO_CRATE_DEPENDS+= bstr-0.1.4
CARGO_CRATE_DEPENDS+= byte-tools-0.3.1
CARGO_CRATE_DEPENDS+= bytecount-0.5.1
CARGO_CRATE_DEPENDS+= byteorder-1.3.2
CARGO_CRATE_DEPENDS+= cc-1.0.37
CARGO_CRATE_DEPENDS+= cfg-if-0.1.9
CARGO_CRATE_DEPENDS+= clap-2.33.0
CARGO_CRATE_DEPENDS+= cloudabi-0.0.3
CARGO_CRATE_DEPENDS+= constant_time_eq-0.1.3
CARGO_CRATE_DEPENDS+= crossbeam-channel-0.3.8
CARGO_CRATE_DEPENDS+= crossbeam-deque-0.2.0
CARGO_CRATE_DEPENDS+= crossbeam-epoch-0.3.1
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.2.2
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.6.5
CARGO_CRATE_DEPENDS+= digest-0.8.0
CARGO_CRATE_DEPENDS+= dirs-2.0.1
CARGO_CRATE_DEPENDS+= dirs-sys-0.3.3
CARGO_CRATE_DEPENDS+= dtoa-0.4.4
CARGO_CRATE_DEPENDS+= either-1.5.2
CARGO_CRATE_DEPENDS+= encoding_rs-0.8.17
CARGO_CRATE_DEPENDS+= encoding_rs_io-0.1.6
CARGO_CRATE_DEPENDS+= env_logger-0.6.1
CARGO_CRATE_DEPENDS+= failure-0.1.5
CARGO_CRATE_DEPENDS+= failure_derive-0.1.5
CARGO_CRATE_DEPENDS+= fake-simd-0.1.2
CARGO_CRATE_DEPENDS+= fnv-1.0.6
CARGO_CRATE_DEPENDS+= fuchsia-cprng-0.1.1
CARGO_CRATE_DEPENDS+= generic-array-0.12.0
CARGO_CRATE_DEPENDS+= git2-0.9.1
CARGO_CRATE_DEPENDS+= globset-0.4.3
CARGO_CRATE_DEPENDS+= grep-matcher-0.1.2
CARGO_CRATE_DEPENDS+= grep-searcher-0.1.4
CARGO_CRATE_DEPENDS+= half-1.3.0
CARGO_CRATE_DEPENDS+= handlebars-1.1.0
CARGO_CRATE_DEPENDS+= hex-0.3.2
CARGO_CRATE_DEPENDS+= humantime-1.2.0
CARGO_CRATE_DEPENDS+= idna-0.1.5
CARGO_CRATE_DEPENDS+= ignore-0.4.7
CARGO_CRATE_DEPENDS+= itoa-0.4.4
CARGO_CRATE_DEPENDS+= kernel32-sys-0.2.2
CARGO_CRATE_DEPENDS+= lazy_static-1.3.0
CARGO_CRATE_DEPENDS+= libc-0.2.58
CARGO_CRATE_DEPENDS+= libgit2-sys-0.8.0
CARGO_CRATE_DEPENDS+= libz-sys-1.0.25
CARGO_CRATE_DEPENDS+= linked-hash-map-0.5.2
CARGO_CRATE_DEPENDS+= log-0.4.6
CARGO_CRATE_DEPENDS+= maplit-1.0.1
CARGO_CRATE_DEPENDS+= matches-0.1.8
CARGO_CRATE_DEPENDS+= memchr-2.2.0
CARGO_CRATE_DEPENDS+= memmap-0.7.0
CARGO_CRATE_DEPENDS+= memoffset-0.2.1
CARGO_CRATE_DEPENDS+= nodrop-0.1.13
CARGO_CRATE_DEPENDS+= num_cpus-1.10.1
CARGO_CRATE_DEPENDS+= numtoa-0.1.0
CARGO_CRATE_DEPENDS+= opaque-debug-0.2.2
CARGO_CRATE_DEPENDS+= percent-encoding-1.0.1
CARGO_CRATE_DEPENDS+= pest-2.1.1
CARGO_CRATE_DEPENDS+= pest_derive-2.1.0
CARGO_CRATE_DEPENDS+= pest_generator-2.1.0
CARGO_CRATE_DEPENDS+= pest_meta-2.1.1
CARGO_CRATE_DEPENDS+= pkg-config-0.3.14
CARGO_CRATE_DEPENDS+= proc-macro2-0.4.30
CARGO_CRATE_DEPENDS+= quick-error-1.2.2
CARGO_CRATE_DEPENDS+= quote-0.6.12
CARGO_CRATE_DEPENDS+= rand-0.6.5
CARGO_CRATE_DEPENDS+= rand_chacha-0.1.1
CARGO_CRATE_DEPENDS+= rand_core-0.3.1
CARGO_CRATE_DEPENDS+= rand_core-0.4.0
CARGO_CRATE_DEPENDS+= rand_hc-0.1.0
CARGO_CRATE_DEPENDS+= rand_isaac-0.1.1
CARGO_CRATE_DEPENDS+= rand_jitter-0.1.4
CARGO_CRATE_DEPENDS+= rand_os-0.1.3
CARGO_CRATE_DEPENDS+= rand_pcg-0.1.2
CARGO_CRATE_DEPENDS+= rand_xorshift-0.1.1
CARGO_CRATE_DEPENDS+= rayon-1.0.3
CARGO_CRATE_DEPENDS+= rayon-core-1.4.1
CARGO_CRATE_DEPENDS+= rdrand-0.4.0
CARGO_CRATE_DEPENDS+= redox_syscall-0.1.54
CARGO_CRATE_DEPENDS+= redox_termios-0.1.1
CARGO_CRATE_DEPENDS+= redox_users-0.3.0
CARGO_CRATE_DEPENDS+= regex-1.1.7
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.7
CARGO_CRATE_DEPENDS+= remove_dir_all-0.5.1
CARGO_CRATE_DEPENDS+= rustc-demangle-0.1.15
CARGO_CRATE_DEPENDS+= ryu-0.2.8
CARGO_CRATE_DEPENDS+= same-file-1.0.4
CARGO_CRATE_DEPENDS+= scoped_threadpool-0.1.9
CARGO_CRATE_DEPENDS+= scopeguard-0.3.3
CARGO_CRATE_DEPENDS+= serde-1.0.92
CARGO_CRATE_DEPENDS+= serde_cbor-0.9.0
CARGO_CRATE_DEPENDS+= serde_derive-1.0.92
CARGO_CRATE_DEPENDS+= serde_json-1.0.39
CARGO_CRATE_DEPENDS+= serde_yaml-0.8.9
CARGO_CRATE_DEPENDS+= sha-1-0.8.1
CARGO_CRATE_DEPENDS+= smallvec-0.6.10
CARGO_CRATE_DEPENDS+= strsim-0.8.0
CARGO_CRATE_DEPENDS+= syn-0.15.35
CARGO_CRATE_DEPENDS+= synstructure-0.10.2
CARGO_CRATE_DEPENDS+= tempfile-3.0.8
CARGO_CRATE_DEPENDS+= term_size-0.3.1
CARGO_CRATE_DEPENDS+= termcolor-1.0.5
CARGO_CRATE_DEPENDS+= termion-1.5.2
CARGO_CRATE_DEPENDS+= textwrap-0.11.0
CARGO_CRATE_DEPENDS+= thread_local-0.3.6
CARGO_CRATE_DEPENDS+= toml-0.5.1
CARGO_CRATE_DEPENDS+= typenum-1.10.0
CARGO_CRATE_DEPENDS+= ucd-trie-0.1.1
CARGO_CRATE_DEPENDS+= ucd-util-0.1.3
CARGO_CRATE_DEPENDS+= unicode-bidi-0.3.4
CARGO_CRATE_DEPENDS+= unicode-normalization-0.1.8
CARGO_CRATE_DEPENDS+= unicode-width-0.1.5
CARGO_CRATE_DEPENDS+= unicode-xid-0.1.0
CARGO_CRATE_DEPENDS+= url-1.7.2
CARGO_CRATE_DEPENDS+= utf8-ranges-1.0.3
CARGO_CRATE_DEPENDS+= vcpkg-0.2.6
CARGO_CRATE_DEPENDS+= vec_map-0.8.1
CARGO_CRATE_DEPENDS+= walkdir-2.2.8
CARGO_CRATE_DEPENDS+= winapi-0.2.8
CARGO_CRATE_DEPENDS+= winapi-0.3.7
CARGO_CRATE_DEPENDS+= winapi-build-0.1.1
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-util-0.1.2
CARGO_CRATE_DEPENDS+= winapi-x86_64-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= wincolor-1.0.1
CARGO_CRATE_DEPENDS+= yaml-rust-0.4.3
.include "cargo-depends.mk"
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
INSTALLATION_DIRS= bin
post-install:
${RM} ${DESTDIR}${PREFIX}/.crates2.json
.include "../../wip/mk/cargo-binary.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,3 +1,2 @@
@comment $NetBSD$
.crates2.json
bin/tokei

View File

@ -1 +0,0 @@
This installs a ${PREFIX}/.crates2.json file, which it should not.

152
tokei/cargo-depends.mk Normal file
View File

@ -0,0 +1,152 @@
# $NetBSD$
CARGO_CRATE_DEPENDS+= ahash-0.3.8
CARGO_CRATE_DEPENDS+= aho-corasick-0.7.13
CARGO_CRATE_DEPENDS+= ansi_term-0.11.0
CARGO_CRATE_DEPENDS+= arrayref-0.3.6
CARGO_CRATE_DEPENDS+= arrayvec-0.4.12
CARGO_CRATE_DEPENDS+= arrayvec-0.5.1
CARGO_CRATE_DEPENDS+= atty-0.2.14
CARGO_CRATE_DEPENDS+= autocfg-1.0.0
CARGO_CRATE_DEPENDS+= base64-0.11.0
CARGO_CRATE_DEPENDS+= bitflags-1.2.1
CARGO_CRATE_DEPENDS+= blake2b_simd-0.5.10
CARGO_CRATE_DEPENDS+= block-buffer-0.7.3
CARGO_CRATE_DEPENDS+= block-padding-0.1.5
CARGO_CRATE_DEPENDS+= bstr-0.2.13
CARGO_CRATE_DEPENDS+= byte-tools-0.3.1
CARGO_CRATE_DEPENDS+= bytecount-0.6.0
CARGO_CRATE_DEPENDS+= byteorder-1.3.4
CARGO_CRATE_DEPENDS+= cc-1.0.54
CARGO_CRATE_DEPENDS+= cfg-if-0.1.10
CARGO_CRATE_DEPENDS+= chrono-0.4.11
CARGO_CRATE_DEPENDS+= chrono-tz-0.5.2
CARGO_CRATE_DEPENDS+= clap-2.33.3
CARGO_CRATE_DEPENDS+= cloudabi-0.1.0
CARGO_CRATE_DEPENDS+= const-random-0.1.8
CARGO_CRATE_DEPENDS+= const-random-macro-0.1.8
CARGO_CRATE_DEPENDS+= constant_time_eq-0.1.5
CARGO_CRATE_DEPENDS+= crossbeam-channel-0.4.2
CARGO_CRATE_DEPENDS+= crossbeam-deque-0.7.3
CARGO_CRATE_DEPENDS+= crossbeam-epoch-0.8.2
CARGO_CRATE_DEPENDS+= crossbeam-queue-0.2.3
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.7.2
CARGO_CRATE_DEPENDS+= dashmap-3.11.10
CARGO_CRATE_DEPENDS+= deunicode-0.4.3
CARGO_CRATE_DEPENDS+= digest-0.8.1
CARGO_CRATE_DEPENDS+= dirs-2.0.2
CARGO_CRATE_DEPENDS+= dirs-sys-0.3.5
CARGO_CRATE_DEPENDS+= dtoa-0.4.6
CARGO_CRATE_DEPENDS+= either-1.5.3
CARGO_CRATE_DEPENDS+= encoding_rs-0.8.23
CARGO_CRATE_DEPENDS+= encoding_rs_io-0.1.7
CARGO_CRATE_DEPENDS+= env_logger-0.7.1
CARGO_CRATE_DEPENDS+= fake-simd-0.1.2
CARGO_CRATE_DEPENDS+= fnv-1.0.7
CARGO_CRATE_DEPENDS+= generic-array-0.12.3
CARGO_CRATE_DEPENDS+= getrandom-0.1.14
CARGO_CRATE_DEPENDS+= git2-0.13.6
CARGO_CRATE_DEPENDS+= globset-0.4.5
CARGO_CRATE_DEPENDS+= globwalk-0.8.0
CARGO_CRATE_DEPENDS+= grep-matcher-0.1.4
CARGO_CRATE_DEPENDS+= grep-searcher-0.1.7
CARGO_CRATE_DEPENDS+= half-1.6.0
CARGO_CRATE_DEPENDS+= hermit-abi-0.1.14
CARGO_CRATE_DEPENDS+= hex-0.4.2
CARGO_CRATE_DEPENDS+= humansize-1.1.0
CARGO_CRATE_DEPENDS+= humantime-1.3.0
CARGO_CRATE_DEPENDS+= idna-0.2.0
CARGO_CRATE_DEPENDS+= ignore-0.4.16
CARGO_CRATE_DEPENDS+= instant-0.1.5
CARGO_CRATE_DEPENDS+= itoa-0.4.6
CARGO_CRATE_DEPENDS+= jobserver-0.1.21
CARGO_CRATE_DEPENDS+= lazy_static-1.4.0
CARGO_CRATE_DEPENDS+= libc-0.2.71
CARGO_CRATE_DEPENDS+= libgit2-sys-0.12.7+1.0.0
CARGO_CRATE_DEPENDS+= libz-sys-1.0.25
CARGO_CRATE_DEPENDS+= linked-hash-map-0.5.3
CARGO_CRATE_DEPENDS+= lock_api-0.4.0
CARGO_CRATE_DEPENDS+= log-0.4.8
CARGO_CRATE_DEPENDS+= maplit-1.0.2
CARGO_CRATE_DEPENDS+= matches-0.1.8
CARGO_CRATE_DEPENDS+= maybe-uninit-2.0.0
CARGO_CRATE_DEPENDS+= memchr-2.3.3
CARGO_CRATE_DEPENDS+= memmap-0.7.0
CARGO_CRATE_DEPENDS+= memoffset-0.5.4
CARGO_CRATE_DEPENDS+= nodrop-0.1.14
CARGO_CRATE_DEPENDS+= num-format-0.4.0
CARGO_CRATE_DEPENDS+= num-integer-0.1.43
CARGO_CRATE_DEPENDS+= num-traits-0.2.12
CARGO_CRATE_DEPENDS+= num_cpus-1.13.0
CARGO_CRATE_DEPENDS+= once_cell-1.4.0
CARGO_CRATE_DEPENDS+= opaque-debug-0.2.3
CARGO_CRATE_DEPENDS+= parking_lot-0.11.0
CARGO_CRATE_DEPENDS+= parking_lot_core-0.8.0
CARGO_CRATE_DEPENDS+= parse-zoneinfo-0.3.0
CARGO_CRATE_DEPENDS+= percent-encoding-2.1.0
CARGO_CRATE_DEPENDS+= pest-2.1.3
CARGO_CRATE_DEPENDS+= pest_derive-2.1.0
CARGO_CRATE_DEPENDS+= pest_generator-2.1.3
CARGO_CRATE_DEPENDS+= pest_meta-2.1.3
CARGO_CRATE_DEPENDS+= pkg-config-0.3.17
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.8
CARGO_CRATE_DEPENDS+= proc-macro-hack-0.5.16
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.18
CARGO_CRATE_DEPENDS+= quick-error-1.2.3
CARGO_CRATE_DEPENDS+= quote-1.0.7
CARGO_CRATE_DEPENDS+= rand-0.7.3
CARGO_CRATE_DEPENDS+= rand_chacha-0.2.2
CARGO_CRATE_DEPENDS+= rand_core-0.5.1
CARGO_CRATE_DEPENDS+= rand_hc-0.2.0
CARGO_CRATE_DEPENDS+= rayon-1.3.1
CARGO_CRATE_DEPENDS+= rayon-core-1.7.1
CARGO_CRATE_DEPENDS+= redox_syscall-0.1.56
CARGO_CRATE_DEPENDS+= redox_users-0.3.4
CARGO_CRATE_DEPENDS+= regex-1.3.9
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.18
CARGO_CRATE_DEPENDS+= remove_dir_all-0.5.3
CARGO_CRATE_DEPENDS+= rust-argon2-0.7.0
CARGO_CRATE_DEPENDS+= ryu-1.0.5
CARGO_CRATE_DEPENDS+= same-file-1.0.6
CARGO_CRATE_DEPENDS+= scopeguard-1.1.0
CARGO_CRATE_DEPENDS+= serde-1.0.115
CARGO_CRATE_DEPENDS+= serde_cbor-0.11.1
CARGO_CRATE_DEPENDS+= serde_derive-1.0.115
CARGO_CRATE_DEPENDS+= serde_json-1.0.57
CARGO_CRATE_DEPENDS+= serde_yaml-0.8.13
CARGO_CRATE_DEPENDS+= sha-1-0.8.2
CARGO_CRATE_DEPENDS+= slug-0.1.4
CARGO_CRATE_DEPENDS+= smallvec-1.4.0
CARGO_CRATE_DEPENDS+= strsim-0.8.0
CARGO_CRATE_DEPENDS+= syn-1.0.33
CARGO_CRATE_DEPENDS+= tempfile-3.1.0
CARGO_CRATE_DEPENDS+= tera-1.5.0
CARGO_CRATE_DEPENDS+= term_size-0.3.2
CARGO_CRATE_DEPENDS+= termcolor-1.1.0
CARGO_CRATE_DEPENDS+= textwrap-0.11.0
CARGO_CRATE_DEPENDS+= thread_local-1.0.1
CARGO_CRATE_DEPENDS+= time-0.1.43
CARGO_CRATE_DEPENDS+= tinyvec-0.3.3
CARGO_CRATE_DEPENDS+= toml-0.5.6
CARGO_CRATE_DEPENDS+= typenum-1.12.0
CARGO_CRATE_DEPENDS+= ucd-trie-0.1.3
CARGO_CRATE_DEPENDS+= unic-char-property-0.9.0
CARGO_CRATE_DEPENDS+= unic-char-range-0.9.0
CARGO_CRATE_DEPENDS+= unic-common-0.9.0
CARGO_CRATE_DEPENDS+= unic-segment-0.9.0
CARGO_CRATE_DEPENDS+= unic-ucd-segment-0.9.0
CARGO_CRATE_DEPENDS+= unic-ucd-version-0.9.0
CARGO_CRATE_DEPENDS+= unicode-bidi-0.3.4
CARGO_CRATE_DEPENDS+= unicode-normalization-0.1.13
CARGO_CRATE_DEPENDS+= unicode-width-0.1.7
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.0
CARGO_CRATE_DEPENDS+= url-2.1.1
CARGO_CRATE_DEPENDS+= vcpkg-0.2.10
CARGO_CRATE_DEPENDS+= vec_map-0.8.2
CARGO_CRATE_DEPENDS+= walkdir-2.3.1
CARGO_CRATE_DEPENDS+= wasi-0.9.0+wasi-snapshot-preview1
CARGO_CRATE_DEPENDS+= winapi-0.3.8
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-util-0.1.5
CARGO_CRATE_DEPENDS+= winapi-x86_64-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= yaml-rust-0.4.4

File diff suppressed because it is too large Load Diff

View File

@ -1,17 +0,0 @@
$NetBSD$
Upstream commit afc44415a202504ac3f6990c74c8c1619fddb33a
by Erin Power <xampprocky@gmail.com> to prevent cargo updating the
lockfile, which is not possible with --frozen --locked
--- Cargo.lock~
+++ Cargo.lock
@@ -961,7 +961,7 @@ dependencies = [
[[package]]
name = "tokei"
-version = "10.0.0"
+version = "10.0.1"
dependencies = [
"clap 2.33.0 (registry+https://github.com/rust-lang/crates.io-index)",
"dirs 2.0.1 (registry+https://github.com/rust-lang/crates.io-index)",