wip/i3lock-color: import i3lock-color-2.12.c.5

i3lock improves slock by making it fork() and therefore combinable with
commands to suspend your computer. Additionally, instead of turning off
your screen via DPMS and/or displaying a black screen, i3lock displays
a white screen so you can see if your computer failed to resume from
suspend or if your screen is just locked. Also, when entering a wrong
password, i3lock does not call XBell(). This is important because
i3lock/slock think you've entered a password when resuming from suspend,
at least sometimes.
This commit is contained in:
Kamil Rytarowski 2020-10-21 21:36:08 +02:00
parent eed1e6ea16
commit 4c1c047e65
6 changed files with 91 additions and 0 deletions

8
i3lock-color/DESCR Normal file
View File

@ -0,0 +1,8 @@
i3lock improves slock by making it fork() and therefore combinable with
commands to suspend your computer. Additionally, instead of turning off
your screen via DPMS and/or displaying a black screen, i3lock displays
a white screen so you can see if your computer failed to resume from
suspend or if your screen is just locked. Also, when entering a wrong
password, i3lock does not call XBell(). This is important because
i3lock/slock think you've entered a password when resuming from suspend,
at least sometimes.

12
i3lock-color/MESSAGE Normal file
View File

@ -0,0 +1,12 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2016/06/11 23:00:13 kamil Exp $
You need to copy the i3lock PAM configuration file to your PAM
configuration directory (typically /etc/pam.d). You can find a sample
file in:
${EGDIR}/pam.d/i3lock
It may need to be manually adjusted.
===========================================================================

42
i3lock-color/Makefile Normal file
View File

@ -0,0 +1,42 @@
# $NetBSD$
DISTNAME= i3lock-color-2.12.c.5
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GITHUB:=Raymo111/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://i3wm.org/i3lock/
COMMENT= Slightly improved screen locker based on slock
LICENSE= modified-bsd
USE_TOOLS+= gmake pkg-config autoconf automake autoreconf
USE_LANGUAGES= c99
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR}
INSTALL_MAKE_FLAGS+= sysconfdir=${PREFIX}/share/examples/i3lock
EGDIR= ${PREFIX}/share/examples/i3lock
MESSAGE_SUBST+= EGDIR=${EGDIR}
MAKE_DIRS+= ${PKG_SYSCONFBASEDIR}/pam.d
CONF_FILES+= ${EGDIR}/pam.d/i3lock ${PKG_SYSCONFBASEDIR}/pam.d/i3lock
CONFLICTS+= i3lock-[0-9]*
pre-configure:
${RUN} cd ${WRKSRC} && autoreconf -if
.include "../../devel/libev/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../x11/libxcb/buildlink3.mk"
.include "../../x11/libxkbcommon/buildlink3.mk"
.include "../../x11/xcb-util/buildlink3.mk"
.include "../../x11/xcb-util-image/buildlink3.mk"
#.include "../../x11/xcb-util-keysyms/buildlink3.mk"
.include "../../x11/xcb-util-xrm/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../mk/pam.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

4
i3lock-color/PLIST Normal file
View File

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2016/06/11 23:00:13 kamil Exp $
bin/i3lock
man/man1/i3lock.1
share/examples/i3lock/pam.d/i3lock

7
i3lock-color/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.2 2016/06/12 19:48:02 kamil Exp $
SHA1 (i3lock-color-2.12.c.5.tar.gz) = 813eafc4daa794045759abf80e8d274ef1b36ce2
RMD160 (i3lock-color-2.12.c.5.tar.gz) = d50e44560f2d4fc2b12e1054cc74547c3a2a4310
SHA512 (i3lock-color-2.12.c.5.tar.gz) = b579a9511c9c4220db2b9bc406b76fd9daac5dff27c8e7a646bc2c0feb15edf6a136c26a0945684791e0be554c0ce56fe986d79cc8a9b572c6d584be52f61b89
Size (i3lock-color-2.12.c.5.tar.gz) = 208461 bytes
SHA1 (patch-jpg.c) = 2da0ba7d6ac2080991a47dad91e9813133f76a8f

View File

@ -0,0 +1,18 @@
$NetBSD$
Build with both jpeg and libjpeg-turbo.
--- jpg.c.orig 2020-08-05 04:57:41.000000000 +0000
+++ jpg.c
@@ -67,7 +67,11 @@ void* read_JPEG_file(char *file_path, JP
// BGRA + endianness change = RGBA?
// TODO: Test this code on non-x86_64 platforms
+#ifdef JCS_EXTENSIONS
cinfo.out_color_space = JCS_EXT_BGRA;
+#else
+ cinfo.out_color_space = JCS_RGB;
+#endif
(void) jpeg_start_decompress(&cinfo);