sabnzbd: update to 3.0.2. No more python2 needed!

Fixed CVE-2020-13124 by upgrading.

Release Notes - SABnzbd 3.0.2
Bugfixes since 3.0.1

    Priority was not parsed correctly if supplied as through the API.
    API-call addfile could fail if name and nzbfile were used.
    Permissions were still not set correctly when creating directories.
    Propagation delay label was shown even if no delay was activated.
    Reading RSS feed with no categories set could result in crash.
    Jobs with numeric names could crash post-processing.
    Jobs with missing articles could result in crash.
    macOS: changed the power assertion to NoIdleSleep.
    Windows: end-of-queue-script did not run on Windows.
    Windows: crash if the virus scanner removed the certificate bundle.

Bugfixes since 3.0.0

    Basic Authentication resulted in crash.
    Permissions were not set correctly when creating directories.
    Windows: base SSL certificate bundle was not included.

About the new major version

We have been working for months to upgrade the SABnzbd code from Python 2 to Python 3.
Although it might not sound like a big change, we had to rewrite almost every part of
the code. We also included a number of new features, listed below.
Big changes in 3.0.0

    Python 3.5 and above are the only supported versions of Python.
    Cache handling is greatly improved, resulting in more stable speeds on some systems.
    Articles failing with CRC errors are now retried on other servers.
    SFV files, even obfuscated, will be used for renaming when there are no par2 files.
    Fully obfuscated RAR-sets with no verification files are detected and extracted.
    Built-in internet bandwidth test.
    Windows Service support was changed. The service will need to be reinstalled!
    Documentation: https://sabnzbd.org/wiki/advanced/sabnzbd-as-a-windows-service
    The Windows installer is 64-bit only, for 32-bit please use the standalone package.

Other changes since 2.3.9

    Files inside an NZB that are fully identical are now skipped automatically.
    Folders of jobs that failed post-processing are renamed to _FAILED_.
    Blocking of unwanted extensions that are directly inside an NZB.
    In Python 3 OpenSSL 1.1.1 is used for Windows and macOS, as a result
    newsservers manually set to RC4-MD5 cipher can no longer connect.
    Documentation: https://sabnzbd.org/wiki/advanced/ssl-ciphers
    TLS1.3 support for newsserver connections.
    SABYenc, par2 and unrar are now required to start downloading.
    Growl-support was removed.
    The smpl skin was removed.
    Using the API with output=text to add NZB's will report the nzo_ids instead of ok.
    Queue-item labels are no longer part of the name but separated in API-property labels.
    API-calls tapi and qstatus were removed.
    On Windows only Multipar is available for repair.
    Linux tray icon support was improved.
    On Linux special permission bits are removed from files after download.
    macOS features such as the menu and notifications now use native code.

Bugfixes since 2.3.9

    Resolved potential security issue in FAT-filesystem check and Nice and IONice Parameters.
    More information: https://github.com/sabnzbd/sabnzbd/security/advisories/GHSA-9x87-96gg-33w2
    Sample removal did not work if only 1 sample file was present.
    Crash on badly formatted RSS-feeds or readout during editing.
    Only really run pre-queue-script when it is set.
    Always report API paused status as a boolean.
    Automatic aborting of jobs that can't be completed would sometimes not trigger.
    Windows systems could enter standby state during downloading.
    Some errors thrown by unrar were not caught.
    Files and sockets were not always closed correctly.
    Unwanted extension check was overly aggressively deleting folders

Upgrade notices

    When upgrading from 2.x.x or older the queue will be converted. Job order,
    settings and data will be preserved, but if you decide to go back to 2.x.x
    your queue cannot be downgraded again. But you can restore the jobs by going
    to the Status page and running Queue Repair.
This commit is contained in:
Olaf Seibert 2020-09-08 21:46:19 +02:00
parent 82c94726f7
commit 54a634fc63
6 changed files with 117 additions and 149 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.6 2015/02/04 10:10:53 thomasklausner Exp $
DISTNAME= sabnzbd-${DISTVERSION}
DISTVERSION= 2.3.9
DISTVERSION= 3.0.2
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_GITHUB:=sabnzbd/}
GITHUB_PROJECT= sabnzbd
@ -13,12 +13,16 @@ HOMEPAGE= https://sabnzbd.org/
COMMENT= Web-interface based binary newsgrabber in python, with nzb support
LICENSE= gnu-gpl-v2 AND gnu-gpl-v3 AND modified-bsd AND mit
DEPENDS+= ${PYPKGPREFIX}-cheetah-[0-9]*:../../devel/py-cheetah
DEPENDS+= ${PYPKGPREFIX}-cheetah-[0-9]*:../../devel/py-cheetah3
DEPENDS+= ${PYPKGPREFIX}-cryptography-[0-9]*:../../security/py-cryptography
DEPENDS+= ${PYPKGPREFIX}-sabyenc-[0-9]*:../../wip/py-sabyenc
DEPENDS+= ${PYPKGPREFIX}-sabyenc3-[0-9]*:../../wip/py-sabyenc3
DEPENDS+= ${PYPKGPREFIX}-sqlite3-[0-9]*:../../databases/py-sqlite3
# DEPENDS+= ${PYPKGPREFIX}-configobj-[0-9]*:../../devel/py-configobj #??
# DEPENDS+= ${PYPKGPREFIX}-xml-[0-9]*:../../textproc/py-xml #??
DEPENDS+= ${PYPKGPREFIX}-chardet-[0-9]*:../../converters/py-chardet
DEPENDS+= ${PYPKGPREFIX}-configobj-[0-9]*:../../devel/py-configobj
DEPENDS+= ${PYPKGPREFIX}-portend-[0-9]*:../../net/py-portend
DEPENDS+= ${PYPKGPREFIX}-cherrypy>=18.2:../../www/py-cherrypy
DEPENDS+= par2-[0-9]*:../../archivers/par2
DEPENDS+= unrar-[0-9]*:../../archivers/unrar
# in options.mk
#DEPENDS+= par2-[0-9]*:../../archivers/par2
@ -27,11 +31,10 @@ DEPENDS+= unzip-[0-9]*:../../archivers/unzip
DEPENDS+= p7zip-[0-9]*:../../archivers/p7zip
NO_BUILD= yes
#PYDISTUTILSPKG= YES
USE_TOOLS= pax
USE_LANGUAGES+= c
PYTHON_VERSIONS_ACCEPTED= 27 # py-cheetah, py-xml
PYTHON_VERSIONS_ACCEPTED= 38 37 36
.include "options.mk"
@ -41,10 +44,10 @@ PKG_HOME.sabnzbd= ${PREFIX}/sabnzbd
OWN_DIRS_PERMS= ${PREFIX}/sabnzbd sabnzbd sabnzbd 0755
INSTALLATION_DIRS+= cherrypy gntp interfaces po tools util
INSTALLATION_DIRS+= email icons interfaces po sabnzbd scripts tools
PY_PATCHPLIST= yes
REPLACE_PYTHON= *.py */*.py */*/*.py cherrypy/cherryd
REPLACE_PYTHON= *.py */*.py */*/*.py
SUBST_CLASSES+= fix-paths
SUBST_STAGE.fix-paths= pre-configure

View File

@ -16,6 +16,7 @@ ${PYSITELIB}/sabnzbd/dirscanner.py
${PYSITELIB}/sabnzbd/downloader.py
${PYSITELIB}/sabnzbd/emailer.py
${PYSITELIB}/sabnzbd/encoding.py
${PYSITELIB}/sabnzbd/filesystem.py
${PYSITELIB}/sabnzbd/getipaddress.py
${PYSITELIB}/sabnzbd/interface.py
${PYSITELIB}/sabnzbd/lang.py
@ -23,6 +24,7 @@ ${PYSITELIB}/sabnzbd/misc.py
${PYSITELIB}/sabnzbd/newsunpack.py
${PYSITELIB}/sabnzbd/newswrapper.py
${PYSITELIB}/sabnzbd/notifier.py
${PYSITELIB}/sabnzbd/nzbparser.py
${PYSITELIB}/sabnzbd/nzbqueue.py
${PYSITELIB}/sabnzbd/nzbstuff.py
${PYSITELIB}/sabnzbd/osxmenu.py
@ -39,83 +41,38 @@ ${PYSITELIB}/sabnzbd/skintext.py
${PYSITELIB}/sabnzbd/sorting.py
${PYSITELIB}/sabnzbd/urlgrabber.py
${PYSITELIB}/sabnzbd/utils/__init__.py
${PYSITELIB}/sabnzbd/utils/apireg.py
${PYSITELIB}/sabnzbd/utils/certgen.py
${PYSITELIB}/sabnzbd/utils/checkdir.py
${PYSITELIB}/sabnzbd/utils/configobj.py
${PYSITELIB}/sabnzbd/utils/diskspeed.py
${PYSITELIB}/sabnzbd/utils/feedparser.py
${PYSITELIB}/sabnzbd/utils/getperformance.py
${PYSITELIB}/sabnzbd/utils/happyeyeballs.py
${PYSITELIB}/sabnzbd/utils/json.py
${PYSITELIB}/sabnzbd/utils/internetspeed.py
${PYSITELIB}/sabnzbd/utils/kronos.py
${PYSITELIB}/sabnzbd/utils/pathbrowser.py
${PYSITELIB}/sabnzbd/utils/pybonjour.py
${PYSITELIB}/sabnzbd/utils/pystone.py
${PYSITELIB}/sabnzbd/utils/rarfile.py
${PYSITELIB}/sabnzbd/utils/rsslib.py
${PYSITELIB}/sabnzbd/utils/rarvolinfo.py
${PYSITELIB}/sabnzbd/utils/servertests.py
${PYSITELIB}/sabnzbd/utils/sleepless.py
${PYSITELIB}/sabnzbd/utils/systrayiconthread.py
${PYSITELIB}/sabnzbd/utils/upload.py
${PYSITELIB}/sabnzbd/version.py
${PYSITELIB}/sabnzbd/zconfig.py
share/sabnzbd/cherrypy/VERSION.txt
share/sabnzbd/cherrypy/__init__.py
share/sabnzbd/cherrypy/__main__.py
share/sabnzbd/cherrypy/_cpchecker.py
share/sabnzbd/cherrypy/_cpcompat.py
share/sabnzbd/cherrypy/_cpconfig.py
share/sabnzbd/cherrypy/_cpdispatch.py
share/sabnzbd/cherrypy/_cperror.py
share/sabnzbd/cherrypy/_cplogging.py
share/sabnzbd/cherrypy/_cpmodpy.py
share/sabnzbd/cherrypy/_cpnative_server.py
share/sabnzbd/cherrypy/_cpreqbody.py
share/sabnzbd/cherrypy/_cprequest.py
share/sabnzbd/cherrypy/_cpserver.py
share/sabnzbd/cherrypy/_cptools.py
share/sabnzbd/cherrypy/_cptree.py
share/sabnzbd/cherrypy/_cpwsgi.py
share/sabnzbd/cherrypy/_cpwsgi_server.py
share/sabnzbd/cherrypy/_helper.py
share/sabnzbd/cherrypy/cherryd
share/sabnzbd/cherrypy/daemon.py
share/sabnzbd/cherrypy/favicon.ico
share/sabnzbd/cherrypy/lib/__init__.py
share/sabnzbd/cherrypy/lib/auth.py
share/sabnzbd/cherrypy/lib/auth_basic.py
share/sabnzbd/cherrypy/lib/auth_digest.py
share/sabnzbd/cherrypy/lib/caching.py
share/sabnzbd/cherrypy/lib/covercp.py
share/sabnzbd/cherrypy/lib/cpstats.py
share/sabnzbd/cherrypy/lib/cptools.py
share/sabnzbd/cherrypy/lib/encoding.py
share/sabnzbd/cherrypy/lib/gctools.py
share/sabnzbd/cherrypy/lib/httpauth.py
share/sabnzbd/cherrypy/lib/httputil.py
share/sabnzbd/cherrypy/lib/jsontools.py
share/sabnzbd/cherrypy/lib/lockfile.py
share/sabnzbd/cherrypy/lib/locking.py
share/sabnzbd/cherrypy/lib/profiler.py
share/sabnzbd/cherrypy/lib/reprconf.py
share/sabnzbd/cherrypy/lib/sessions.py
share/sabnzbd/cherrypy/lib/static.py
share/sabnzbd/cherrypy/lib/xmlrpcutil.py
share/sabnzbd/cherrypy/process/__init__.py
share/sabnzbd/cherrypy/process/plugins.py
share/sabnzbd/cherrypy/process/servers.py
share/sabnzbd/cherrypy/process/win32.py
share/sabnzbd/cherrypy/process/wspbus.py
share/sabnzbd/cherrypy/wsgiserver/__init__.py
share/sabnzbd/cherrypy/wsgiserver/ssl_builtin.py
share/sabnzbd/cherrypy/wsgiserver/ssl_pyopenssl.py
share/sabnzbd/gntp/__init__.py
share/sabnzbd/gntp/cli.py
share/sabnzbd/gntp/config.py
share/sabnzbd/gntp/core.py
share/sabnzbd/gntp/errors.py
share/sabnzbd/gntp/notifier.py
share/sabnzbd/gntp/shim.py
share/sabnzbd/gntp/version.py
share/sabnzbd/email/badfetch-en.tmpl
share/sabnzbd/email/email-en.tmpl
share/sabnzbd/email/rss-en.tmpl
share/sabnzbd/icons/logo-arrow.svg
share/sabnzbd/icons/logo-arrow_gray.svg
share/sabnzbd/icons/logo-arrow_green.svg
share/sabnzbd/icons/nzb.ico
share/sabnzbd/icons/sabnzbd.ico
share/sabnzbd/icons/sabnzbd16_32.ico
share/sabnzbd/icons/sabnzbd16_32green.ico
share/sabnzbd/icons/sabnzbd16_32paused.ico
share/sabnzbd/icons/sabnzbd_osx_clicked.tiff
share/sabnzbd/icons/sabnzbd_osx_idle.tiff
share/sabnzbd/icons/sabnzbd_osx_pause.tiff
share/sabnzbd/interfaces/Config/README.txt
share/sabnzbd/interfaces/Config/templates/_inc_footer_uc.tmpl
share/sabnzbd/interfaces/Config/templates/_inc_header_uc.tmpl
@ -153,7 +110,7 @@ share/sabnzbd/interfaces/Config/templates/staticcfg/images/logo-full.svg
share/sabnzbd/interfaces/Config/templates/staticcfg/images/logo-small.svg
share/sabnzbd/interfaces/Config/templates/staticcfg/js/chartist.min.js
share/sabnzbd/interfaces/Config/templates/staticcfg/js/filesize.min.js
share/sabnzbd/interfaces/Config/templates/staticcfg/js/jquery-3.2.1.min.js
share/sabnzbd/interfaces/Config/templates/staticcfg/js/jquery-3.5.1.min.js
share/sabnzbd/interfaces/Config/templates/staticcfg/js/jquery-ui.min.js
share/sabnzbd/interfaces/Config/templates/staticcfg/js/jquery.tablesort.min.js
share/sabnzbd/interfaces/Config/templates/staticcfg/js/script.js
@ -181,12 +138,12 @@ share/sabnzbd/interfaces/Glitter/templates/static/javascripts/glitter.history.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/glitter.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/glitter.main.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/glitter.queue.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/jquery-3.5.1.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/jquery-ui.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/jquery.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/jquery.peity.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/knockout-3.5.1.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/knockout-extensions.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/knockout-latest.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/moment.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/moment-2.26.0.min.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/momentjs_locale/da.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/momentjs_locale/de.js
share/sabnzbd/interfaces/Glitter/templates/static/javascripts/momentjs_locale/es.js
@ -272,44 +229,6 @@ share/sabnzbd/interfaces/Plush/templates/static/stylesheets/rateit/delete.gif
share/sabnzbd/interfaces/Plush/templates/static/stylesheets/rateit/rateit.css
share/sabnzbd/interfaces/Plush/templates/static/stylesheets/rateit/star.gif
share/sabnzbd/interfaces/Plush/templates/status.tmpl
share/sabnzbd/interfaces/smpl/CreativeCommons2-5.txt
share/sabnzbd/interfaces/smpl/CreativeCommons3-0.txt
share/sabnzbd/interfaces/smpl/GPL2.txt
share/sabnzbd/interfaces/smpl/GPL3.txt
share/sabnzbd/interfaces/smpl/LICENCE-silk_icons.txt
share/sabnzbd/interfaces/smpl/LICENSE.txt
share/sabnzbd/interfaces/smpl/License-ExCanvas.txt
share/sabnzbd/interfaces/smpl/License-MochiKit.txt
share/sabnzbd/interfaces/smpl/License-Nuvola.txt
share/sabnzbd/interfaces/smpl/License-PlotKit.txt
share/sabnzbd/interfaces/smpl/License-getElementPosition.txt
share/sabnzbd/interfaces/smpl/README.txt
share/sabnzbd/interfaces/smpl/templates/history.tmpl
share/sabnzbd/interfaces/smpl/templates/main.tmpl
share/sabnzbd/interfaces/smpl/templates/nzo.tmpl
share/sabnzbd/interfaces/smpl/templates/queue.tmpl
share/sabnzbd/interfaces/smpl/templates/static/MochiKit/MochiKit.js
share/sabnzbd/interfaces/smpl/templates/static/MochiKit/__package__.js
share/sabnzbd/interfaces/smpl/templates/static/PlotKit/PlotKit.js
share/sabnzbd/interfaces/smpl/templates/static/excanvas/excanvas.js
share/sabnzbd/interfaces/smpl/templates/static/feed-icon-14x14.png
share/sabnzbd/interfaces/smpl/templates/static/images/browser.png
share/sabnzbd/interfaces/smpl/templates/static/images/bullet_arrow_down.png
share/sabnzbd/interfaces/smpl/templates/static/images/control_pause.png
share/sabnzbd/interfaces/smpl/templates/static/images/control_play.png
share/sabnzbd/interfaces/smpl/templates/static/images/down.gif
share/sabnzbd/interfaces/smpl/templates/static/images/drive.png
share/sabnzbd/interfaces/smpl/templates/static/images/drive_go.png
share/sabnzbd/interfaces/smpl/templates/static/images/favicon.ico
share/sabnzbd/interfaces/smpl/templates/static/images/key_enter.png
share/sabnzbd/interfaces/smpl/templates/static/images/messagebox_critical.png
share/sabnzbd/interfaces/smpl/templates/static/images/nuvola/kgpg.png
share/sabnzbd/interfaces/smpl/templates/static/images/up.gif
share/sabnzbd/interfaces/smpl/templates/static/sabnzbd_small4.png
share/sabnzbd/interfaces/smpl/templates/static/stylesheets/colorschemes/black.css
share/sabnzbd/interfaces/smpl/templates/static/stylesheets/colorschemes/white.css
share/sabnzbd/interfaces/smpl/templates/static/stylesheets/smpl.css
share/sabnzbd/interfaces/smpl/templates/status.tmpl
share/sabnzbd/interfaces/wizard/README.TXT
share/sabnzbd/interfaces/wizard/inc_bottom.tmpl
share/sabnzbd/interfaces/wizard/inc_top.tmpl
@ -370,15 +289,77 @@ share/sabnzbd/po/nsis/sr.po
share/sabnzbd/po/nsis/sv.po
share/sabnzbd/po/nsis/zh_CN.po
share/sabnzbd/sabnzbd.xml
share/sabnzbd/sabnzbd/__init__.py
share/sabnzbd/sabnzbd/api.py
share/sabnzbd/sabnzbd/articlecache.py
share/sabnzbd/sabnzbd/assembler.py
share/sabnzbd/sabnzbd/bpsmeter.py
share/sabnzbd/sabnzbd/cfg.py
share/sabnzbd/sabnzbd/config.py
share/sabnzbd/sabnzbd/constants.py
share/sabnzbd/sabnzbd/database.py
share/sabnzbd/sabnzbd/decoder.py
share/sabnzbd/sabnzbd/decorators.py
share/sabnzbd/sabnzbd/directunpacker.py
share/sabnzbd/sabnzbd/dirscanner.py
share/sabnzbd/sabnzbd/downloader.py
share/sabnzbd/sabnzbd/emailer.py
share/sabnzbd/sabnzbd/encoding.py
share/sabnzbd/sabnzbd/filesystem.py
share/sabnzbd/sabnzbd/getipaddress.py
share/sabnzbd/sabnzbd/interface.py
share/sabnzbd/sabnzbd/lang.py
share/sabnzbd/sabnzbd/misc.py
share/sabnzbd/sabnzbd/newsunpack.py
share/sabnzbd/sabnzbd/newswrapper.py
share/sabnzbd/sabnzbd/notifier.py
share/sabnzbd/sabnzbd/nzbparser.py
share/sabnzbd/sabnzbd/nzbqueue.py
share/sabnzbd/sabnzbd/nzbstuff.py
share/sabnzbd/sabnzbd/osxmenu.py
share/sabnzbd/sabnzbd/panic.py
share/sabnzbd/sabnzbd/par2file.py
share/sabnzbd/sabnzbd/postproc.py
share/sabnzbd/sabnzbd/powersup.py
share/sabnzbd/sabnzbd/rating.py
share/sabnzbd/sabnzbd/rss.py
share/sabnzbd/sabnzbd/sabtray.py
share/sabnzbd/sabnzbd/sabtraylinux.py
share/sabnzbd/sabnzbd/scheduler.py
share/sabnzbd/sabnzbd/skintext.py
share/sabnzbd/sabnzbd/sorting.py
share/sabnzbd/sabnzbd/urlgrabber.py
share/sabnzbd/sabnzbd/utils/__init__.py
share/sabnzbd/sabnzbd/utils/apireg.py
share/sabnzbd/sabnzbd/utils/certgen.py
share/sabnzbd/sabnzbd/utils/checkdir.py
share/sabnzbd/sabnzbd/utils/diskspeed.py
share/sabnzbd/sabnzbd/utils/getperformance.py
share/sabnzbd/sabnzbd/utils/happyeyeballs.py
share/sabnzbd/sabnzbd/utils/internetspeed.py
share/sabnzbd/sabnzbd/utils/kronos.py
share/sabnzbd/sabnzbd/utils/pathbrowser.py
share/sabnzbd/sabnzbd/utils/pybonjour.py
share/sabnzbd/sabnzbd/utils/pystone.py
share/sabnzbd/sabnzbd/utils/rarfile.py
share/sabnzbd/sabnzbd/utils/rarvolinfo.py
share/sabnzbd/sabnzbd/utils/servertests.py
share/sabnzbd/sabnzbd/utils/sleepless.py
share/sabnzbd/sabnzbd/utils/systrayiconthread.py
share/sabnzbd/sabnzbd/version.py
share/sabnzbd/sabnzbd/zconfig.py
share/sabnzbd/scripts/Deobfuscate.py
share/sabnzbd/scripts/Sample-PostProc.cmd
share/sabnzbd/scripts/Sample-PostProc.py
share/sabnzbd/scripts/Sample-PostProc.sh
share/sabnzbd/tools/extract_pot.py
share/sabnzbd/tools/make_mo.py
share/sabnzbd/tools/msgfmt.py
share/sabnzbd/util/__init__.py
share/sabnzbd/util/apireg.py
share/sabnzbd/util/mailslot.py
@pkgdir util
share/sabnzbd/tools/pygettext.py
@pkgdir tools
@pkgdir scripts
@pkgdir sabnzbd
@pkgdir po
@pkgdir interfaces
@pkgdir gntp
@pkgdir cherrypy
@pkgdir icons
@pkgdir email

View File

@ -1,2 +0,0 @@
This package has known vulnerabilities, please investigate and fix if possible:
CVE-2020-13124

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.1 2013/10/01 20:25:20 wongk Exp $
SHA1 (sabnzbd-2.3.9.tar.gz) = eec095bdc51ab745c42fa45523cfb2bde35531f5
RMD160 (sabnzbd-2.3.9.tar.gz) = 2de2968a60b07a4f766a5cf9ecf07976753f85bf
SHA512 (sabnzbd-2.3.9.tar.gz) = d555bd2c61d075d9bd181bc9f8f7958be2edc63cb3543fd6630aba3ff2487ad936ce061078477bf32dc191c746fe4d2fb96de1ce26f3ac631a6848fbe8efe18f
Size (sabnzbd-2.3.9.tar.gz) = 4610937 bytes
SHA1 (patch-SABnzbd.py) = 7b6de86e427e7a17c9e3ca7bf0928dfe59953c02
SHA1 (sabnzbd-3.0.2.tar.gz) = a66fb715776e0f7a9e2cc0e08e74ce33d5dbd373
RMD160 (sabnzbd-3.0.2.tar.gz) = 6c4d1ea10baea1f5889393f683acdf118f1764fb
SHA512 (sabnzbd-3.0.2.tar.gz) = 44f2a4d76a11a2e6131226903db6f4003c188404523a1e0cc1964d19c354a8f10c53adad5566e24dbe2c135b64250c323da4ec69cf5ab44ef8c4eefccb239c49
Size (sabnzbd-3.0.2.tar.gz) = 4287487 bytes
SHA1 (patch-SABnzbd.py) = 5b132afee8ee953613802cef0267e82a3ce5c063

View File

@ -2,27 +2,13 @@
# Global and legacy options
PKG_OPTIONS_VAR= PKG_OPTIONS.sabnzbdplus
PKG_SUPPORTED_OPTIONS= par2 unrar feedparser openssl
PKG_SUGGESTED_OPTIONS= par2 unrar feedparser openssl
PKG_OPTIONS_VAR= PKG_OPTIONS.sabnzbd
PKG_SUPPORTED_OPTIONS= feedparser openssl
PKG_SUGGESTED_OPTIONS= feedparser openssl
.include "../../mk/bsd.options.mk"
.include "../../lang/python/application.mk"
###
### par2 support
###
.if !empty(PKG_OPTIONS:Mpar2)
DEPENDS+= par2-[0-9]*:../../archivers/par2
.endif
###
### unrar support
###
.if !empty(PKG_OPTIONS:Munrar)
DEPENDS+= unrar-[0-9]*:../../archivers/unrar
.endif
###
### feedparser support
###

View File

@ -2,9 +2,9 @@ $NetBSD$
Fix path.
--- SABnzbd.py.orig 2020-02-12 20:18:12.258920844 +0000
+++ SABnzbd.py
@@ -42,6 +42,10 @@ import ssl
--- SABnzbd.py.orig 2020-08-30 20:58:31.000000000 +0200
+++ SABnzbd.py 2020-09-07 20:29:13.831328403 +0200
@@ -35,6 +35,10 @@
import time
import re
@ -14,8 +14,8 @@ Fix path.
+
try:
import Cheetah
if Cheetah.Version[0] < '2':
@@ -919,7 +923,8 @@ def main():
import feedparser
@@ -925,7 +929,8 @@
sabnzbd.MY_FULLNAME = os.path.normpath(os.path.abspath(sabnzbd.MY_FULLNAME))
sabnzbd.MY_NAME = os.path.basename(sabnzbd.MY_FULLNAME)