wip/tracy: import tracy-0.4.1

This commit is contained in:
Aleksej Lebedev 2019-04-02 11:17:20 +00:00
parent ca3f765a05
commit 54bde25e1a
5 changed files with 60 additions and 0 deletions

4
tracy/DESCR Normal file
View File

@ -0,0 +1,4 @@
Tracy is a real time, nanosecond resolution frame profiler that can be used for
remote or embedded telemetry of your application. It can profile CPU (C, C++11,
Lua), GPU (OpenGL, Vulkan) and memory. It also can display locks held by threads
and their interactions with each other.

32
tracy/Makefile Normal file
View File

@ -0,0 +1,32 @@
# $NetBSD$
VERSION= 0.4.1
PKGNAME= tracy-${VERSION}
DISTNAME= v${VERSION}
CATEGORIES= devel
MASTER_SITES= https://bitbucket.org/wolfpld/tracy/get/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= root@zta.lk
HOMEPAGE= https://bitbucket.org/wolfpld/tracy
COMMENT= Real time, nanosecond resolution frame profiler
LICENSE= modified-bsd
WRKSRC= ${WRKDIR}/wolfpld-tracy-59ed5775d973
USE_LANGUAGES= c c++
USE_TOOLS+= gmake pkg-config
INSTALLATION_DIRS= bin
do-build:
cd ${WRKSRC}/profiler/build/unix && ${GMAKE} release
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/profiler/build/unix/Tracy-release ${DESTDIR}${PREFIX}/bin/tracy
.include "../../devel/zlib/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/glfw/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
tracy/PLIST Normal file
View File

@ -0,0 +1,2 @@
@comment $NetBSD$
bin/tracy

7
tracy/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (v0.4.1.tar.bz2) = 82bb67a85a74b0d876ecc7c36184450315b5bf9b
RMD160 (v0.4.1.tar.bz2) = ad62157232ae3f18729563d6ad4ac51051d4b55c
SHA512 (v0.4.1.tar.bz2) = 55ef47713a188e5a6e591157bd1bb189e26d9c0ece2c5724461fb5a87127b3e950bf60c5e4ef5348fec9c550ee43fc2a1603b07e57cca97825a76d8808cbbdb9
Size (v0.4.1.tar.bz2) = 1565710 bytes
SHA1 (patch-profiler_build_unix_build.mk) = 26f5f6e9ec7ebc1c24fc427531484d593b116bef

View File

@ -0,0 +1,15 @@
$NetBSD$
Prevents pkgsrc glfw's headers from being picked up during the build.
--- profiler/build/unix/build.mk.orig 2019-03-26 14:55:22.000000000 +0000
+++ profiler/build/unix/build.mk
@@ -1,7 +1,7 @@
CFLAGS +=
CXXFLAGS := $(CFLAGS) -std=c++17
DEFINES += -DTRACY_FILESELECTOR -DTRACY_EXTENDED_FONT -DTRACY_ROOT_WINDOW
-INCLUDES := $(shell pkg-config --cflags glfw3 freetype2) -I../../../imgui -I../../libs/gl3w
+INCLUDES := -I../../../imgui -I../../libs/gl3w $(shell pkg-config --cflags glfw3 freetype2)
LIBS := $(shell pkg-config --libs glfw3 freetype2) -lpthread -ldl
PROJECT := Tracy
IMAGE := $(PROJECT)-$(BUILD)