Rebase work to ATLAS 3.11.11

This commit is contained in:
Aleksej Saushev 2013-09-14 23:46:50 +00:00 committed by Thomas Klausner
parent 640d4182da
commit 54d55e354e
4 changed files with 25 additions and 25 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.11 2012/09/24 16:56:39 asau Exp $
# $NetBSD: Makefile,v 1.12 2013/09/14 23:46:50 asau Exp $
ATLAS_VERSION= 3.9.25
ATLAS_VERSION= 3.11.11
DISTNAME= atlas${ATLAS_VERSION}
PKGNAME= atlas-${ATLAS_VERSION}

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2010/08/01 11:17:03 asau Exp $
$NetBSD: distinfo,v 1.7 2013/09/14 23:46:50 asau Exp $
SHA1 (atlas3.9.25.tar.bz2) = ab1b8b44a0f7f44ce0e7635af9d1200d087b08db
RMD160 (atlas3.9.25.tar.bz2) = a8a884c9db69946f5a839716e75fe73b76eb34b5
Size (atlas3.9.25.tar.bz2) = 4988010 bytes
SHA1 (patch-aa) = b804aff967228551bafd3f5d232c2f79c79e989b
SHA1 (patch-ab) = 1f363575769a70689a7466483c2caa132d840820
SHA1 (atlas3.11.11.tar.bz2) = 8e26a499606762464b70d09df6915fa9b9e3d687
RMD160 (atlas3.11.11.tar.bz2) = 6b9895301becdf1ef35c7951c40672119256fe78
Size (atlas3.11.11.tar.bz2) = 5238482 bytes
SHA1 (patch-aa) = 1cfe4f7ad66ec006a2d6ee9186d1d91b9d656c44
SHA1 (patch-ab) = 45a535eb378de2cfcc4cf64e5f76d0ae0fc28a0f

View File

@ -1,9 +1,9 @@
$NetBSD: patch-aa,v 1.2 2009/10/14 20:17:35 asau Exp $
$NetBSD: patch-aa,v 1.3 2013/09/14 23:46:51 asau Exp $
Teach it about NetBSD.
--- CONFIG/include/atlconf.h.orig 2009-02-20 18:22:54.000000000 +0300
+++ CONFIG/include/atlconf.h 2009-02-21 20:30:30.000000000 +0300
--- CONFIG/include/atlconf.h.orig 2013-07-05 21:32:45.000000000 +0000
+++ CONFIG/include/atlconf.h 2013-09-14 23:36:56.253504705 +0000
@@ -6,12 +6,12 @@
#include <string.h>
#include <assert.h>
@ -12,11 +12,11 @@ Teach it about NetBSD.
+#define NOS 14
static char *osnam[NOS] =
{"UNKNOWN", "Linux", "SunOS", "SunOS4", "OSF1", "IRIX", "AIX",
- "Win9x", "WinNT", "WinSFU", "HPUX", "FreeBSD", "OSX"};
+ "Win9x", "WinNT", "WinSFU", "HPUX", "FreeBSD", "OSX", "NetBSD"};
- "Win9x", "WinNT", "Win64", "HPUX", "FreeBSD", "OSX"};
+ "Win9x", "WinNT", "Win64", "HPUX", "FreeBSD", "OSX", "NetBSD"};
enum OSTYPE {OSOther=0, OSLinux, OSSunOS, OSSunOS4, OSOSF1, OSIRIX, OSAIX,
- OSWin9x, OSWinNT, OSWinSFU, OSHPUX, OSFreeBSD, OSOSX};
+ OSWin9x, OSWinNT, OSWinSFU, OSHPUX, OSFreeBSD, OSOSX, OSNetBSD};
- OSWin9x, OSWinNT, OSWin64, OSHPUX, OSFreeBSD, OSOSX};
+ OSWin9x, OSWinNT, OSWin64, OSHPUX, OSFreeBSD, OSOSX, OSNetBSD};
#define OSIsWin(OS_) ( ((OS_) == OSWinNT) || ((OS_) == OSWin9x) || \
((OS_) == OSWinSFU) )
((OS_) == OSWin64) )

View File

@ -1,14 +1,14 @@
$NetBSD: patch-ab,v 1.2 2010/08/01 11:17:03 asau Exp $
$NetBSD: patch-ab,v 1.3 2013/09/14 23:46:51 asau Exp $
Teach it about NetBSD.
--- CONFIG/src/probe_OS.c.orig 2010-06-04 20:42:47.000000000 +0400
+++ CONFIG/src/probe_OS.c 2010-08-01 15:15:22.000000000 +0400
@@ -19,6 +19,7 @@
--- CONFIG/src/probe_OS.c.orig 2013-07-05 21:32:46.000000000 +0000
+++ CONFIG/src/probe_OS.c 2013-09-14 23:37:54.725504172 +0000
@@ -23,6 +23,7 @@
* This is patch from Sylvestre Ledru; I have no direct experience wt HURD
*/
if(strstr(ln, "Linux") || strstr(ln, "GNU")) OS = OSLinux;
+ else if (strstr(ln, "NetBSD")) OS = OSNetBSD;
else if(strstr(ln, "FreeBSD")) OS = OSFreeBSD;
else if (strstr(ln, "Darwin")) OS = OSOSX;
else if(strstr(ln, "SunOS"))
if(strstr(res, "Linux") || strstr(res, "GNU")) OS = OSLinux;
+ else if(strstr(res, "NetBSD")) OS = OSNetBSD;
else if(strstr(res, "FreeBSD")) OS = OSFreeBSD;
else if (strstr(res, "Darwin")) OS = OSOSX;
else if(strstr(res, "SunOS"))