py-pafy: Update wip/py-pafy to 0.5.3.1

pkgsrc changes:
- Add support for ALTERNATIVES
- Rework the appending of ${PYVERSSUFFIX} to bin/ytdl. Instead of using
  `post-extract' and a patch for setup.py directly do that via `post-install'
  target, similarly to other Python multi-packages (this is simpler and less
  intrusive).

Changes:
15 January 2017
Version 0.5.3.1

[Bugfix] - Fix issue when stdout.encoding is None (#165)

-------------------------------------------------------------------------------

13 January 2017
Version 0.5.3

[Bugfix] - Handle occassional issue reading category (@regisb)
[Bugfix] - Encode filename to system locale (#163)
[Update] - Support m.youtube.com urls (@HouseK) (#159)
[Update] - Support gaming.youtube.com urls (@Phosphorus-M) (#161)
[Update] - Fix running under Boost.Python (#162)

-------------------------------------------------------------------------------

18 August 2016
Version 0.5.2

[Bugfix] - Fix internal backend (#140)
[Update] - Support liked video playlist (#149)
[Update] - Add spaces to file name format (@ghost) (#145)

-------------------------------------------------------------------------------
31 May 2016
Version 0.5.1

[Bugfix] - Fix python 2 import (#134)
[Bugfix] - Fix two bugs in the internal backend (major bug remains unfixed)
[Update] - Remove deprecated signature argument

-------------------------------------------------------------------------------

28 February 2016
Version 0.5.0

[Feature] - Support both youtube-dl backend and internal backend (old 0.3.x
            branch. This makes youtube-dl an optional dependency, though it
            is more stable and thus recommended. There will be no more 0.3.x
            releases, as this eliminates the need for them.

            To use the internal backend even if youtube-dl is installed, set
            the environmental variable PAFY_BACKEND to "internal".
[Bugfix] - Fix UnicodeDecodeError(krishnawhite) (#129)
[Bugfix] - Fix quality property

-------------------------------------------------------------------------------

1 January 2016
Version 0.4.3

[Feature] - get_playlist2() command with new interface and support for
  playlists longer than 200 videos (ids1024)
[Bugfix] - Fix ZeroDivisionError (cpnielsen) (#125)

-------------------------------------------------------------------------------

11 November 2015
Version 0.4.2

[Bugfix] - Fix crash when snippet has no tags property
[Bugfix] - Fix issue with get_filesize on some streams
[Bugfix] - Fix bigthumb and bigthumbhd (#118)
[Feature] - Allow specifying youtube-dl arguments (#115 #120)

-------------------------------------------------------------------------------

4 October 2015
Version 0.4.1

[Bugfix] - Fix Pafy.streams

-------------------------------------------------------------------------------

4 October 2015
Version 0.4.0

[Major Update!] - Pull in youtube-dl as a dependency, replacing current
                  stream code [#109]

This is a major change, and will likely prove controversial, so version
0.3.76 has been released concurrently with all the changes not related to
youtube-dl. This makes the code simpler and easier to maintain while fixing
various bugs, but has some disadvantages.

If this is a problem for you, please use version 0.3.76 AND state your reasons
and suggestions at issue #110 on Github.
https://github.com/mps-youtube/pafy/issues/110

-------------------------------------------------------------------------------

4 October 2015
Version 0.3.76

[Bugfix] - Fix bug in ytdl (#101 #102)
[Update] - Use better method for matching urls (#104)
[Bugfix] - Use .opus extension for opus audio (#108)
This commit is contained in:
Leonardo Taccari 2017-08-27 16:54:17 +02:00
parent d88607924c
commit 5573286a97
6 changed files with 45 additions and 29 deletions

1
py-pafy/ALTERNATIVES Normal file
View File

@ -0,0 +1 @@
bin/ytdl @PREFIX@/bin/ytdl@PYVERSSUFFIX@

View File

@ -1 +1,16 @@
Retrieve YouTube content and metadata
Features:
- Retreive metadata such as viewcount, duration, rating, author, thumbnail, keywords
- Download video or audio at requested resolution / bitrate / format / filesize
- Command line tool (ytdl) for downloading directly from the command line
- Retrieve the URL to stream the video in a player such as vlc or mplayer
- Works with age-restricted videos and non-embeddable videos
- Small, standalone, single importable module file (pafy.py)
- Select highest quality stream for download or streaming
- Download video only (no audio) in m4v or webm format
- Download audio only (no video) in ogg or m4a format
- Retreive playlists and playlist metadata
- Works with Python 2.6+ and 3.3+
- Optionally depends on youtube-dl (recommended; more stable)

View File

@ -1,6 +1,6 @@
# $NetBSD$
DISTNAME= pafy-0.3.74
DISTNAME= pafy-0.5.3.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pafy/}
@ -12,8 +12,8 @@ LICENSE= gnu-lgpl-v3
USE_LANGUAGES= # none
post-extract:
${MV} ${WRKSRC}/scripts/ytdl ${WRKSRC}/scripts/ytdl${PYVERSSUFFIX}
post-install:
${MV} ${DESTDIR}${PREFIX}/bin/ytdl ${DESTDIR}${PREFIX}/bin/ytdl${PYVERSSUFFIX} || ${TRUE}
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -3,10 +3,32 @@ bin/ytdl${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/pafy/__init__.py
${PYSITELIB}/pafy/__init__.pyc
${PYSITELIB}/pafy/__init__.pyo
${PYSITELIB}/pafy/backend_internal.py
${PYSITELIB}/pafy/backend_internal.pyc
${PYSITELIB}/pafy/backend_internal.pyo
${PYSITELIB}/pafy/backend_shared.py
${PYSITELIB}/pafy/backend_shared.pyc
${PYSITELIB}/pafy/backend_shared.pyo
${PYSITELIB}/pafy/backend_youtube_dl.py
${PYSITELIB}/pafy/backend_youtube_dl.pyc
${PYSITELIB}/pafy/backend_youtube_dl.pyo
${PYSITELIB}/pafy/g.py
${PYSITELIB}/pafy/g.pyc
${PYSITELIB}/pafy/g.pyo
${PYSITELIB}/pafy/jsinterp.py
${PYSITELIB}/pafy/jsinterp.pyc
${PYSITELIB}/pafy/jsinterp.pyo
${PYSITELIB}/pafy/pafy.py
${PYSITELIB}/pafy/pafy.pyc
${PYSITELIB}/pafy/pafy.pyo
${PYSITELIB}/pafy/playlist.py
${PYSITELIB}/pafy/playlist.pyc
${PYSITELIB}/pafy/playlist.pyo
${PYSITELIB}/pafy/util.py
${PYSITELIB}/pafy/util.pyc
${PYSITELIB}/pafy/util.pyo

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2015/02/14 10:58:25 jihbed Exp $
SHA1 (pafy-0.3.74.tar.gz) = 7133f60c5a6ec447808d009790f9e2c73bf38076
RMD160 (pafy-0.3.74.tar.gz) = 44b90355c0e518b5cf191c7a8bf236af232f6b61
Size (pafy-0.3.74.tar.gz) = 22584 bytes
SHA1 (patch-setup.py) = 4ef995164dcabd3d30190c51a3e26aac862ca8f1
SHA1 (pafy-0.5.3.1.tar.gz) = e96b6377dca8c80ed90fa20bc869eb0b0367499a
RMD160 (pafy-0.5.3.1.tar.gz) = f2b4107faa36bc9fafc3c0660b89618a2f096229
SHA512 (pafy-0.5.3.1.tar.gz) = 2d8fa30e15b9d500fac9726d9119da9f1ad24021a804b7e75d6251347f8b47f4517425834ba243a749e22517507fc27b67c7258f81bdebaa7d3b0b7f9b18e5ed
Size (pafy-0.5.3.1.tar.gz) = 25636 bytes

View File

@ -1,22 +0,0 @@
$NetBSD: patch-setup.py,v 1.1 2015/02/14 10:58:25 jihbed Exp $
--- setup.py.orig 2015-06-01 13:14:51.000000000 +0000
+++ setup.py
@@ -9,6 +9,8 @@ python setup.py sdist bdist_wheel
"""
+import sys
+
try:
from setuptools import setup
@@ -18,7 +20,7 @@ except ImportError:
setup(
name='pafy',
packages=['pafy'],
- scripts=['scripts/ytdl'],
+ scripts=['scripts/ytdl'+sys.version[0:3]],
version='0.3.74',
description="Retrieve YouTube content and metadata",
keywords=["pafy", "API", "YouTube", "youtube", "download", "video"],