cosmo-engine: import cosmo-engine (git snapshot) as wip/cosmo-engine

A new game engine to play the MS-DOS game "Cosmo's Cosmic Adventure"
on modern systems.

A copy of the original Cosmo game (or shareware version) is required
to play.
This commit is contained in:
Yorick Hardy 2020-01-29 20:34:18 +02:00
parent afc0c90209
commit 55d51b9f5f
6 changed files with 69 additions and 0 deletions

View File

@ -489,6 +489,7 @@ SUBDIR+= coreclr-git
SUBDIR+= corefx-git
SUBDIR+= corert-git
SUBDIR+= cortex-var
SUBDIR+= cosmo-engine
SUBDIR+= coturn
SUBDIR+= courierpassd
SUBDIR+= coverity-analysis-bin

5
cosmo-engine/DESCR Normal file
View File

@ -0,0 +1,5 @@
A new game engine to play the MS-DOS game "Cosmo's Cosmic Adventure"
on modern systems.
A copy of the original Cosmo game (or shareware version) is required
to play.

29
cosmo-engine/Makefile Normal file
View File

@ -0,0 +1,29 @@
# $NetBSD$
GITHUB_PROJECT= cosmo-engine
GITHUB_TAG= c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44
DISTNAME= ${GITHUB_TAG}
PKGNAME= ${GITHUB_PROJECT}-0.0
PKGREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=yuv422/}
DIST_SUBDIR= ${GITHUB_PROJECT}
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/yuv422/cosmo-engine/
COMMENT= Game engine to play Cosmo's Cosmic Adventure
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/cosmo-engine-c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44
USE_CMAKE= yes
USE_LANGUAGES= c c++
INSTALLATION_DIRS+= bin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cosmo_engine ${DESTDIR}${PREFIX}/bin
.include "../../audio/SDL2_mixer/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
cosmo-engine/PLIST Normal file
View File

@ -0,0 +1,2 @@
@comment $NetBSD$
bin/cosmo_engine

7
cosmo-engine/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (cosmo-engine/c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44-c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44.zip) = e0b01810659c7766ae06105bb07f6d9c47053c02
RMD160 (cosmo-engine/c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44-c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44.zip) = 099bcd181732f57e8086a7c9d24eb442c8368767
SHA512 (cosmo-engine/c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44-c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44.zip) = 2909b472d8d1d48eccb367c164e5f1402f82a5b2bc371ea2a17a67d3d17413968ae6d2eeeefac7ba396f53d85d2099fb178d7c1651f165f74b6fb61c56a4f907
Size (cosmo-engine/c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44-c9d6aeda06bb88388fda5e4a9e1c93e624a0ea44.zip) = 183736 bytes
SHA1 (patch-CMakeLists.txt) = 1c5cf8740637fd45baa0853052343bb317cd0966

View File

@ -0,0 +1,25 @@
$NetBSD$
Support BSDs.
--- CMakeLists.txt.orig 2020-01-29 14:15:47.010539816 +0000
+++ CMakeLists.txt
@@ -42,6 +42,18 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
TARGET_LINK_LIBRARIES(cosmo_engine dl m ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARIES})
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+IF(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ TARGET_LINK_LIBRARIES(cosmo_engine m ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARIES})
+ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+
+IF(${CMAKE_SYSTEM_NAME} MATCHES "NetBSD")
+ TARGET_LINK_LIBRARIES(cosmo_engine m ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARIES})
+ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+
+IF(${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
+ TARGET_LINK_LIBRARIES(cosmo_engine m ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARIES})
+ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+
IF(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
TARGET_LINK_LIBRARIES(cosmo_engine ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARIES})
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Windows")