zabbix50-agent: Cleanup of build

This commit is contained in:
Juraj Lutter 2020-09-17 19:17:46 +00:00
parent 80819d6200
commit 58268701b5
4 changed files with 21 additions and 11 deletions

View File

@ -5,22 +5,24 @@
PKGNAME= ${DISTNAME:S/-/-agent-/}
COMMENT= Enterprise-class Monitoring Solution for Everyone
CONFLICTS+= zabbix-[0-9]*
CONFLICTS+= zabbix-agent-[0-9]*
USE_TOOLS+= pkg-config
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-agent
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --datarootdir=${PREFIX}/share/${PKGBASE}
CONFIGURE_ARGS+= --with-libcurl
CONFIGURE_ARGS+= --with-libpcre=${BUILDLINK_PREFIX.pcre}
CONFIGURE_ARGS+= --with-openssl=${BUILDLINK_PREFIX.openssl}
EGDIR= share/examples/zabbix
EGDIR= share/examples/${PKGBASE}
CONF_FILES+= ${EGDIR}/zabbix_agentd.conf ${PKG_SYSCONFDIR}/zabbix_agentd.conf
RCD_SCRIPTS= zabbix_agentd
INSTALLATION_DIRS+= ${EGDIR} share/zabbix
INSTALLATION_DIRS+= ${EGDIR} share/${PKGBASE}
SUBST_CLASSES+= fix-paths
SUBST_STAGE.fix-paths= pre-configure
@ -29,6 +31,14 @@ SUBST_FILES.fix-paths= conf/*.conf
SUBST_FILES.fix-paths+= man/*.man
SUBST_SED.fix-paths= -e 's,/usr/local/etc,${PKG_SYSCONFDIR},g'
SUBST_CLASSES+= fix-pkgbase
SUBST_STAGE.fix-pkgbase= pre-configure
SUBST_MESSAGE.fix-pkgbase= Fixing PKGBASE.
SUBST_FILES.fix-pkgbase= src/zabbix_agent/Makefile.in
SUBST_SED.fix-pkgbase= -e 's,%%PKGBASE%%,${PKGBASE},g'
PLIST_SUBST+= PKGBASE=${PKGBASE}
.include "../../mk/bsd.prefs.mk"
.include "options.mk"

View File

@ -5,7 +5,7 @@ man/man1/zabbix_get.1
man/man1/zabbix_sender.1
man/man8/zabbix_agentd.8
sbin/zabbix_agentd
share/examples/zabbix/zabbix_agentd.conf
@pkgdir share/zabbix
share/examples/${PKGBASE}/zabbix_agentd.conf
@pkgdir share/${PKGBASE}
@pkgdir lib/modules
@pkgdir etc/zabbix_agentd.conf.d

View File

@ -5,5 +5,5 @@ RMD160 (zabbix-5.0.3.tar.gz) = a1d122b71549a230f21f9d85dbc28042b40ec7ea
SHA512 (zabbix-5.0.3.tar.gz) = d08a031b334f531320f6b695af3ed7e3514c802ea28e0cec75040c518409e16ab4c591b389091aa12c07129f9b758d050c958967e3e86e725f4595f3b3a90d97
Size (zabbix-5.0.3.tar.gz) = 18893485 bytes
SHA1 (patch-configure) = cf647b9ee52a96882d31f8783ac19b66e3e65105
SHA1 (patch-src_libs_zbxsysinfo_netbsd_net.c) = 29c27d9e2acf8c13c02135afbc589bef6a7b56e6
SHA1 (patch-src_zabbix__agent_Makefile.in) = b74b47ffc4b8f16046778cacd9be2b7207d7f549
SHA1 (patch-src_libs_zbxsysinfo_netbsd_net.c) = 468f2112a3d65b0a73f371194ae15ce0df0ad71c
SHA1 (patch-src_zabbix__agent_Makefile.in) = efbd804ecee4b99db36db5f4fd61583b2ef96a86

View File

@ -1,15 +1,15 @@
$NetBSD: patch-src_zabbix__agent_Makefile.in,v 1.2 2018/11/12 10:51:34 he Exp $
$NetBSD$
Install config files in example dir.
Install config file to component's example directory.
--- src/zabbix_agent/Makefile.in.orig 2020-07-13 07:56:40.000000000 +0000
--- src/zabbix_agent/Makefile.in.orig 2020-08-24 09:43:03.000000000 +0000
+++ src/zabbix_agent/Makefile.in
@@ -1092,7 +1092,7 @@ uninstall-am: uninstall-sbinPROGRAMS
@@ -1113,7 +1113,7 @@ uninstall-am: uninstall-sbinPROGRAMS
install-data-hook:
$(MKDIR_P) "$(DESTDIR)$(AGENT_CONFIG_FILE).d"
$(MKDIR_P) "$(DESTDIR)$(LOAD_MODULE_PATH)"
- test -f "$(DESTDIR)$(AGENT_CONFIG_FILE)" || cp "../../conf/zabbix_agentd.conf" "$(DESTDIR)$(AGENT_CONFIG_FILE)"
+ cp "../../conf/zabbix_agentd.conf" "$(DESTDIR)${PREFIX}/share/examples/zabbix"
+ $(INSTALL_DATA) "../../conf/zabbix_agentd.conf" "$(DESTDIR)/${PREFIX}/share/examples/%%PKGBASE%%"
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.