py-stemming: imported version 1.0.1

This commit is contained in:
Aleksej Lebedev 2020-11-04 15:01:03 +01:00
parent 1430136c2a
commit 59188a155b
5 changed files with 60 additions and 0 deletions

5
py-stemming/DESCR Normal file
View File

@ -0,0 +1,5 @@
Python implementations of the Porter, Porter2, Paice-Husk, and Lovins stemming
algorithms for English. These implementations are straightforward and
efficient, unlike some Python versions of the same algorithms available on the
Web. This package is an extraction of the stemming code included in the Whoosh
search engine.

14
py-stemming/Makefile Normal file
View File

@ -0,0 +1,14 @@
# $NetBSD$
DISTNAME= stemming-1.0.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel sysutils
MASTER_SITES= ${MASTER_SITE_PYPI:=s/stemming/}
MAINTAINER= root@zta.lk
HOMEPAGE= https://github.com/tomtom-international/commisery/
COMMENT= Python implementation of Porter Stemming algorithm.
LICENSE= public-domain
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

21
py-stemming/PLIST Normal file
View File

@ -0,0 +1,21 @@
@comment $NetBSD$
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/${EGG_INFODIR}/zip-safe
${PYSITELIB}/stemming/__init__.py
${PYSITELIB}/stemming/__init__.pyc
${PYSITELIB}/stemming/__init__.pyo
${PYSITELIB}/stemming/lovins.py
${PYSITELIB}/stemming/lovins.pyc
${PYSITELIB}/stemming/lovins.pyo
${PYSITELIB}/stemming/paicehusk.py
${PYSITELIB}/stemming/paicehusk.pyc
${PYSITELIB}/stemming/paicehusk.pyo
${PYSITELIB}/stemming/porter.py
${PYSITELIB}/stemming/porter.pyc
${PYSITELIB}/stemming/porter.pyo
${PYSITELIB}/stemming/porter2.py
${PYSITELIB}/stemming/porter2.pyc
${PYSITELIB}/stemming/porter2.pyo

7
py-stemming/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (stemming-1.0.1.tar.gz) = 28ced8c84f1f42363da56678549911bef6eb6416
RMD160 (stemming-1.0.1.tar.gz) = cec14605651c1b5587f938ca14abad39879dba0f
SHA512 (stemming-1.0.1.tar.gz) = 0c495c796688c97fc24a6e2c34ef4dccdca1c6c12160794fe0ddd965745c92d08922eb9972eca0d5537bcd787e1528a3818a02e2aa4f22ca5ebf32c7bade0057
Size (stemming-1.0.1.tar.gz) = 10954 bytes
SHA1 (patch-stemming_porter.py) = 0925bc97e6842c08f06ad71ee5efd44d83feafaa

View File

@ -0,0 +1,13 @@
$NetBSD$
--- stemming/porter.py.orig 2010-02-08 23:06:43.000000000 +0000
+++ stemming/porter.py
@@ -173,7 +173,7 @@ def stem(w):
return w
if __name__ == '__main__':
- print stem("fundamentally")
+ print(stem("fundamentally"))