cannonball: Updates to the latest github commit.

Upstream merged local patches, they have been removed and version
has been updated.
This commit is contained in:
Santhosh Raju 2019-08-19 09:34:13 -05:00
parent 1f0a6fce28
commit 5981af9231
5 changed files with 7 additions and 123 deletions

View File

@ -1,9 +1,9 @@
# $NetBSD$
DISTNAME= cannonball-0.3.20171201
DISTNAME= cannonball-0.3.20190819
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GITHUB:=djyt/}
GITHUB_TAG= 0c0814d8233ee4e5be7beb309b8e16e0eecbb2e6
GITHUB_TAG= 48d2c6294b0bf3e16be4c2a83399da9108544d5f
EXTRACT_USING= bsdtar
MAINTAINER= fox@NetBSD.org
@ -42,7 +42,7 @@ do-install:
${DESTDIR}${PREFIX}/bin/cannonball
${INSTALL_PROGRAM} ${WRKSRC}/build/cannonball \
${DESTDIR}${PREFIX}/libexec
${INSTALL_MAN} ${FILESDIR}/cannonball.6 \
${INSTALL_MAN} ${WRKSRC}/docs/cannonball.6 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man6
.include "../../devel/boost-headers/buildlink3.mk"

View File

@ -1,8 +1,6 @@
$NetBSD$
SHA1 (cannonball-0.3.20171201-0c0814d8233ee4e5be7beb309b8e16e0eecbb2e6.tar.gz) = a92cea8856b9c625541841969de01b72ff149cd6
RMD160 (cannonball-0.3.20171201-0c0814d8233ee4e5be7beb309b8e16e0eecbb2e6.tar.gz) = 79f33565344ec4f5b6d37ff0967c033ea8751bba
SHA512 (cannonball-0.3.20171201-0c0814d8233ee4e5be7beb309b8e16e0eecbb2e6.tar.gz) = b387e1d855c7949a9685d0fc9dac1a917962e2a1679a0ef5813f0efe6a936e5e25e57ccd80d54f28384c390a74f0285f40c673d2294c24693a52cb52ece80de0
Size (cannonball-0.3.20171201-0c0814d8233ee4e5be7beb309b8e16e0eecbb2e6.tar.gz) = 277449 bytes
SHA1 (patch-cmake_CMakeLists.txt) = bc474aa576a9d28fc2569f9c9c19b2a3808d5ddd
SHA1 (patch-cmake_bsd.cmake) = 74fe1f8d35b7712ea69232971e37bfb6c48dec16
SHA1 (cannonball-0.3.20190819-48d2c6294b0bf3e16be4c2a83399da9108544d5f.tar.gz) = 02e716fed541d3e261c679bda7d11c14b5a98af7
RMD160 (cannonball-0.3.20190819-48d2c6294b0bf3e16be4c2a83399da9108544d5f.tar.gz) = bfca36c5dd9de523fd8ad6ea0f8c8bbf1a97429d
SHA512 (cannonball-0.3.20190819-48d2c6294b0bf3e16be4c2a83399da9108544d5f.tar.gz) = 50b0130f26d8d73f748434dc365908f7bca8fb059967e1e6b777142d2bf81ffe30e43a103232f0d85a8178651ae348faeb00d75fc610c4703649905d44771d25
Size (cannonball-0.3.20190819-48d2c6294b0bf3e16be4c2a83399da9108544d5f.tar.gz) = 278411 bytes

View File

@ -1,50 +0,0 @@
.\" Manpage for cannonball
.TH "cannonball" "6" "August 2019" "CannonBall 0.3" "CannonBall - Configuration Help"
.SH NAME
cannonball \- An Enhanced OutRun Engine
.SH SYNOPSIS
cannonball
.SH DESCRIPTION
CannonBall is a program which allows you to play an enhanced version
of Yu Suzuki's seminal arcade racer, OutRun, on a variety of systems.
.SH CONFIGURATION
In order for CannonBall to work you need to provide a copy of the
OutRun revision B romset to the roms subdirectory. Rename the files if
necessary.
The roms subdirectory can be found at $XDG_DATA_HOME/cannonball/roms
which defaults to $HOME/.local/share/cannonball/roms
Configuration can be found at $XDG_DATA_HOME/cannonball/config.xml
which defaults to $HOME/.local/share/cannonball/config.xml
NOTE: The directories will be created on the first run of Cannonball
if they do not exist.
.SH OPTIONS
cannonball does not take any options.
.SH SEE ALSO
CannonBall Wiki <https://github.com/djyt/cannonball/wiki>
CannonBall online manual
<https://github.com/djyt/cannonball/wiki/Cannonball-Manual>
.SH BUGS
For known issues see <https://github.com/djyt/cannonball/issues>.
.SH COPYRIGHT
Copyright (c) 2012-2014 Chris White.
Users of CannonBall are expected to own licensed copies of the ROM
files that is intended to be used with this program. These ROMs may be
subject to their copyright laws under their jurisdiction. Make sure
you can legally transfer the ROMs to your system before using them
with this program.
OutRun ROMs may be subject to copyright laws.
OutRun is a trademark of the SEGA Corporation. This project is not
affiliated with SEGA in any way.
.SH AUTHOR
Chris White <pointblnk@hotmail.com> - Project creator.
Arun Horne - Cross platform work.
Santhosh Raju <fox@NetBSD.org> - Man page.

View File

@ -1,34 +0,0 @@
$NetBSD$
Adds support for BSD based builds.
1. PREFIX path is configured via BSD_PREFIX_PATH for BSDs.
2. Boost include directory is set from bsd.cmake for BSDs.
--- cmake/CMakeLists.txt.orig 2019-08-18 00:42:17.620253273 +0000
+++ cmake/CMakeLists.txt
@@ -20,12 +20,22 @@ if(TARGET)
message("CMake files for ${TARGET} not found, using ${DCMAKE}")
include(${DCMAKE})
endif()
+ if(${TARGET} STREQUAL "bsd")
+ if(NOT DEFINED BSD_PREFIX_PATH)
+ message(FATAL_ERROR "Warning: BSD_PREFIX_PATH Variable Not Defined!")
+ else()
+ message("Setting ${BSD_PREFIX_PATH} as the prefix path.")
+ endif()
+ endif()
else()
message("TARGET not passed, using ${DCMAKE}")
include(${DCMAKE})
endif(TARGET)
-set(BOOST_INCLUDEDIR ${lib_base}/boost_1_54_0)
+if(NOT(${TARGET} STREQUAL "bsd"))
+ set(BOOST_INCLUDEDIR ${lib_base}/boost_1_54_0)
+endif()
+
find_package(Boost REQUIRED)
# Include

View File

@ -1,30 +0,0 @@
$NetBSD$
Create a cmake file for BSD based builds.
--- cmake/bsd.cmake.orig 2019-08-18 00:41:57.311525123 +0000
+++ cmake/bsd.cmake
@@ -0,0 +1,23 @@
+# Default CMake Setup. Used for BSD Builds.
+
+set(lib_base ${BSD_PREFIX_PATH}/include)
+
+set(BOOST_INCLUDEDIR ${lib_base})
+
+set(sdl_root ${lib_base}/SDL)
+
+include_directories("${sdl_root}")
+
+link_libraries(cannonball
+ SDL
+)
+
+# Linking
+link_directories(
+ "${BSD_PREFIX_PATH}/lib"
+)
+
+# Location for Cannonball to create save files
+# Used to auto-generate setup.hpp with various file paths
+set(xml_directory ./)
+set(sdl_flags "SDL_DOUBLEBUF | SDL_SWSURFACE")