openfodder: update to openfodder-1.6.0

From the release page:

* Whats new in 1.6.0

Ini for configuration options
JavaScript engine for random map generation
JavaScript engine debugging (See JSDebug build on Discord)
Support more sprites than original engine
Support for maps of any size (limitation is system memory)
Better game asset detection

* Whats fixed

Crash on final PC mission
Amiga intro helicopter no longer flicker
PC Ufo sprite sheet alignment

* Notes

It is advised to increase the maximum sprites/spawns on random maps
This commit is contained in:
Yorick Hardy 2020-01-06 22:30:30 +02:00
parent 185c8e41fe
commit 5a6cb88a14
6 changed files with 49 additions and 39 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD$
GITHUB_PROJECT= openfodder
DISTNAME= 1.5.3
DISTNAME= 1.6.0
PKGNAME= ${GITHUB_PROJECT}-${DISTNAME}
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=OpenFodder/}
@ -22,12 +22,12 @@ LIBS+= `sdl2-config --libs`
LIBS+= -lSDL2_mixer
LIBS+= ${X11_LDFLAGS}
DEPENDS+= openfodder-data-1.6.0:../../wip/openfodder-data
DEPENDS+= openfodder-data-1.7.0:../../wip/openfodder-data
FODDER_SRCDIRS= Source Source/Amiga Source/PC Source/Structures
FODDER_SRCDIRS= Source Source/Amiga Source/Map Source/PC Source/Structures Source/Utils
FODDER_SRCS= ${FODDER_SRCDIRS:=/*.cpp}
INSTALLATION_DIRS+= bin share/doc/OpenFodder
INSTALLATION_DIRS+= bin share/doc/OpenFodder share/examples/OpenFodder
do-build:
${ECHO} 'const char* gitversion="pkgsrc-${PKGVERSION_NOREV}";' > ${WRKSRC}/Source/gitver.hpp
@ -35,7 +35,9 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/OpenFodder ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/INSTALL.md ${DESTDIR}${PREFIX}/share/doc/OpenFodder/
${INSTALL_DATA} ${WRKSRC}/README.md ${DESTDIR}${PREFIX}/share/doc/OpenFodder/
${INSTALL_DATA} ${WRKSRC}/openfodder.ini.example ${DESTDIR}${PREFIX}/share/examples/OpenFodder/
.include "../../audio/SDL2_mixer/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"

View File

@ -1,3 +1,5 @@
@comment $NetBSD$
bin/OpenFodder
share/doc/OpenFodder/INSTALL.md
share/doc/OpenFodder/README.md
share/examples/OpenFodder/openfodder.ini.example

View File

@ -1,7 +1,8 @@
$NetBSD$
SHA1 (openfodder/1.5.3.tar.gz) = aa1007a06ea3c03f483f6941194ec8288cc121b0
RMD160 (openfodder/1.5.3.tar.gz) = b1b725c5268d8c5b7d5b0eb1cc06a00f229b96aa
SHA512 (openfodder/1.5.3.tar.gz) = 9556cb83b85ab92aec80813cfb2ce79956369aba19c2fe6515162ce03ea86f3e46b2ed235a114648f56f685cc1e03de0630582dcf35fff49092a61beb841ed30
Size (openfodder/1.5.3.tar.gz) = 424997 bytes
SHA1 (patch-Source_stdafx.cpp) = be4b9baa22d9b5750f8400ca6e913dac4a8e3e1c
SHA1 (openfodder/1.6.0.tar.gz) = 2856d566ecfb5624f99287dc1b99d8fbf81b65a1
RMD160 (openfodder/1.6.0.tar.gz) = 828f2c2f4d40451738075f201b76f60c5728a85d
SHA512 (openfodder/1.6.0.tar.gz) = d0e77ff16e1e2aa7f758350a9813f59dcf3db766a197850192c955ab6b6d53d6de89276540a1bc84588b8b33be22f0921c38ab76f08fea863711f9697e75b75a
Size (openfodder/1.6.0.tar.gz) = 1421940 bytes
SHA1 (patch-Source_ResourceMan.cpp) = 9d825f5ce9d94fb10708315e533878f17433b893
SHA1 (patch-Source_Utils_SimplexIslands.hpp) = fa32683d975ddfbbb7adf2fb9147defb8f5df57e

View File

@ -0,0 +1,21 @@
$NetBSD$
Use PREFIX when searching for data.
--- Source/ResourceMan.cpp.orig 2019-12-31 20:48:13.000000000 +0000
+++ Source/ResourceMan.cpp
@@ -82,6 +82,7 @@ void cResourceMan::addDefaultDirs() {
addBaseDir(path + "/.local/share/");
}
addBaseDir("/usr/local/share/");
+ addBaseDir(OPENFODDER_DATADIR);
#endif
}
@@ -624,4 +625,4 @@ std::vector<std::string> cResourceMan::D
return results;
}
-#endif
\ No newline at end of file
+#endif

View File

@ -0,0 +1,14 @@
$NetBSD$
Need stdint.h for int32_t.
--- Source/Utils/SimplexIslands.hpp.orig 2019-12-31 20:48:13.000000000 +0000
+++ Source/Utils/SimplexIslands.hpp
@@ -15,6 +15,7 @@
*
*/
#include <math.h>
+#include <stdint.h>
struct Grad
{
double x, y, z, w;

View File

@ -1,30 +0,0 @@
$NetBSD$
Use PREFIX when searching for data.
--- Source/stdafx.cpp.orig 2018-12-11 09:43:06.000000000 +0000
+++ Source/stdafx.cpp
@@ -245,14 +245,19 @@ void local_BasePathGenerate() {
if (path) {
FinalPath = path;
FinalPath.append("/.local/share/");
+ filePathFinal << FinalPath << "OpenFodder/";
+ if (!local_FileExists(filePathFinal.str())) {
+ FinalPath = "";
+ filePathFinal.str("");
+ }
}
}
// Fall back just incase
- if (!FinalPath.size())
- FinalPath = "/usr/local/share/";
-
- filePathFinal << FinalPath << "OpenFodder/";
+ if (!FinalPath.size()) {
+ FinalPath = OPENFODDER_DATADIR;
+ filePathFinal << FinalPath << "OpenFodder/";
+ }
#endif