Add neko 2.2.0 as wip/neko.

This is a minimally configured distribution of the Neko virtual machine. We
should include an options.mk next.
This commit is contained in:
Charlotte Koch 2018-12-22 14:39:33 -08:00
parent e6657ec19d
commit 5bbcfd342f
6 changed files with 72 additions and 0 deletions

View File

@ -2267,6 +2267,7 @@ SUBDIR+= neb-cd512
SUBDIR+= neb-hdtoolbox
SUBDIR+= necpp-git
SUBDIR+= nehe-opengl-tutorials
SUBDIR+= neko
SUBDIR+= nemo
SUBDIR+= neovim
SUBDIR+= neovim-git

6
neko/DESCR Normal file
View File

@ -0,0 +1,6 @@
Neko is a high-level dynamically typed programming language. It can be used
as an embedded scripting language. It has been designed to provide a common
runtime for several different languages. Learning and using Neko is very
easy. You can easily extend the language with C libraries. You can also
write generators from your own language to Neko and then use the Neko
Runtime to compile, run, and access existing libraries.

27
neko/Makefile Normal file
View File

@ -0,0 +1,27 @@
# $NetBSD$
DISTNAME= neko-2.2.0
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GITHUB:=HaxeFoundation/}
GITHUB_TAG= v${PKGVERSION_NOREV:S/./-/g}
MAINTAINER= cfkoch@edgebsd.org
COMMENT= The Neko virtual machine
LICENSE= mit
EXTRACT_USING= gtar
USE_LANGUAGES= c
USE_CMAKE= yes
# XXX Minimal configuration for now. Should use options.mk instead.
CMAKE_ARGS+= -DWITH_REGEXP:BOOL=OFF
CMAKE_ARGS+= -DWITH_UI:BOOL=OFF
CMAKE_ARGS+= -DWITH_SSL:BOOL=OFF
CMAKE_ARGS+= -DWITH_MYSQL:BOOL=OFF
CMAKE_ARGS+= -DWITH_SQLITE:BOOL=OFF
CMAKE_ARGS+= -DWITH_APACHE:BOOL=OFF
CMAKE_ARGS+= -DWITH_NEKOML:BOOL=OFF
.include "../../devel/boehm-gc/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

17
neko/PLIST Normal file
View File

@ -0,0 +1,17 @@
@comment $NetBSD$
bin/neko
bin/nekoc
bin/nekotools
include/neko.h
include/neko_elf.h
include/neko_mod.h
include/neko_vm.h
lib/cmake/Neko/NekoConfig.cmake
lib/cmake/Neko/NekoConfigVersion.cmake
lib/cmake/Neko/NekoTargets-noconfig.cmake
lib/cmake/Neko/NekoTargets.cmake
lib/libneko.so
lib/libneko.so.2
lib/libneko.so.2.2.0
lib/neko/std.ndll
lib/neko/zlib.ndll

7
neko/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (neko-2.2.0.tar.gz) = 5edf252759c156625cd226f5594bdf64663fe782
RMD160 (neko-2.2.0.tar.gz) = a91e97a7234e4d8d54156f38cb6192d61296d399
SHA512 (neko-2.2.0.tar.gz) = 4bc89fddf4a5ae94e73843b06a3b6fe8de59d72922764276a5bd9d56daf6570525e842039bf704598b41e1de4a5fe08931adc4ca9730fe3333be0beb7a1ccaed
Size (neko-2.2.0.tar.gz) = 510643 bytes
SHA1 (patch-CMakeLists.txt) = 76c56efa8c8f5a2f6d04932085592c606dee03c5

View File

@ -0,0 +1,14 @@
$NetBSD$
Specify additional systems which do not use libdl.
--- CMakeLists.txt.orig 2018-12-22 14:27:53.412791761 -0800
+++ CMakeLists.txt 2018-12-22 14:28:10.004843917 -0800
@@ -360,7 +360,7 @@
target_link_libraries(nekovm libneko)
if(UNIX)
- if (NOT ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ if (NOT ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD" AND NOT ${CMAKE_SYSTEM_NAME} STREQUAL "NetBSD")
set(DL_LIB "dl")
endif()
find_package(Threads)