py-rlp: remove the package

This was imported to pkgsrc.
This commit is contained in:
Pierre Pronchery 2020-10-08 20:18:16 +02:00
parent 0d5faf5e12
commit 5d22d235c2
6 changed files with 0 additions and 138 deletions

View File

@ -4058,7 +4058,6 @@ SUBDIR+= py-riccipy
SUBDIR+= py-rich
SUBDIR+= py-rigidbodysimulator
SUBDIR+= py-rlcompleter2
SUBDIR+= py-rlp
SUBDIR+= py-rogues
SUBDIR+= py-ropemode
SUBDIR+= py-rpaths

View File

@ -1,23 +0,0 @@
TODO: Adjust the following lines from README.md
# pyrlp
[![Build Status](https://travis-ci.org/ethereum/pyrlp.svg?branch=develop)](https://travis-ci.org/ethereum/pyrlp)
[![Coverage Status](https://coveralls.io/repos/ethereum/pyrlp/badge.svg)](https://coveralls.io/r/ethereum/pyrlp)
[![PyPI version](https://badge.fury.io/py/rlp.svg)](http://badge.fury.io/py/rlp)
A Python implementation of Recursive Length Prefix encoding (RLP). You can find
the specification of the standard in the
[Ethereum wiki](https://github.com/ethereum/wiki/wiki/RLP) and the
documentation of this package on
[readthedocs](http://pyrlp.readthedocs.org/en/latest/).
### Release setup
For Debian-like systems:
```
apt install pandoc
```
...

View File

@ -1,37 +0,0 @@
# $NetBSD$
GITHUB_PROJECT= pyrlp
GITHUB_TAG= v1.2.0
DISTNAME= v1.2.0
PKGNAME= ${PYPKGPREFIX}-rlp-${DISTNAME:S,^v,,}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_GITHUB:=ethereum/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= khorben@defora.org
HOMEPAGE= https://github.com/ethereum/pyrlp
COMMENT= Recursive Length Prefix (RLP) encoding and decoding
LICENSE= mit
BUILD_DEPENDS+= ${PYPKGPREFIX}-bumpversion-[0-9]*:../../wip/py-bumpversion
BUILD_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
BUILD_DEPENDS+= # TODO: pytest-xdist>=0
BUILD_DEPENDS+= # TODO: pytest-watch>=4.1.0,<5
BUILD_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
BUILD_DEPENDS+= ${PYPKGPREFIX}-ipython-[0-9]*:../../devel/py-ipython
BUILD_DEPENDS+= ${PYPKGPREFIX}-twine-[0-9]*:../../net/py-twine
BUILD_DEPENDS+= # TODO: pytest==3.3.2>=0
BUILD_DEPENDS+= ${PYPKGPREFIX}-tox-[0-9]*:../../devel/py-tox
BUILD_DEPENDS+= ${PYPKGPREFIX}-flake8-[0-9]*:../../devel/py-flake8
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx-[0-9]*:../../textproc/py-sphinx
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx-rtd-theme-[0-9]*:../../textproc/py-sphinx-rtd-theme
DEPENDS+= ${PYPKGPREFIX}-eth-utils-[0-9]*:../../wip/py-eth-utils
PYTHON_VERSIONED_DEPENDENCIES= hypothesis:test
USE_LANGUAGES= # none
# TODO: Migrate MASTER_SITES to MASTER_SITE_PYPI
.include "../../lang/python/egg.mk"
.include "../../lang/python/versioned_dependencies.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,49 +0,0 @@
@comment $NetBSD$
${PYSITELIB}/rlp-${PKGVERSION}-py${PYVERSSUFFIX}.egg-info/PKG-INFO
${PYSITELIB}/rlp-${PKGVERSION}-py${PYVERSSUFFIX}.egg-info/SOURCES.txt
${PYSITELIB}/rlp-${PKGVERSION}-py${PYVERSSUFFIX}.egg-info/dependency_links.txt
${PYSITELIB}/rlp-${PKGVERSION}-py${PYVERSSUFFIX}.egg-info/not-zip-safe
${PYSITELIB}/rlp-${PKGVERSION}-py${PYVERSSUFFIX}.egg-info/requires.txt
${PYSITELIB}/rlp-${PKGVERSION}-py${PYVERSSUFFIX}.egg-info/top_level.txt
${PYSITELIB}/rlp/__init__.py
${PYSITELIB}/rlp/__init__.pyc
${PYSITELIB}/rlp/__init__.pyo
${PYSITELIB}/rlp/atomic.py
${PYSITELIB}/rlp/atomic.pyc
${PYSITELIB}/rlp/atomic.pyo
${PYSITELIB}/rlp/codec.py
${PYSITELIB}/rlp/codec.pyc
${PYSITELIB}/rlp/codec.pyo
${PYSITELIB}/rlp/exceptions.py
${PYSITELIB}/rlp/exceptions.pyc
${PYSITELIB}/rlp/exceptions.pyo
${PYSITELIB}/rlp/lazy.py
${PYSITELIB}/rlp/lazy.pyc
${PYSITELIB}/rlp/lazy.pyo
${PYSITELIB}/rlp/sedes/__init__.py
${PYSITELIB}/rlp/sedes/__init__.pyc
${PYSITELIB}/rlp/sedes/__init__.pyo
${PYSITELIB}/rlp/sedes/big_endian_int.py
${PYSITELIB}/rlp/sedes/big_endian_int.pyc
${PYSITELIB}/rlp/sedes/big_endian_int.pyo
${PYSITELIB}/rlp/sedes/binary.py
${PYSITELIB}/rlp/sedes/binary.pyc
${PYSITELIB}/rlp/sedes/binary.pyo
${PYSITELIB}/rlp/sedes/boolean.py
${PYSITELIB}/rlp/sedes/boolean.pyc
${PYSITELIB}/rlp/sedes/boolean.pyo
${PYSITELIB}/rlp/sedes/lists.py
${PYSITELIB}/rlp/sedes/lists.pyc
${PYSITELIB}/rlp/sedes/lists.pyo
${PYSITELIB}/rlp/sedes/raw.py
${PYSITELIB}/rlp/sedes/raw.pyc
${PYSITELIB}/rlp/sedes/raw.pyo
${PYSITELIB}/rlp/sedes/serializable.py
${PYSITELIB}/rlp/sedes/serializable.pyc
${PYSITELIB}/rlp/sedes/serializable.pyo
${PYSITELIB}/rlp/sedes/text.py
${PYSITELIB}/rlp/sedes/text.pyc
${PYSITELIB}/rlp/sedes/text.pyo
${PYSITELIB}/rlp/utils.py
${PYSITELIB}/rlp/utils.pyc
${PYSITELIB}/rlp/utils.pyo

View File

@ -1,7 +0,0 @@
$NetBSD$
SHA1 (pyrlp/v1.2.0.tar.gz) = bebc1163631e21b30b529c0058838b741fca5047
RMD160 (pyrlp/v1.2.0.tar.gz) = 50abca33a77eedb2d7095fef6ab67de66b0485a9
SHA512 (pyrlp/v1.2.0.tar.gz) = 19fe6ce84ad43111f74807f6d4dfdde6dfe58eec0a36cce111083cd03ae2766494a66d3b211cd3593783b5f03bf7471961ae346beb8bdd917539b83fff435abe
Size (pyrlp/v1.2.0.tar.gz) = 38972 bytes
SHA1 (patch-setup.py) = a26d8c5bfad30f1ed15c69f14f58d452614a0485

View File

@ -1,21 +0,0 @@
$NetBSD$
Remove dependency on py-setuptools-markdown
--- setup.py.orig 2019-12-02 17:00:58.000000000 +0000
+++ setup.py
@@ -44,13 +44,12 @@ setup(
# *IMPORTANT*: Don't manually change the version here. See README for more.
version='1.2.0',
description="A package for Recursive Length Prefix encoding and decoding",
- long_description_markdown_filename='README.md',
+ long_description_content_type='text/markdown',
author="jnnk",
author_email='jnnknnj@gmail.com',
url='https://github.com/ethereum/pyrlp',
packages=find_packages(exclude=["tests", "tests.*"]),
include_package_data=True,
- setup_requires=['setuptools-markdown'],
install_requires=[
"eth-utils>=1.0.2,<2",
],