Version bump of dma to v0.12 and fix build

This commit is contained in:
Thomas Merkel 2019-09-07 11:07:32 +02:00
parent a7d2857a23
commit 5db66ab52e
6 changed files with 19 additions and 64 deletions

View File

@ -1,11 +1,11 @@
# $NetBSD$
DISTNAME= dma-${GITHUB_TAG}
PKGNAME= dma-0.11
PKGNAME= dma-0.12
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_GITHUB:=corecode/}
GITHUB_PROJECT= dma
GITHUB_TAG= v0.11
GITHUB_TAG= v0.12
MAINTAINER= cfkoch@edgebsd.org
HOMEPAGE= https://github.com/corecode/dma
@ -53,4 +53,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/dma.conf ${DESTDIR}${EGDIR}/dma.conf
${INSTALL_DATA} ${WRKSRC}/auth.conf ${DESTDIR}${EGDIR}/auth.conf
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,14 +1,12 @@
$NetBSD$
SHA1 (dma-v0.11.tar.gz) = 39badd49b6305c282df7734c927e7a90420265dc
RMD160 (dma-v0.11.tar.gz) = 1ec92cb8854640a1f0e0fc1f5cdf7132f715949e
SHA512 (dma-v0.11.tar.gz) = 8ccf85a921da12cbf5b9f2c93dd96da91d2acdace979ed4a6b37af94e72441bf654ac65525fc2c1118c1b16136278de4daeafc753dcaf4300a017e317f83fc4d
Size (dma-v0.11.tar.gz) = 34529 bytes
SHA1 (dma-v0.12.tar.gz) = 4662ead892eb98bdc746c45beab4cc0f4f26e8f7
RMD160 (dma-v0.12.tar.gz) = 01520083b2880515637e67ff2af6faa858c1829a
SHA512 (dma-v0.12.tar.gz) = 7840cd3d8da9045891f6daa6c7758a63886f7b62ce9f4a21cbe0b354fe3e39fcd57bacd582391df99554160faf32b61b470d39090a14996ab2ea19c8cc98daa2
Size (dma-v0.12.tar.gz) = 35603 bytes
SHA1 (patch-Makefile) = 76395db385e3afb8f3d3678f12bb676c0ef73f67
SHA1 (patch-crypto.c) = 80f4eb7c3a7e5dc296259ac90678b0d8eac0ec35
SHA1 (patch-dma.c) = a77711f474ded4c53eeb3176bd0c561777c15807
SHA1 (patch-dma.h) = c1d57229ec790f5f11a18f277c19e0ba1cdcfdd4
SHA1 (patch-dns.c) = 5f8a7adb8b1ca379ab8b837e56ca044d7699d2f1
SHA1 (patch-local.c) = 28cfa61aedc87851addf0db0c347d0bce820869d
SHA1 (patch-mail.c) = c4d952d16086f3c47448f6e4a55f24ed86da3e9b
SHA1 (patch-spool.c) = 1c63ef62cefa3a20da3001d841393bbaf6ac5978
SHA1 (patch-mail.c) = b5397243763d2283cab33b1aa5d55cfd9ef4792e
SHA1 (patch-spool.c) = 9094f7e106d7c3f2b97a064eee4087d1ad5b78bc

View File

@ -1,14 +0,0 @@
$NetBSD$
Include strings.h for bzero and bcopy function.
--- crypto.c.orig 2016-02-07 12:41:49.000000000 +0000
+++ crypto.c
@@ -40,6 +40,7 @@
#include <openssl/pem.h>
#include <openssl/rand.h>
+#include <strings.h>
#include <syslog.h>
#include "dma.h"

View File

@ -1,14 +0,0 @@
$NetBSD$
Include strings.h for bzero and bcopy function.
--- local.c.orig 2016-02-07 12:41:49.000000000 +0000
+++ local.c
@@ -45,6 +45,7 @@
#include <stdint.h>
#include <stdio.h>
#include <syslog.h>
+#include <strings.h>
#include <unistd.h>
#include "dma.h"

View File

@ -3,17 +3,9 @@ $NetBSD$
Rename queue to dma_queue because the struct is already defined in SunOS.
Include strings.h for bzero and bcopy function.
--- mail.c.orig 2016-02-07 12:41:49.000000000 +0000
--- mail.c.orig 2019-08-20 09:52:52.000000000 +0000
+++ mail.c
@@ -36,6 +36,7 @@
#include <errno.h>
#include <inttypes.h>
#include <signal.h>
+#include <strings.h>
#include <syslog.h>
#include <unistd.h>
@@ -44,7 +45,7 @@
@@ -46,7 +46,7 @@
void
bounce(struct qitem *it, const char *reason)
{
@ -22,7 +14,7 @@ Include strings.h for bzero and bcopy function.
char line[1000];
size_t pos;
int error;
@@ -160,7 +161,7 @@ struct parse_state {
@@ -162,7 +162,7 @@ struct parse_state {
* XXX local addresses will need treatment
*/
static int
@ -31,7 +23,7 @@ Include strings.h for bzero and bcopy function.
{
char *addr;
@@ -342,7 +343,7 @@ newaddr:
@@ -344,7 +344,7 @@ newaddr:
}
int

View File

@ -2,17 +2,9 @@ $NetBSD$
Rename queue to dma_queue because the struct is already defined in SunOS.
--- spool.c.orig 2016-02-07 12:41:49.000000000 +0000
--- spool.c.orig 2019-08-20 09:52:52.000000000 +0000
+++ spool.c
@@ -46,6 +46,7 @@
#include <inttypes.h>
#include <unistd.h>
#include <syslog.h>
+#include <strings.h>
#include "dma.h"
@@ -69,7 +70,7 @@
@@ -72,7 +72,7 @@
*/
int
@ -21,7 +13,7 @@ Rename queue to dma_queue because the struct is already defined in SunOS.
{
char fn[PATH_MAX+1];
struct stat st;
@@ -151,10 +152,10 @@ writequeuef(struct qitem *it)
@@ -154,10 +154,10 @@ writequeuef(struct qitem *it)
}
static struct qitem *
@ -34,7 +26,7 @@ Rename queue to dma_queue because the struct is already defined in SunOS.
FILE *queuef = NULL;
char *s;
char *queueid = NULL, *sender = NULL, *addr = NULL;
@@ -229,7 +230,7 @@ out:
@@ -232,7 +232,7 @@ out:
}
int
@ -43,7 +35,7 @@ Rename queue to dma_queue because the struct is already defined in SunOS.
{
struct stat st;
struct qitem *it;
@@ -276,7 +277,7 @@ delfiles:
@@ -279,7 +279,7 @@ delfiles:
}
int
@ -52,7 +44,7 @@ Rename queue to dma_queue because the struct is already defined in SunOS.
{
struct stat sb;
struct qitem *it;
@@ -382,7 +383,7 @@ fail:
@@ -385,7 +385,7 @@ fail:
}
void