added support for Solaris

This commit is contained in:
Georg Schwarz 2009-11-22 10:26:10 +00:00 committed by Thomas Klausner
parent 5d3bfe7aec
commit 60bc718928
3 changed files with 24 additions and 2 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2009/04/19 20:16:24 gschwarz Exp $
# $NetBSD: Makefile,v 1.3 2009/11/22 10:26:10 gschwarz Exp $
DISTNAME= ar7-0.1
CATEGORIES= net
@ -14,4 +14,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= YES
INSTALLATION_DIRS= bin
USE_FEATURES+= getopt_long
LIBS.SunOS+= -lnsl -lsocket
.include "../../mk/bsd.pkg.mk"

View File

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2008/11/08 21:31:18 gschwarz Exp $
$NetBSD: distinfo,v 1.3 2009/11/22 10:26:10 gschwarz Exp $
SHA1 (ar7-0.1.tar.gz) = 76c2373f5890e7a511ac78c90c05f03ff60a644d
RMD160 (ar7-0.1.tar.gz) = 482696b197fdbefd6cad69a8f4ed50025c2c2258
Size (ar7-0.1.tar.gz) = 79230 bytes
SHA1 (patch-aa) = 8601b28856197e172423cd02db32171ed9b46ff6
SHA1 (patch-ab) = 04484effa7edfaa6081eb840d4eac87ea7ab2f85

18
ar7/patches/patch-ab Normal file
View File

@ -0,0 +1,18 @@
$NetBSD: patch-ab,v 1.1 2009/11/22 10:26:10 gschwarz Exp $
--- src/logic.c.orig 2009-11-08 10:49:06.920001000 +0100
+++ src/logic.c 2009-11-08 10:51:26.039999000 +0100
@@ -2,7 +2,13 @@
#include "err.h"
#include <stdio.h>
#include <string.h>
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/config.h> /* needed for the other headers */
+#include <nbcompat/cdefs.h> /* needed for the other headers */
+#include <nbcompat/getopt.h>
+#else
#include <getopt.h>
+#endif
#include "defaults.h"
int ar7_login(int fd, const char *user, const char *pass)