Import nudoku 2.0.0 as wip/nudoku.

nudoku is a ncurses based sudoku game. Perfect to relax a little or
just waste some time when you are on the console.
This commit is contained in:
Frederic Cambus 2019-12-12 22:24:36 +01:00
parent 8b0eca3448
commit 634008acdd
5 changed files with 58 additions and 0 deletions

2
nudoku/DESCR Normal file
View File

@ -0,0 +1,2 @@
nudoku is a ncurses based sudoku game. Perfect to relax a little or
just waste some time when you are on the console.

28
nudoku/Makefile Normal file
View File

@ -0,0 +1,28 @@
# $NetBSD$
DISTNAME= nudoku-2.0.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=jubalh/}
GITHUB_RELEASE= 2.0.0
MAINTAINER= fcambus@NetBSD.org
HOMEPAGE= https://jubalh.github.io/nudoku/
COMMENT= Ncurses based sudoku game
LICENSE= gnu-gpl-v3
# Fix gettext includes
SUBST_CLASSES+= includes
SUBST_STAGE.includes= post-configure
SUBST_MESSAGE.includes= Fix gettext includes
SUBST_FILES.includes= src/main.c
SUBST_FILES.includes+= src/sudoku.c
SUBST_SED.includes+= -e 's,"gettext.h",<libintl.h>,'
GNU_CONFIGURE= yes
USE_PKGLOCALEDIR= yes
FAKE_NCURSES= yes
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

7
nudoku/PLIST Normal file
View File

@ -0,0 +1,7 @@
@comment $NetBSD$
bin/nudoku
man/man6/nudoku.6
share/locale/de/LC_MESSAGES/nudoku.mo
share/locale/es/LC_MESSAGES/nudoku.mo
share/locale/fr/LC_MESSAGES/nudoku.mo
share/locale/ru/LC_MESSAGES/nudoku.mo

7
nudoku/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (nudoku-2.0.0.tar.gz) = 4eb056fa5d58551d7b57a2698428ddfcc521a9c5
RMD160 (nudoku-2.0.0.tar.gz) = ebe12ecf0a2f51a322d512e312e969c44cace8d4
SHA512 (nudoku-2.0.0.tar.gz) = acf0a5714fc767bb580c97d5ceb586db5390ce7a1428e56c1e7413af653cd784939dc5ae3681c4ad19fde0a3ee5e941f1a4466bc35eac4bdf802f0b9ba6b025f
Size (nudoku-2.0.0.tar.gz) = 203292 bytes
SHA1 (patch-src_main.c) = 96af8db25c7ea2839045be95cbcc99b1beee4609

View File

@ -0,0 +1,14 @@
$NetBSD$
Add missing <locale.h> header, for setlocale.
--- src/main.c.orig 2019-12-12 21:05:55.068322791 +0000
+++ src/main.c
@@ -20,6 +20,7 @@ along with this program. If not, see <ht
/* INCLUDES */
#include "gettext.h" /* gettext */
+#include <locale.h> /* setlocale */
#include <stdlib.h> /* rand, srand */
#include <unistd.h> /* getopt */
#include <ncurses.h> /* ncurses */