telegram-desktop: + some patches

This commit is contained in:
AcidBear 2020-03-13 15:02:52 +03:00
parent 7f8532781e
commit 6352fdc04d
4 changed files with 40 additions and 0 deletions

View File

@ -18,6 +18,8 @@ SHA1 (patch-call_delayed.h) = 935062178537df05e44a2e651bef2030faa613f3
SHA1 (patch-concurrent_timer.h) = 8b2356cbf705bfb9e19af2725475dd9bcd6a33d7
SHA1 (patch-export_api_wrap.h) = 2a492eb102225f05731567106932c7a91f8cd548
SHA1 (patch-export_data_types.h) = 01fa2c695e892172144fa254c7513d087f5e4a9d
SHA1 (patch-export_output_abstract.h) = 5602c23108699108f96f8d46e82bd3a4bab34048
SHA1 (patch-export_output_stats.h) = 736dbd60f9374f0bdc3b3f7ae1c187ad1f68bfb8
SHA1 (patch-export_settings.h) = ffc21f6d2ab3afccacd1dc67a9902f0c54333e80
SHA1 (patch-last_user_input.h) = 961f5a2a308ec973bc8037658c5658ce145627ef
SHA1 (patch-lib_base-CMakeLists.txt) = 940672a38a1168e2cb9835f84aecd3ad0ef041f4
@ -26,6 +28,7 @@ SHA1 (patch-lib_base-openssl_help.h) = 145e29381d9b7b6f3095db0cfc0d380fd3603f8e
SHA1 (patch-lib_export.cmake) = 70d41d6a858fe029b781174940c50eba6a20d9e9
SHA1 (patch-lib_mtproto.cmake) = b82484ff782d10366696f5d40912f17d5d2f6583
SHA1 (patch-lib_storage-CMakeLists.txt) = ef770e3f50f075d251262fc511ef21313f5edab1
SHA1 (patch-lib_ui-CMakeLists.txt) = 337297cf3bfe7b67b503dbf29b8c9c267ad4fc5d
SHA1 (patch-libtgvoip-audio-AudioIO.cpp) = 96b482354b3ad6321b3ea95767d0d55ba63dab38
SHA1 (patch-libtgvoip-audio-AudioInput.cpp) = 1624ba5ec9c4625fdf26ba898aded05f37fcdf82
SHA1 (patch-libtgvoip-audio-AudioOutput.cpp) = ec83d33d1158c0e3e8ada0e0458c84347a38e112

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/export/output/export_output_abstract.h.orig 2020-03-06 00:32:42.296561696 +0000
+++ Telegram/SourceFiles/export/output/export_output_abstract.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include <QtCore/QString>
+#include <memory>
namespace Export {
namespace Data {

View File

@ -0,0 +1,12 @@
$NetBSD$
--- Telegram/SourceFiles/export/output/export_output_stats.h.orig 2020-03-06 21:41:17.128893400 +0000
+++ Telegram/SourceFiles/export/output/export_output_stats.h
@@ -8,6 +8,7 @@ https://github.com/telegramdesktop/tdesk
#pragma once
#include <atomic>
+#include "../export_pch.h"
namespace Export {
namespace Output {

View File

@ -0,0 +1,13 @@
$NetBSD$
--- Telegram/lib_ui/CMakeLists.txt.orig 2020-03-06 23:16:00.470139439 +0000
+++ Telegram/lib_ui/CMakeLists.txt
@@ -26,7 +26,7 @@ generate_emoji(lib_ui emoji_suggestions/
set_target_properties(lib_ui PROPERTIES AUTOMOC ON AUTORCC ON)
-target_precompile_headers(lib_ui PRIVATE ${src_loc}/ui/ui_pch.h)
+#target_precompile_headers(lib_ui PRIVATE ${src_loc}/ui/ui_pch.h)
nice_target_sources(lib_ui ${src_loc}
PRIVATE
${style_files}