wip/gcc10snapshot: Update to 20200119.

This commit is contained in:
Kai-Uwe Eckhardt 2020-01-23 08:48:53 +01:00
parent 0c6b3c4d4e
commit 67df950cbf
4 changed files with 5 additions and 142 deletions

View File

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.23 2015/05/06 05:25:00 keckhardt Exp $
SHA1 (gcc-10-20200110.tar.xz) = 51874857c60b9d2dc9b6a75a0228e4c8acb5fff4
RMD160 (gcc-10-20200110.tar.xz) = 42e42430ace7eb25aa98ab2e9b8ea77e387054b2
SHA512 (gcc-10-20200110.tar.xz) = 5da15e91d658487c1b546fa6b24068a81f76a1446831bd1199958194cd634e37c2bb1b8950017f2178cf704d3af9e3357b369c711b3ef68349fcccc067db7726
Size (gcc-10-20200110.tar.xz) = 71327392 bytes
SHA1 (gcc-10-20200119.tar.xz) = 6f54e409e4d85cbf8eaf402ead9645741305e0de
RMD160 (gcc-10-20200119.tar.xz) = 74c64cff4c5f3d779d8ab22791435152b3f0a348
SHA512 (gcc-10-20200119.tar.xz) = 65c3421de88d76c13eb216c99df60ef15935d60056813336cd522add0e39fac403037ecb362bde9b36778d249b35de7ec192aa9900146231974ca3b2caff31aa
Size (gcc-10-20200119.tar.xz) = 71440592 bytes
SHA1 (isl-0.16.1.tar.bz2) = c5a2b201bf05229647e73203c0bf2d9679d4d21f
RMD160 (isl-0.16.1.tar.bz2) = 5a99db3fe0d0a1f6bbac1ed4448f2403495c55b2
SHA512 (isl-0.16.1.tar.bz2) = c188667a84dc5bdddb4ab7c35f89c91bf15a8171f4fcaf41301cf285fb7328846d9a367c096012fec4cc69d244f0bc9e95d84c09ec097394cd4093076f2a041b
@ -24,5 +24,3 @@ SHA1 (patch-libffi_testsuite_libffi.call_float2.c) = 6321dde308579448c27c2b6e1e3
SHA1 (patch-libgcc_config.host) = bdd4cd27249c8b62793204428d95c977d58f06fb
SHA1 (patch-libgcc_crtstuff.c) = e3a3b02a26229992851f195b5701cb1b86c29efe
SHA1 (patch-libgfortran_io_io.h) = d44676239a7f45e42054d24bd5224f43c20055c0
SHA1 (patch-libstdc++-v3_config_os_bsd_netbsd_ctype__base.h) = 1b907114f8b3477400fabc7b84ca5c16cd9c2930
SHA1 (patch-libstdc++-v3_config_os_bsd_netbsd_ctype__configure__char.cc) = d498ce411dfcd57652f87957778fab66dd4ab9a0

View File

@ -1,54 +0,0 @@
$NetBSD: patch-libstdc++-v3_config_os_bsd_netbsd_ctype__base.h,v 1.1 2017/05/03 00:21:03 maya Exp $
Sync with netbsd ctype_base.h
--- libstdc++-v3/config/os/bsd/netbsd/ctype_base.h.orig 2018-01-03 10:03:58.000000000 +0000
+++ libstdc++-v3/config/os/bsd/netbsd/ctype_base.h
@@ -38,14 +38,16 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
/// @brief Base class for ctype.
struct ctype_base
{
- // Non-standard typedefs.
- typedef const unsigned char* __to_type;
// NB: Offsets into ctype<char>::_M_table force a particular size
// on the mask type. Because of this, we don't use an enum.
- typedef unsigned char mask;
#ifndef _CTYPE_U
+ // Non-standard typedefs.
+ typedef const unsigned char* __to_type;
+
+ typedef unsigned char mask;
+
static const mask upper = _U;
static const mask lower = _L;
static const mask alpha = _U | _L;
@@ -58,17 +60,21 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
static const mask punct = _P;
static const mask alnum = _U | _L | _N;
#else
+ typedef const unsigned short* __to_type;
+
+ typedef unsigned short mask;
+
static const mask upper = _CTYPE_U;
static const mask lower = _CTYPE_L;
- static const mask alpha = _CTYPE_U | _CTYPE_L;
- static const mask digit = _CTYPE_N;
- static const mask xdigit = _CTYPE_N | _CTYPE_X;
+ static const mask alpha = _CTYPE_A;
+ static const mask digit = _CTYPE_D;
+ static const mask xdigit = _CTYPE_X;
static const mask space = _CTYPE_S;
- static const mask print = _CTYPE_P | _CTYPE_U | _CTYPE_L | _CTYPE_N | _CTYPE_B;
- static const mask graph = _CTYPE_P | _CTYPE_U | _CTYPE_L | _CTYPE_N;
+ static const mask print = _CTYPE_R;
+ static const mask graph = _CTYPE_G;
static const mask cntrl = _CTYPE_C;
static const mask punct = _CTYPE_P;
- static const mask alnum = _CTYPE_U | _CTYPE_L | _CTYPE_N;
+ static const mask alnum = _CTYPE_A | _CTYPE_D;
#endif
#if __cplusplus >= 201103L
static const mask blank = space;

View File

@ -1,81 +0,0 @@
$NetBSD: patch-libstdc++-v3_config_os_bsd_netbsd_ctype__configure__char.cc,v 1.1 2017/05/03 00:21:03 maya Exp $
Sync with netbsd ctype_configure_char.cc
--- libstdc++-v3/config/os/bsd/netbsd/ctype_configure_char.cc.orig 2018-01-03 10:03:58.000000000 +0000
+++ libstdc++-v3/config/os/bsd/netbsd/ctype_configure_char.cc
@@ -38,29 +38,27 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
// Information as gleaned from /usr/include/ctype.h
- extern "C" const u_int8_t _C_ctype_[];
-
const ctype_base::mask*
ctype<char>::classic_table() throw()
- { return _C_ctype_ + 1; }
+ { return _C_ctype_tab_ + 1; }
- ctype<char>::ctype(__c_locale, const mask* __table, bool __del,
- size_t __refs)
- : facet(__refs), _M_del(__table != 0 && __del),
- _M_toupper(NULL), _M_tolower(NULL),
+ ctype<char>::ctype(__c_locale, const mask* __table, bool __del,
+ size_t __refs)
+ : facet(__refs), _M_del(__table != 0 && __del),
+ _M_toupper(NULL), _M_tolower(NULL),
_M_table(__table ? __table : classic_table())
- {
+ {
memset(_M_widen, 0, sizeof(_M_widen));
_M_widen_ok = 0;
memset(_M_narrow, 0, sizeof(_M_narrow));
_M_narrow_ok = 0;
}
- ctype<char>::ctype(const mask* __table, bool __del, size_t __refs)
- : facet(__refs), _M_del(__table != 0 && __del),
- _M_toupper(NULL), _M_tolower(NULL),
+ ctype<char>::ctype(const mask* __table, bool __del, size_t __refs)
+ : facet(__refs), _M_del(__table != 0 && __del),
+ _M_toupper(NULL), _M_tolower(NULL),
_M_table(__table ? __table : classic_table())
- {
+ {
memset(_M_widen, 0, sizeof(_M_widen));
_M_widen_ok = 0;
memset(_M_narrow, 0, sizeof(_M_narrow));
@@ -69,14 +67,14 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
char
ctype<char>::do_toupper(char __c) const
- { return ::toupper((int) __c); }
+ { return ::toupper((int)(unsigned char) __c); }
const char*
ctype<char>::do_toupper(char* __low, const char* __high) const
{
while (__low < __high)
{
- *__low = ::toupper((int) *__low);
+ *__low = ::toupper((int)(unsigned char) *__low);
++__low;
}
return __high;
@@ -84,14 +82,14 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
char
ctype<char>::do_tolower(char __c) const
- { return ::tolower((int) __c); }
+ { return ::tolower((int)(unsigned char) __c); }
- const char*
+ const char*
ctype<char>::do_tolower(char* __low, const char* __high) const
{
while (__low < __high)
{
- *__low = ::tolower((int) *__low);
+ *__low = ::tolower((int)(unsigned char) *__low);
++__low;
}
return __high;

View File

@ -1,2 +1,2 @@
# $NetBSD: version.mk,v 1.21 2015/05/06 05:25:00 keckhardt Exp $
GCC10S_DIST_VERSION:= 10-20200110
GCC10S_DIST_VERSION:= 10-20200119