denise: a working way to get it to link and it even runs.

This commit is contained in:
Olaf Seibert 2020-10-25 22:37:45 +01:00
parent 15d8ed2f0d
commit 6ae2975beb
4 changed files with 3 additions and 28 deletions

View File

@ -9,7 +9,7 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= rhialto@NetBSD.org
HOMEPAGE= https://bitbucket.org/piciji/denise/
COMMENT= Commodore-64 emulator
#LICENSE= # TODO: (see mk/license.mk)
LICENSE= gnu-gpl-v3
WRKSRC= ${WRKDIR}/piciji-denise-b0f2c4bf4115
USE_LANGUAGES= c c++ #c++17
@ -17,7 +17,6 @@ USE_TOOLS+= gmake
.include "../../x11/gtk3/buildlink3.mk"
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../graphics/glew/buildlink3.mk" # needed? glUseProgram, glDeleteSync, glGetUniformLocation, glClientWaitSync, glBindFramebuffer, ...
.include "../../audio/pulseaudio/buildlink3.mk"
.include "../../audio/openal-soft/buildlink3.mk"
.include "../../devel/SDL2/buildlink3.mk"

View File

@ -5,5 +5,5 @@ RMD160 (v1.0.9.tar.bz2) = 8f204e0c3aef864ecd1e5ebad08fc26b5014bf41
SHA512 (v1.0.9.tar.bz2) = e106db70e37a22c0e861e2860e9fe4c08a91759da401e107b0d00bf0c35c4758367925eaa3b330ed021944ce86d4b4903038dcdb419e401b587293519ab71183
Size (v1.0.9.tar.bz2) = 5941348 bytes
SHA1 (patch-Makefile) = ffaa85b5cd947b87fa423e1ecb2bb54a9bd8f46a
SHA1 (patch-driver_Makefile) = fdf126d30eec635fdc01f9adac5ac330404b4b3a
SHA1 (patch-driver_video_opengl_opengl.h) = f4a18802efc2d05e7f68ed23e3d12c75541256f9
SHA1 (patch-driver_Makefile) = cfb336839ccbef29e01e4fb3fe045340592ff90c
SHA1 (patch-driver_video_opengl_bind.h) = c09521cece8c1dd1ddd88dda7d5f50a3ae9d867c

View File

@ -23,11 +23,3 @@ Also, GLEW may be the wrong thing but at least it compiles and links.
drvlink += $(if $(findstring openal,$(drv)),-lopenal)
ifneq ($(findstring xlib,$(drv)),)
drvlink += $(if $(findstring sdl,$(drv)), $(shell $(env)sdl2-config --libs))
@@ -74,6 +74,6 @@ drvlink += $(if $(findstring iokit,$(drv
drvlink += $(if $(findstring cgl,$(drv)),-framework OpenGL)
drvlink += $(if $(findstring coreaudio,$(drv)),-framework CoreAudio -framework AudioToolbox)
-drvlink += $(if $(findstring glx,$(drv)),-lGL)
+drvlink += $(if $(findstring glx,$(drv)),-lGL -lGLEW)
drvlink += $(if $(findstring udev,$(drv)),-ludev)
drvlink += $(if $(findstring pulseaudio,$(drv)),-lpulse)

View File

@ -1,16 +0,0 @@
$NetBSD$
Lots of functions remain undeclared in the original. I'm not sure which
header should be included. With <GL/glew.h> you also need to link with -lGLEW
which makes me uncomfortable.
--- driver/video/opengl/opengl.h.orig 2020-10-25 12:34:43.000000000 +0000
+++ driver/video/opengl/opengl.h
@@ -6,6 +6,7 @@
#include <GL/glext.h>
#define glGetProcAddress(name) wglGetProcAddress(name)
#else
+ #include <GL/glew.h>
#include <GL/gl.h>
#include <GL/glx.h>
#define glGetProcAddress(name) (*glXGetProcAddress)((const GLubyte*)(name))