workrave: Incomplete upgrade to 0.10.1

This commit is contained in:
Kamil Rytarowski 2020-02-11 12:37:11 +01:00
parent 30bed69341
commit 6be580ceaa
8 changed files with 139 additions and 204 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.6 2012/10/07 20:11:07 asau Exp $
DISTNAME= workrave-1.8.5
DISTNAME= workrave-1.10.1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=workrave/}
@ -9,6 +9,8 @@ HOMEPAGE= http://www.workrave.org/
COMMENT= Wrist break reminder program for prevention of RSI
LICENSE= gnu-gpl-v3
PYTHON_VERSIONS_ACCEPTED= 27 # 1.10.1
USE_LIBTOOL= YES
USE_TOOLS+= gmake pkg-config intltool
USE_LANGUAGES+= c c++
@ -29,6 +31,12 @@ EGDIR= ${PREFIX}/share/examples/${PKGBASE}
CONF_FILES+= ${EGDIR}/sound/events/workrave.soundlist \
${PKG_SYSCONFDIR}/sound/events/workrave.soundlist
.include "options.mk"
DEPENDS+= ${PYPKGPREFIX}-cheetah-[0-9]*:../../devel/py-cheetah
.include "../../x11/gtkmm/buildlink3.mk"
.include "../../devel/libsigc++/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../x11/libXtst/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.2 2007/10/01 22:51:22 briandealwis Exp $
SHA1 (workrave-1.8.5.tar.gz) = d40c3d536f1a37b849fcf8d1e7a6591e043cf19d
RMD160 (workrave-1.8.5.tar.gz) = 306364cbae2a1a4270cbd624864dc111b27ef388
Size (workrave-1.8.5.tar.gz) = 1940651 bytes
SHA1 (patch-ab) = d2d95b7489e447add4f37131830261c3950bcee8
SHA1 (patch-ac) = be17bb8f1dfba1a810d86d0d642022ee8192de13
SHA1 (patch-ad) = c4bedf25eb0d4b3e0b26d7491580047efcd7295c
SHA1 (workrave-1.10.1.tar.gz) = b5ad2c6748b0b9eb5e997532dd1401ebcb33dc40
RMD160 (workrave-1.10.1.tar.gz) = 2dd2578b49d31971167473214775fa2fd5b10b11
SHA512 (workrave-1.10.1.tar.gz) = 4f721ebaceb43f542c25b0eb3fcd2e2d205290c982ddb57628c56bfed0c63fdde85adf304b4fdaf07908e31e8e31942ffdf17a9f1f0a3e62fec71aa5722d946a
Size (workrave-1.10.1.tar.gz) = 6800197 bytes
SHA1 (patch-configure) = 3c056eb9601a1bf9fbd09da44de2e988dee0f947
SHA1 (patch-configure.ac) = 368216f3cf678fd6ed9b20f7e59ac601b1f0a989

View File

@ -1,101 +0,0 @@
# $NetBSD: options.mk,v 1.4 2012/11/23 22:34:06 othyro Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.workrave
PKG_SUPPORTED_OPTIONS+= arts dbus debug distributed
PKG_SUGGESTED_OPTIONS+= distributed
PKG_OPTIONS_REQUIRED_GROUPS= frontends backends
PKG_OPTIONS_GROUP.frontends= gtk gnome
# The backends (configuration databases) is a bit of a mess!
# * backends/src/Core.cc requires one of GConf, GDome (XML), or Qt
# * backends/src/Configurator.cc requires one of GLib or Qt
# to read .ini-style files
# Workrave doesn't currently support Qt without KDE.
# We interpret gnome to imply gconf.
# No KDE/Qt implies glib must be included
PKG_OPTIONS_GROUP.backends= xml gconf gnome
.include "../../mk/bsd.options.mk"
#.if !empty(PKG_OPTIONS:Mx11)
#CONFIGURE_ARGS+= --with-x
#. include "../../x11/libX11/buildlink3.mk"
#.else
#CONFIGURE_ARGS+= --without-x
#.endif
###
### GTK2
###
.if !empty(PKG_OPTIONS:Mgtk)
CONFIGURE_ARGS+= --enable-app-gtk
. include "../../x11/gtk2/buildlink3.mk"
. include "../../x11/gtkmm/buildlink3.mk"
. include "../../x11/libX11/buildlink3.mk"
. include "../../x11/libXt/buildlink3.mk"
. include "../../x11/libXmu/buildlink3.mk"
#XXX . include "../../devel/glibmm/buildlink3.mk"
#XXX . include "../../devel/libsigc++/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-app-gtk
.endif
###
### GNOME and GConf
### GNOME implies GConf
###
.if !empty(PKG_OPTIONS:Mgnome)
CONFIGURE_ARGS+= --enable-gnome --enable-gnomemm --enable-gconf
. include "../../devel/libgnomeui/buildlink3.mk"
. include "../../devel/libgnomeuimm/buildlink3.mk"
. include "../../devel/GConf/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-gnome --disable-gnomemm
. if !empty(PKG_OPTIONS:Mgconf)
CONFIGURE_ARGS+= --enable-gconf
. include "../../devel/GConf/buildlink3.mk"
. else
CONFIGURE_ARGS+= --disable-gconf
. endif
.endif
###
### XML backends (via GDome2)
###
.if !empty(PKG_OPTIONS:Mxml)
CONFIGURE_ARGS+= --enable-xml
. include "../../textproc/gdome2/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-xml
.endif
###
### DBus
###
.if !empty(PKG_OPTIONS:Mdbus)
CONFIGURE_ARGS+= --enable-dbus
. include "../../sysutils/dbus/buildlink3.mk"
. include "../../sysutils/dbus-glib/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-dbus
.endif
###
### Distributed: coordinate with workrave instances on other machines
###
.if !empty(PKG_OPTIONS:Mdistributed)
CONFIGURE_ARGS+= --enable-distributed
. include "../../net/gnet/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-distributed
.endif
###
### Debugging
###
.if !empty(PKG_OPTIONS:Mdebug)
CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif

View File

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1 2007/10/01 22:51:23 briandealwis Exp $
--- frontend/common/src/System.cc.orig 2007-09-14 12:50:32.000000000 -0600
+++ frontend/common/src/System.cc
@@ -39,6 +39,10 @@
#include <X11/Xutil.h>
#endif
+#if defined(HAVE_UNIX)
+#include <sys/wait.h>
+#endif
+
#ifdef WIN32
#include <shlobj.h>
#include "harpoon.h"

View File

@ -1,40 +0,0 @@
$NetBSD: patch-ac,v 1.1 2007/10/01 22:51:23 briandealwis Exp $
--- configure.orig 2007-09-14 14:25:06.000000000 -0600
+++ configure
@@ -2942,7 +2942,7 @@ if test "${enable_experimental+set}" = s
enableval=$enable_experimental; config_experimental=$enableval
else
- config_experimental==yes
+ config_experimental=yes
fi
@@ -40816,7 +40816,7 @@ fi
-if test "x$GNET_LIBS" == "x"; then
+if test "x$GNET_LIBS" = "x"; then
config_distribution=no
fi
@@ -48064,7 +48064,7 @@ _ACEOF
#AM_GLIB_GNU_GETTEXT
-if test "x$platform_win32" == "xyes"; then
+if test "x$platform_win32" = "xyes"; then
USE_NLS=yes
cat >>confdefs.h <<\_ACEOF
@@ -48772,7 +48772,7 @@ _ACEOF
fi
HAVE_GLIB=
-if test "x$GTKMM_LIBS" != "x"; then
+if test "x$GLIB_LIBS" != "x"; then
cat >>confdefs.h <<\_ACEOF
#define HAVE_GLIB

View File

@ -1,40 +0,0 @@
$NetBSD: patch-ad,v 1.1 2007/10/01 22:51:23 briandealwis Exp $
--- configure.ac.orig 2007-09-14 12:50:42.000000000 -0600
+++ configure.ac
@@ -119,7 +119,7 @@ AC_ARG_ENABLE( experimental,
[ --disable-experimental compile without experimental features],
config_experimental=$enableval
,
- config_experimental==yes
+ config_experimental=yes
)
dnl AC_MSG_CHECKING(whether to link statically)
@@ -460,7 +460,7 @@ AC_SUBST(GNET_LIBS)
AC_SUBST(GNET_CFLAGS)
-if test "x$GNET_LIBS" == "x"; then
+if test "x$GNET_LIBS" = "x"; then
config_distribution=no
fi
@@ -588,7 +588,7 @@ AM_GNU_GETTEXT()
#AM_GLIB_GNU_GETTEXT
dnl Hack because windows gettext package is SEVERELY broken...
-if test "x$platform_win32" == "xyes"; then
+if test "x$platform_win32" = "xyes"; then
USE_NLS=yes
AC_DEFINE(ENABLE_NLS,1,[Define to 1 if translation of program messages to the user's native
language is requested.])
@@ -719,7 +719,7 @@ if test "x$config_with_registry" = "xyes
fi
HAVE_GLIB=
-if test "x$GTKMM_LIBS" != "x"; then
+if test "x$GLIB_LIBS" != "x"; then
AC_DEFINE(HAVE_GLIB,,[Define if glib is available])
fi

View File

@ -0,0 +1,68 @@
$NetBSD$
--- configure.orig 2013-06-12 16:55:18.000000000 +0000
+++ configure
@@ -19093,7 +19093,7 @@ if test "x$ac_cv_lib_Xss_XScreenSaverReg
fi
- if test "x$have_xscreensaver" == "xyes"; then
+ if test "x$have_xscreensaver" = "xyes"; then
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -19221,11 +19221,11 @@ fi
if test "x$platform_os_unix" = "xyes"
then
- if test "x$enable_monitors" == "x"; then
- if test "x$have_xrecord" == "xyes" ; then
+ if test "x$enable_monitors" = "x"; then
+ if test "x$have_xrecord" = "xyes" ; then
enable_monitors="record"
fi
- if test "x$have_xscreensaver" == "xyes" ; then
+ if test "x$have_xscreensaver" = "xyes" ; then
if test "x$enable_monitors" != "x"; then
enable_monitors="$enable_monitors,"
fi
@@ -19239,11 +19239,8 @@ then
loop=${enable_monitors},
- while echo $loop | grep \, &> /dev/null
+ for monitor in `echo ${loop} | sed -e 's/,/ /g'`;
do
- monitor=${loop%%\,*}
- loop=${loop#*\,}
-
case "$monitor" in
record)
if test "x$have_xrecord" != "xyes" ; then
@@ -19357,7 +19354,7 @@ $as_echo "yes" >&6; }
fi
fi
-if test "x$config_dbus_gio" == "xno" -a "x$enable_dbus" != "xno"
+if test "x$config_dbus_gio" = "xno" -a "x$enable_dbus" != "xno"
then
if test "x$platform_os_win32" = "xyes"
then
@@ -19602,7 +19599,7 @@ $as_echo "#define HAVE_DBUS /**/" >>conf
$as_echo "#define HAVE_DBUSGLIB /**/" >>confdefs.h
fi
- if test "x$config_dbus_gio" == "xyes";
+ if test "x$config_dbus_gio" = "xyes";
then
$as_echo "#define HAVE_DBUS_GIO 1" >>confdefs.h
@@ -20119,7 +20116,7 @@ fi
config_gsettings=no
if test "x$enable_gsettings" != "xno" -a "x$config_gnome3" = "xyes"
then
- if test "x$platform_os_unix" == "xyes"; then
+ if test "x$platform_os_unix" = "xyes"; then
# Check whether --enable-schemas-compile was given.

View File

@ -0,0 +1,55 @@
$NetBSD$
--- configure.ac.orig 2013-06-12 16:40:10.000000000 +0000
+++ configure.ac
@@ -385,7 +385,7 @@ then
[],
[-lX11 -lXext -lm])
- if test "x$have_xscreensaver" == "xyes"; then
+ if test "x$have_xscreensaver" = "xyes"; then
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <X11/Xlib.h>
#include <X11/extensions/scrnsaver.h>
@@ -408,11 +408,11 @@ dnl
if test "x$platform_os_unix" = "xyes"
then
- if test "x$enable_monitors" == "x"; then
- if test "x$have_xrecord" == "xyes" ; then
+ if test "x$enable_monitors" = "x"; then
+ if test "x$have_xrecord" = "xyes" ; then
enable_monitors="record"
fi
- if test "x$have_xscreensaver" == "xyes" ; then
+ if test "x$have_xscreensaver" = "xyes" ; then
if test "x$enable_monitors" != "x"; then
enable_monitors="$enable_monitors,"
fi
@@ -475,7 +475,7 @@ PKG_CHECK_MODULES([GIO],
], [ config_dbus_gio=no])
fi
-if test "x$config_dbus_gio" == "xno" -a "x$enable_dbus" != "xno"
+if test "x$config_dbus_gio" = "xno" -a "x$enable_dbus" != "xno"
then
if test "x$platform_os_win32" = "xyes"
then
@@ -504,7 +504,7 @@ then
then
AC_DEFINE(HAVE_DBUSGLIB, , [DBus-glib support])
fi
- if test "x$config_dbus_gio" == "xyes";
+ if test "x$config_dbus_gio" = "xyes";
then
AC_DEFINE(HAVE_DBUS_GIO, 1, [Have GIO DBUS support])
fi
@@ -608,7 +608,7 @@ PKG_CHECK_MODULES([GLIB],
config_gsettings=no
if test "x$enable_gsettings" != "xno" -a "x$config_gnome3" = "xyes"
then
- if test "x$platform_os_unix" == "xyes"; then
+ if test "x$platform_os_unix" = "xyes"; then
GLIB_GSETTINGS
config_gsettings=yes
AC_DEFINE(HAVE_GSETTINGS, 1, [Have GSettings])