khotkeys: be happier about HAVE_X11

... Maybe the right way to fix all those (upstream) is to use
X11_FOUND as a variable, which will make the extra variable
redundant.
This commit is contained in:
coypu 2019-04-27 22:36:37 +03:00
parent 76fdee0dfe
commit 6ddda63d61
3 changed files with 25 additions and 0 deletions

View File

@ -4,3 +4,5 @@ SHA1 (khotkeys-5.12.4.tar.xz) = 0905c317459f52fb64055f05dd5b4c9914c37749
RMD160 (khotkeys-5.12.4.tar.xz) = a94e85457138294c60236f4f6224ee0fabe59a65
SHA512 (khotkeys-5.12.4.tar.xz) = dacf62abbd13ce37b308f797ca9c6fac740f0ae950c5ee7abd96eb561e6b5b817fd0ccd72b4d5d0ca1fe5a77bec4f1d14c9426877ebcb6cd852a5aa3441b49a4
Size (khotkeys-5.12.4.tar.xz) = 1058428 bytes
SHA1 (patch-CMakeLists.txt) = 76c5d572dce339d106ecee11952e28e7de9a2fb0
SHA1 (patch-config-X11.h.cmake) = 896b0c53e14c0150d9003cca36046e36befa95e0

View File

@ -0,0 +1,12 @@
$NetBSD$
--- CMakeLists.txt.orig 2019-04-27 19:24:43.601064954 +0000
+++ CMakeLists.txt
@@ -37,6 +37,7 @@ find_package(LibKWorkspace CONFIG REQUIR
if(X11_FOUND)
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS X11Extras )
set(HAVE_XTEST ${X11_XTest_FOUND})
+ set(HAVE_X11 ${X11_FOUND})
endif()
configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h)

View File

@ -0,0 +1,11 @@
$NetBSD$
--- config-X11.h.cmake.orig 2018-03-27 11:10:16.000000000 +0000
+++ config-X11.h.cmake
@@ -41,4 +41,4 @@
#cmakedefine HAS_RANDR_1_3 1
/* Define if you have X11 at all */
-#define HAVE_X11 ${X11_FOUND}
\ No newline at end of file
+#cmakedefine01 HAVE_X11