baresip: update to baresip-0.5.3

2017-05-14 Alfred E. Heggestad

	* Version 0.5.3

	* GIT URL: https://github.com/alfredh/baresip.git
	* GIT tag: v0.5.3
	* NOTE: Requires libre v0.5.3 or later
	        Requires librem v0.5.0 or later

	* config:
	  - (no changes)

	* build:
	  - detect jack module (thanks Tony Langley)
	  - Updated MSVS projects to vs2015 (thanks Mikhail Barg)

	* baresip-core:
	  - aulevel: add aulevel_calc_dbov()
	  - audio: Set correct clock rate for telephone events
		   (thanks Jan Hoffmann)
	  - play: Add gapless repeat for tone playback (thanks Jan Hoffmann)

	* selftest:
	  - add tests for aulevel
	  - add tests for audio player
	  - add mock aucodec/auplay

	* Modules:

	* gst_video1: Tune x264enc for low latency (thanks Jonathan Sieber)

	* httpd: fix a crash

	* ice: update to latest libre ICE-api

	* omx: Fixed some problems on OMX/RaspberryPi (thanks Jonathan Sieber)

	* srtp: fix SRTP for early-media (thanks Jan Hoffmann)

	* vumeter: use aulevel_calc_dbov to calculate signal energy

	* zrtp: update to latest libzrtp from freeswitch (thanks Juha Heinanen)
This commit is contained in:
Yorick Hardy 2017-05-14 20:39:41 +02:00
parent 3e7704fdbb
commit 6e4a99aa92
5 changed files with 10 additions and 39 deletions

View File

@ -1,16 +0,0 @@
===========================================================================
$NetBSD$
The "oss" module opens an audio device for playback and an audio device
for recording. On NetBSD current, baresip fails to open the same device
for both playback and recording. A workaround is to use
audio_player oss,/dev/fd/4
audio_source oss,/dev/fd/4
module oss.so
in the baresip config file, and run baresip using
baresip 4<>/dev/audio
Another option is to use the "jack" module.
===========================================================================

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.2 2014/09/05 08:06:00 thomasklausner Exp $
DISTNAME= baresip-0.5.2
DISTNAME= baresip-0.5.3
CATEGORIES= net audio
MASTER_SITES= http://www.creytiv.com/pub/

View File

@ -11,6 +11,7 @@ ${PLIST.ffmpeg}lib/baresip/modules/avformat.so
${PLIST.cairo}lib/baresip/modules/cairo.so
lib/baresip/modules/cons.so
lib/baresip/modules/contact.so
lib/baresip/modules/debug_cmd.so
lib/baresip/modules/fakevideo.so
lib/baresip/modules/g711.so
lib/baresip/modules/g722.so

View File

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.1 2014/08/10 00:26:01 thomasklausner Exp $
SHA1 (baresip-0.5.2.tar.gz) = c172bf2c09826c52e1ceef10374c9ab29753f354
RMD160 (baresip-0.5.2.tar.gz) = b8ef6faaee6a432190356b59129ef3e7df3bba2c
SHA512 (baresip-0.5.2.tar.gz) = bbea1090d98e84ceee13a482b8e0cdf59356bfe43fc6e4715998669fc510797a308a2ee4fe79b8fe3ac8244e0e637a1c0d4783bd629b405d8c6c6ed2b388fef1
Size (baresip-0.5.2.tar.gz) = 486949 bytes
SHA1 (patch-mk_modules.mk) = dacb14e7962ebaa3964943fdcfb4db1289fc6e87
SHA1 (baresip-0.5.3.tar.gz) = 2a2ac364b55315e92f0ea45c97a1b1bd819843f1
RMD160 (baresip-0.5.3.tar.gz) = cb6883d930f12feebc3c00a3cb6d0c9f507faf1a
SHA512 (baresip-0.5.3.tar.gz) = 01c44062a352561cab6487a37402f9612223a7d163fcb8e84087b85f252770b1f4db15037694437a061cd1a22a7eefc3180b0e00c30eb8684148d11e9de122b6
Size (baresip-0.5.3.tar.gz) = 491077 bytes
SHA1 (patch-mk_modules.mk) = 12c295c1765f721e2a44d0d6835c2474ebc82e78
SHA1 (patch-modules_ilbc_ilbc.c) = b19d181f41d84ad5cdc2a6e93c5004dab25e6c32
SHA1 (patch-modules_v4l2_v4l2.c) = 71ba2d1e5c8ba61eb011bd2b6b9e0d9cdaec5797

View File

@ -1,14 +1,10 @@
$NetBSD$
Enable the experimental jack module. This provides an alternative for
audio on systems where the full duplex oss/portaudio (opened separately
for read and write) gives problems.
Make sndio available for non-OpenBSD.
--- mk/modules.mk.orig 2016-07-22 19:17:45.000000000 +0000
--- mk/modules.mk.orig 2017-05-14 06:58:08.000000000 +0000
+++ mk/modules.mk
@@ -241,7 +241,7 @@ USE_WINWAVE := yes
@@ -251,7 +251,7 @@ USE_WINWAVE := yes
MODULES += wincons
endif
ifeq ($(OS),openbsd)
@ -17,17 +13,7 @@ Make sndio available for non-OpenBSD.
endif
ifeq ($(OS),freebsd)
MODULES += dtmfio
@@ -355,6 +355,9 @@ endif
ifneq ($(USE_ISAC),)
MODULES += isac
endif
+ifneq ($(USE_JACK),)
+MODULES += jack
+endif
ifneq ($(USE_L16),)
MODULES += l16
endif
@@ -394,6 +397,9 @@ endif
@@ -408,6 +408,9 @@ endif
ifneq ($(USE_SNDFILE),)
MODULES += sndfile
endif