elfhash-git: Import elfhash-master as wip/elfhash-git

elfhash is a utility to manipulate hash tables in ELF files.
This commit is contained in:
Dean Matzkov 2017-10-10 21:27:20 -06:00
parent 93fb10a077
commit 714b6a2d00
6 changed files with 62 additions and 0 deletions

1
elfhash-git/DESCR Normal file
View File

@ -0,0 +1 @@
elfhash is a utility to manipulate hash tables in ELF files.

25
elfhash-git/Makefile Normal file
View File

@ -0,0 +1,25 @@
# $NetBSD$
PKGNAME= elfhash-0.1
CATEGORIES= devel
GIT_REPOSITORIES= elfhash
GIT_REPO.elfhash= git://github.com/cjacker/elfhash
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/cjacker/elfhash
COMMENT= Manipulate Hash tables in ELF files
LICENSE= gnu-gpl-v3
WRKSRC= ${WRKDIR}/elfhash
USE_LANGUAGES= c
INSTALLATION_DIRS+= bin
INSTALLATION_DIRS+= share/doc/${PKGBASE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/elfhash ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/README.md ${DESTDIR}${PREFIX}/share/doc/${PKGBASE}
.include "../../wip/mk/git-package.mk"
.include "../../mk/bsd.pkg.mk"

3
elfhash-git/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD$
bin/elfhash
share/doc/elfhash/README.md

14
elfhash-git/TODO Normal file
View File

@ -0,0 +1,14 @@
- Fails to build on macOS, due to not finding features.h header.
For now, it's commented-out via a patch until there's a better
solution.
- We should probably use the system's elf.h, if possible.
- The author doesn't seem to use any licenses. However, he does
have some GPL'd stuff in his repo, like elf.h for example.
So for now we'll add GPL3 to LICENSE, and perhaps can nuke this
TODO item at a later when we're certain we have it right.
- elfhash's Makefile hard-codes gcc and CFLAGS, and as such, doesn't
honor the $(CC) and $(CFLAGS) variables passed by pkgsrc.

3
elfhash-git/distinfo Normal file
View File

@ -0,0 +1,3 @@
$NetBSD$
SHA1 (patch-elf.h) = d274ace60a671b3bc2734de9114137b54e44f16e

View File

@ -0,0 +1,16 @@
$NetBSD$
On some systems (macOS, for example), features.h is not available. This is a
quick hack to get elfhash to build on those platforms.
--- elf.h.orig 2017-10-06 18:52:37.000000000 +0000
+++ elf.h
@@ -19,7 +19,7 @@
#ifndef _ELF_H
#define _ELF_H 1
-#include <features.h>
+//#include <features.h>
__BEGIN_DECLS