pan2-git: adjust PLIST and patches.

This commit is contained in:
Olaf Seibert 2020-12-24 12:43:50 +01:00
parent 9500d9b310
commit 73f17cbdfb
3 changed files with 1 additions and 19 deletions

View File

@ -31,6 +31,7 @@ share/locale/ga/LC_MESSAGES/pan.mo
share/locale/gl/LC_MESSAGES/pan.mo
share/locale/hr/LC_MESSAGES/pan.mo
share/locale/hu/LC_MESSAGES/pan.mo
share/locale/id/LC_MESSAGES/pan.mo
share/locale/it/LC_MESSAGES/pan.mo
share/locale/ja/LC_MESSAGES/pan.mo
share/locale/ko/LC_MESSAGES/pan.mo

View File

@ -3,4 +3,3 @@ $NetBSD$
SHA1 (patch-configure.ac) = e71544a02c6c3fa09fe79f78eb39ebd31e0d8a3c
SHA1 (patch-filenames) = bd7c49c59be49ba899b1c426aa69968c2443a12c
SHA1 (patch-pan-general-e-util.cc) = c252f074b139b100f3f879261b1ba894b5f3350c
SHA1 (patch-pan_usenet-utils_mime-utils.cc) = 072d8ccd5b92af252fd4a1b7d1ef121b0b517f85

View File

@ -1,18 +0,0 @@
$NetBSD$
iconv prototype was changed to what non-NetBSD has.
--- pan/usenet-utils/mime-utils.cc.orig 2020-04-15 08:49:36.084023027 +0000
+++ pan/usenet-utils/mime-utils.cc
@@ -77,11 +77,7 @@ namespace pan
outbuf = out + converted;
outleft = outlen - converted;
-#if defined(__NetBSD__)
- converted = iconv (cd, &inbuf, &inleft, &outbuf, &outleft);
-#else
converted = iconv (cd, (char **) &inbuf, &inleft, &outbuf, &outleft);
-#endif
if (converted != (size_t) -1 && errno == 0) {
/*