weewx: Update to 4.1.1

packaging notes: Probably this can use python3, but that has not been
tested.

4.1.1 06/01/2020

Fixed problem that caused wind speed to be reported to AWEKAS in m/s instead
of km/h.

Fixed problem that caused FTP attempts not to be retried.

Fixed problem that caused monthly and yearly summaries to appear only
sporadically.

Fixed problem when using the ultimeter driver under Python 2.

Fixed problem when using the ws1 driver under Python 2.

Fixed problem that prevented remote directories from being created by FTP.

New strategy for calculating system uptime under Python 3. Revisits
issue #428. Alternative to PR #561.

4.1.0 05/25/2020

Archive records emitted by the Vantage driver now include the number of wind
samples per archive interval in field wind_samples.

wee_import can now import WeatherCat monthly .cat files.

Changed the logging configuration dictionary to match the Python documents.
Thanks to user Graham for figuring this out!

Fixed problem that prevented ws1 driver from working under Python 3. PR #556.

Eliminate use of logging in wee_config, allowing it to be used for installs
without syslog.

Allow expressions to be used as a datatype when plotting.

Added option 'reuse_ssl' to FTP. This activates a workaround for a bug in the
Python ftp library that causes long-lived connections to get closed prematurely.
Works only with Python 3.6 and greater.

The cc3000 driver will automatically reboot the hardware if it stops sending
observations. PR #549.

Install using setup.py forgot to set WEEWX_ROOT when installing in non-standard
places. Fixes issue #546.

Fixed bug in ws28xx driver that prevented it from running under Python 3.
Fixes issue #543.

Changed query strategy for calculating min and max wind vectors, which
should result in much faster plot generation.

Fixed bug in wmr9x8 driver that prevented it from running under Python 3.

Fixed several bugs in the te923 driver that prevented it from running under
Python 3.

Added a logging handler for rotating files. See https://bit.ly/2StYSHb for how
to use it. It is the default for MacOS.

More information if an exception is raised while querying for vantage hardware
type.

wunderfixer: fixed problem under Python 3 where response was not converted to
str before attempting to parse the JSON. Option --simulate now requires api_key
and password, so it can hit the WU.

Fixed problem in te923 driver under Python 3 that caused it to crash.

4.0.0 04/30/2020

Ported to Python 3. WeeWX should now run under Python 3.5 and greater, as well
as Python 2.7. Support for Python 2.5 and 2.6 has been dropped.

New facility for creating new user-defined derived types. See the Wiki article
https://github.com/weewx/weewx/wiki/WeeWX-V4-user-defined-types

WeeWX now uses the Python 'logging' facility. This means log, formats, and other
things can now be customized. Fixes issue #353.

Strings appearing in the data stream no longer cause a TypeError if they can be
converted to a number.

Strings can now be accumulated and extracted in the accumulators, making it
possible to include them in the database schemas.

The utility wee_reports now loads services, allowing it to use user-supplied
extensions. Fixes issue #95.

New default schema ("wview_extended") that offers many new types. The old schema
is still supported. Fixes issue #115.

Optional, more flexible, way of specifying schemas for the daily summaries. The
old way is still supported.

The install process now offers to register a user's station with weewx.com.

The package MySQL-python, which we used previously, is not always available on
Python 3. Ported the MySQL code to use the package mysqlclient as an
alternative.

The default for WOW no longer throttles posting frequency (the default used to
be no more than once every 15 minutes).

Added new aggregate types minsum, minsumtime, sum_le. PR #382.

Unit group group_distance is now a first-class group.

Added new tag $python_version.

Ported to Python2-PyMySQL package on OpenSUSE.

Added new aggregation types 'first' (similar to 'last'), 'diff' (the difference
between last and first value in the aggregation interval), and 'tderiv' (the
difference divided by the time difference).

Created new unit group 'group_energy2', defined as watt-seconds. Useful for high
resolution energy monitors.

An observation type known to the system, but not in a record, will now return a
proper ValueTuple, rather than UnknownType.

Type "stormStart" was added to the unit system. Fixes issue #380.

Added new aggregation type 'growdeg'. Similar to 'heatdeg', or 'cooldeg', it
measures growing degree-days. Basically, cooldeg, but with a different base.
Fixes issue #367. Thanks to user Clay Jackson for guidance!

Ported OS uptime to OpenBSD. Fixes issue #428. Thanks to user Jeff Ross!

Catch SSL certificate errors in uploaders. Retry after an hour. Fixes issue

Wunderfixer has been ported to the new WU API. This API requires an API key,
which you can get from the WU. Put it in weewx.conf. Added option --upload-only.
Thanks to user Leon Shaner! Fixes issues #414 and #445.

Wee_import can now import Weather Display monthly log files.

Fixed problem where sub-sections DegreeDays and Trend were located under the
wrong weewx.conf section. Fixes issue #432. Thanks to user mph for spotting
this!

Added new parameters to the Weather Underground uploader. Fixes issue #435.

Added new air quality types pm1_0, pm2_5, and pm10_0 to the unit system. Added
new unit microgram_per_meter_cubed. Added new unit group, group_concentration.

Plist for the Mac launcher now includes a log file for stderr.

Night-day transition in plots now uses shortest travel distance around color
wheel to minimize extra colors. Fixes issue #457. Thanks to user Alex Edwards!

Fixed bug that causes plots to fail when both min and max are zero. Fixes issue

Fixed problem with sqlite driver that can lead to memory growth. See PR #467.
Thanks to user Rich Bell!

Fixed bug that caused windrun to be calculated wrongly under METRICWX unit
system. Fixes issue #452.

If a bad value of 'interval' is encountered in a record, the program will simply
ignore it, rather than stopping. Address issue #375.

Change in how the archive timespan is calculated in the engine. This allows
oddball archive intervals. Fixes issue #469.

NOAA reports are now more tolerant of missing data. Fixes issue #300.

Use of strftime() date and time format codes in template file names is now
supported as an alternative to the legacy 'YYYY', 'MM' and 'DD'. The legacy
codes continue to be supported for backwards compatibility. Fixes issue #415.

New --calc-missing action added to wee_database to calculate and store derived
observations.

wee_import now calculates missing derived observations once all imported data
has been saved to archive. Fixes issue #443.

wee_import now tolerates periods that contain no source data. Fixes issue #499.

wee_import now accepts strings representing cardinal, intercardinal and
secondary intercardinal directions in CSV imports. Partially fixes issue #238.

The field delimiter character may now be defined for wee_import CSV imports.

Ignore historical records if the timestamp is in the future.

Can now recover from MariaDB-specific database connection error 1927.

Changed the name of the unit "litre" to "liter", making its spelling more
consistent with "meter". The spelling "litre" is still accepted.

Systemd type changed from "simple" to "forking". Thanks to user Jaap de Munck
for figuring this one out!

The configuration file is now an optional argument when running weewxd directly.
This means most users will be able to use the simple command line 'sudo weewxd'.

Use correct log path for netbsd and openbsd in logger setup.

StdWXCalculate no longer calculates anything by default. Instead, types to be
calculated must be listed in weewx.conf. See the Upgrade Guide.

setup.py install no longer saves the old 'bin' subdirectory. Instead, it simply
overwrites it.
This commit is contained in:
Greg Troxel 2020-07-14 17:46:58 -04:00
parent 3bfdd58e61
commit 78b7159ad8
4 changed files with 76 additions and 41 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.24 2019/04/26 14:12:35 maya Exp $
DISTNAME= weewx-3.9.2
DISTNAME= weewx-4.1.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES= misc
MASTER_SITES= http://weewx.com/downloads/
@ -16,7 +16,8 @@ LICENSE= gnu-gpl-v3
USE_LANGUAGES=
PYTHON_VERSIONS_ACCEPTED= 27 # not yet ported as of 3.9.2
# \todo Allow python 3
PYTHON_VERSIONS_ACCEPTED= 27 # not yet tested
SUBST_CLASSES+= paths
SUBST_MESSAGE.paths= Substituting pkgsrc paths

View File

@ -1,6 +1,6 @@
@comment $NetBSD$
weewx/LICENSE.txt
weewx/README
weewx/README.md
weewx/bin/daemon.py
weewx/bin/daemon.pyc
weewx/bin/daemon.pyo
@ -10,6 +10,12 @@ weewx/bin/schemas/__init__.pyo
weewx/bin/schemas/wview.py
weewx/bin/schemas/wview.pyc
weewx/bin/schemas/wview.pyo
weewx/bin/schemas/wview_extended.py
weewx/bin/schemas/wview_extended.pyc
weewx/bin/schemas/wview_extended.pyo
weewx/bin/six.py
weewx/bin/six.pyc
weewx/bin/six.pyo
weewx/bin/user/__init__.py
weewx/bin/user/__init__.pyc
weewx/bin/user/__init__.pyo
@ -53,6 +59,12 @@ weewx/bin/weeimport/csvimport.pyo
weewx/bin/weeimport/cumulusimport.py
weewx/bin/weeimport/cumulusimport.pyc
weewx/bin/weeimport/cumulusimport.pyo
weewx/bin/weeimport/wdimport.py
weewx/bin/weeimport/wdimport.pyc
weewx/bin/weeimport/wdimport.pyo
weewx/bin/weeimport/weathercatimport.py
weewx/bin/weeimport/weathercatimport.pyc
weewx/bin/weeimport/weathercatimport.pyo
weewx/bin/weeimport/weeimport.py
weewx/bin/weeimport/weeimport.pyc
weewx/bin/weeimport/weeimport.pyo
@ -83,9 +95,18 @@ weewx/bin/weeutil/config.pyo
weewx/bin/weeutil/ftpupload.py
weewx/bin/weeutil/ftpupload.pyc
weewx/bin/weeutil/ftpupload.pyo
weewx/bin/weeutil/log.py
weewx/bin/weeutil/log.pyc
weewx/bin/weeutil/log.pyo
weewx/bin/weeutil/logger.py
weewx/bin/weeutil/logger.pyc
weewx/bin/weeutil/logger.pyo
weewx/bin/weeutil/rsyncupload.py
weewx/bin/weeutil/rsyncupload.pyc
weewx/bin/weeutil/rsyncupload.pyo
weewx/bin/weeutil/timediff.py
weewx/bin/weeutil/timediff.pyc
weewx/bin/weeutil/timediff.pyo
weewx/bin/weeutil/weeutil.py
weewx/bin/weeutil/weeutil.pyc
weewx/bin/weeutil/weeutil.pyo
@ -162,6 +183,9 @@ weewx/bin/weewx/filegenerator.pyo
weewx/bin/weewx/imagegenerator.py
weewx/bin/weewx/imagegenerator.pyc
weewx/bin/weewx/imagegenerator.pyo
weewx/bin/weewx/junk.py
weewx/bin/weewx/junk.pyc
weewx/bin/weewx/junk.pyo
weewx/bin/weewx/manager.py
weewx/bin/weewx/manager.pyc
weewx/bin/weewx/manager.pyo
@ -198,29 +222,16 @@ weewx/bin/weewx/wxmanager.pyo
weewx/bin/weewx/wxservices.py
weewx/bin/weewx/wxservices.pyc
weewx/bin/weewx/wxservices.pyo
weewx/bin/weewx/xtypes.py
weewx/bin/weewx/xtypes.pyc
weewx/bin/weewx/xtypes.pyo
weewx/bin/weewxd
weewx/bin/wunderfixer
weewx/docs/accum.md
weewx/docs/changes.txt
weewx/docs/copyright.htm
weewx/docs/css/jquery.tocify.css
weewx/docs/css/ui-lightness/images/animated-overlay.gif
weewx/docs/css/ui-lightness/images/ui-bg_diagonals-thick_18_b81900_40x40.png
weewx/docs/css/ui-lightness/images/ui-bg_diagonals-thick_20_666666_40x40.png
weewx/docs/css/ui-lightness/images/ui-bg_flat_10_000000_40x100.png
weewx/docs/css/ui-lightness/images/ui-bg_glass_100_f6f6f6_1x400.png
weewx/docs/css/ui-lightness/images/ui-bg_glass_100_fdf5ce_1x400.png
weewx/docs/css/ui-lightness/images/ui-bg_glass_65_ffffff_1x400.png
weewx/docs/css/ui-lightness/images/ui-bg_gloss-wave_35_f6a828_500x100.png
weewx/docs/css/ui-lightness/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
weewx/docs/css/ui-lightness/images/ui-bg_highlight-soft_75_ffe45c_1x100.png
weewx/docs/css/ui-lightness/images/ui-icons_222222_256x240.png
weewx/docs/css/ui-lightness/images/ui-icons_228ef1_256x240.png
weewx/docs/css/ui-lightness/images/ui-icons_ef8c08_256x240.png
weewx/docs/css/ui-lightness/images/ui-icons_ffd27a_256x240.png
weewx/docs/css/ui-lightness/images/ui-icons_ffffff_256x240.png
weewx/docs/css/ui-lightness/jquery-ui-1.10.4.custom.css
weewx/docs/css/ui-lightness/jquery-ui-1.10.4.custom.min.css
weewx/docs/css/weewx_docs.css
weewx/docs/css/tocbot-4.3.1.css
weewx/docs/css/weewx_ui.css
weewx/docs/customizing.htm
weewx/docs/debian.htm
weewx/docs/devnotes.htm
@ -232,6 +243,7 @@ weewx/docs/images/day-gap-showing.png
weewx/docs/images/daycompare.png
weewx/docs/images/daytemp_with_avg.png
weewx/docs/images/daywindvec.png
weewx/docs/images/favicon.png
weewx/docs/images/ferrites.jpg
weewx/docs/images/funky_degree.png
weewx/docs/images/image_parts.png
@ -243,19 +255,24 @@ weewx/docs/images/logo-fedora.png
weewx/docs/images/logo-linux.png
weewx/docs/images/logo-mint.png
weewx/docs/images/logo-opensuse.png
weewx/docs/images/logo-pypi.svg
weewx/docs/images/logo-redhat.png
weewx/docs/images/logo-rpi.png
weewx/docs/images/logo-suse.png
weewx/docs/images/logo-ubuntu.png
weewx/docs/images/logo-weewx.png
weewx/docs/images/pipeline.png
weewx/docs/images/sample_monthrain.png
weewx/docs/images/sample_monthtempdew.png
weewx/docs/images/weekgustoverlay.png
weewx/docs/images/weektempdew.png
weewx/docs/images/yearhilow.png
weewx/docs/js/jquery-1.11.1.min.js
weewx/docs/js/jquery-ui-1.10.4.custom.min.js
weewx/docs/js/jquery.tocify-1.9.0.js
weewx/docs/js/jquery.tocify-1.9.0.min.js
weewx/docs/js/cash.js
weewx/docs/js/cash.min.js
weewx/docs/js/tocbot-4.3.1.js
weewx/docs/js/tocbot-4.3.1.min.js
weewx/docs/js/weewx.js
weewx/docs/logging.md
weewx/docs/macos.htm
weewx/docs/readme.htm
weewx/docs/redhat.htm
@ -264,6 +281,7 @@ weewx/docs/suse.htm
weewx/docs/upgrading.htm
weewx/docs/usersguide.htm
weewx/docs/utilities.htm
weewx/docs/xtypes.md
weewx/examples/alarm.py
weewx/examples/basic/changelog
weewx/examples/basic/install.py
@ -300,8 +318,8 @@ weewx/skins/Mobile/index.html.tmpl
weewx/skins/Mobile/mobile.css
weewx/skins/Mobile/skin.conf
weewx/skins/Rsync/skin.conf
weewx/skins/Seasons/NOAA/NOAA-YYYY-MM.txt.tmpl
weewx/skins/Seasons/NOAA/NOAA-YYYY.txt.tmpl
weewx/skins/Seasons/NOAA/NOAA-%Y-%m.txt.tmpl
weewx/skins/Seasons/NOAA/NOAA-%Y.txt.tmpl
weewx/skins/Seasons/about.inc
weewx/skins/Seasons/analytics.inc
weewx/skins/Seasons/celestial.html.tmpl
@ -312,6 +330,7 @@ weewx/skins/Seasons/font/OpenSans-Bold.ttf
weewx/skins/Seasons/font/OpenSans-Regular.ttf
weewx/skins/Seasons/font/OpenSans.woff
weewx/skins/Seasons/font/OpenSans.woff2
weewx/skins/Seasons/font/license.txt
weewx/skins/Seasons/hilo.inc
weewx/skins/Seasons/identifier.inc
weewx/skins/Seasons/index.html.tmpl
@ -342,8 +361,8 @@ weewx/skins/Smartphone/rain.html.tmpl
weewx/skins/Smartphone/skin.conf
weewx/skins/Smartphone/temp.html.tmpl
weewx/skins/Smartphone/wind.html.tmpl
weewx/skins/Standard/NOAA/NOAA-YYYY-MM.txt.tmpl
weewx/skins/Standard/NOAA/NOAA-YYYY.txt.tmpl
weewx/skins/Standard/NOAA/NOAA-%Y-%m.txt.tmpl
weewx/skins/Standard/NOAA/NOAA-%Y.txt.tmpl
weewx/skins/Standard/RSS/weewx_rss.xml.tmpl
weewx/skins/Standard/backgrounds/band.gif
weewx/skins/Standard/backgrounds/butterfly.jpg
@ -373,9 +392,13 @@ weewx/skins/Standard/week.html.tmpl
weewx/skins/Standard/weewx.css
weewx/skins/Standard/year.html.tmpl
weewx/util/apache/conf.d/weewx.conf
weewx/util/default/weewx
weewx/util/import/csv-example.conf
weewx/util/import/cumulus-example.conf
weewx/util/import/wd-example.conf
weewx/util/import/weathercat-example.conf
weewx/util/import/wu-example.conf
weewx/util/init.d/weewx-multi
weewx/util/init.d/weewx.bsd
weewx/util/init.d/weewx.debian
weewx/util/init.d/weewx.lsb
@ -388,6 +411,15 @@ weewx/util/logwatch/conf/services/weewx.conf
weewx/util/logwatch/scripts/services/weewx
weewx/util/newsyslog.d/weewx.conf
weewx/util/rsyslog.d/weewx.conf
weewx/util/scripts/wee_config
weewx/util/scripts/wee_database
weewx/util/scripts/wee_debug
weewx/util/scripts/wee_device
weewx/util/scripts/wee_extension
weewx/util/scripts/wee_import
weewx/util/scripts/wee_reports
weewx/util/scripts/weewxd
weewx/util/scripts/wunderfixer
weewx/util/solaris/weewx-smf.xml
weewx/util/systemd/weewx.service
weewx/util/udev/rules.d/acurite.rules
@ -395,8 +427,10 @@ weewx/util/udev/rules.d/cc3000.rules
weewx/util/udev/rules.d/fousb.rules
weewx/util/udev/rules.d/te923.rules
weewx/util/udev/rules.d/vantage.rules
weewx/util/udev/rules.d/weewx.rules
weewx/util/udev/rules.d/wmr100.rules
weewx/util/udev/rules.d/wmr200.rules
weewx/util/udev/rules.d/wmr300.rules
weewx/util/udev/rules.d/ws28xx.rules
weewx/weewx.conf.${PKGVERSION}
weewx/weewx.conf.DIST

View File

@ -1,8 +1,8 @@
$NetBSD$
SHA1 (weewx-3.9.2.tar.gz) = c4feacb728b97630ec6c97a008eecd0263a40cc4
RMD160 (weewx-3.9.2.tar.gz) = 651620357a75e6beaa848560b28476610682815a
SHA512 (weewx-3.9.2.tar.gz) = 63abebe15a067f430aaca33063588df116c100a7f232a7e14c5a70eae6c0d2d4e33081ec2c1dbd539ecb83b94396a56b218288f6076b4aa615c0827f69cbc9ad
Size (weewx-3.9.2.tar.gz) = 1554019 bytes
SHA1 (weewx-4.1.1.tar.gz) = e7743aa55cc46ca3c058acdb7b1ac8a11cc8581c
RMD160 (weewx-4.1.1.tar.gz) = 7b2d310484943100a0b47811f7ba51900a7c3972
SHA512 (weewx-4.1.1.tar.gz) = 900ca21954eca2f5923c63c1c1959ca0a1cff99caf79ddf1945757211cf6117b61b7244346d0c86c332fe9e61515e4a8f149292986f6af91ce879272dacf7a60
Size (weewx-4.1.1.tar.gz) = 1586240 bytes
SHA1 (patch-setup.cfg) = ab4c53994fd3046351dc76a4690c37ae42b0fbed
SHA1 (patch-setup.py) = 34dd25522521fc1a384238a99455a68b3ea74fd6
SHA1 (patch-setup.py) = 82a138c526de031e3cb7f6ea655a7969f81e97c5

View File

@ -3,14 +3,14 @@ $NetBSD$
Disable interactive install. Not yet addressed upstream; the issue of
compatibility with packaging systems is quite large.
--- setup.py.orig 2019-07-28 12:28:27.984188292 +0000
--- setup.py.orig 2020-05-30 23:41:13.000000000 +0000
+++ setup.py
@@ -72,7 +72,7 @@ class weewx_install(install):
@@ -55,7 +55,7 @@ class weewx_install(install):
def initialize_options(self, *args, **kwargs):
install.initialize_options(self, *args, **kwargs)
- self.no_prompt = None
+ self.no_prompt = True
install.initialize_options(self, *args, **kwargs)
- self.no_prompt = None
+ self.no_prompt = True
def finalize_options(self):
install.finalize_options(self)
# Call my superclass's version